Huawei E160 Mobile Broadband Modem [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Re: Huawei E160 Mobile Broadband Modem [Solved]

Postby Fitzcarraldo » Fri Oct 22, 2010 23:06

My pleasure; glad you got your modem working. No need to create another thread: by posting your model number here, hopefully the Forum Search facility and/or Google will find this thread if anyone searches for that model number. So it's good that you posted. I see it's your first post, so welcome to the SL (Sabayon Linux) Forums.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Huawei E160 Mobile Broadband Modem [Solved]

Postby magesha » Sat Oct 23, 2010 14:50

Fitzcarraldo wrote:My pleasure; glad you got your modem working. No need to create another thread: by posting your model number here, hopefully the Forum Search facility and/or Google will find this thread if anyone searches for that model number. So it's good that you posted. I see it's your first post, so welcome to the SL (Sabayon Linux) Forums.



Cool! Thanks man! I kind of have a problem now, though. After I started Entropy and did all the updates (I actually lost the connection midway through so it is not completed), I see that the networkmanager got rolled back to r1 instead of the r6. Also, my updating stopped midway (I am guessing because of the connection breakage due to the change of networkmanager package). - I was running the update while being connected via by mobile network, as my other connection is borrowed and has limited bandwidth.

Is there a way to prevent this? Should I avoid doing "Update all" on Entropy Store? (the GUI updater - Sulfur)

Thanks,
Magesha

EDIT: I reran the commands and hence was able to "fix" it again, and once I rebooted, the mobile network works now. But, the "update" to r1 from r6 still shows up when I run Sulfur. Is there any way to keep it from updating? Thanks!
magesha
Young Hen
 
Posts: 21
Joined: Fri Oct 22, 2010 21:09

Re: Huawei E160 Mobile Broadband Modem [Solved]

Postby Fitzcarraldo » Sat Oct 23, 2010 15:15

Add the following line to the file/etc/entropy/packages/package.mask:

Code: Select all
<net-misc/networkmanager-0.8-r6

and enable the option ignore-spm-downgrades in the file /etc/entropy/client.conf:

Code: Select all
ignore-spm-downgrades|enable


For more information on mixing Entropy and Portage, see the thread entropy in gentoo.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Huawei E160 Mobile Broadband Modem [Solved]

Postby _cnfss_ » Sat Oct 23, 2010 20:59

I didn't wanted to mess with Portage and Network Manager, so I found another solution to the Huawei Mobile Modem problem, (Mine is E176, but I think it should work with the others).

1)If it isn't installed:

Code: Select all
# equo install net-dialup/wvdial


2) Insert the modem and wait a bit, until it gets recognized.
3) Run

Code: Select all
# wvdialconf


This is what the output looks like:

Code: Select all
# wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0   S1   S2   S3   
WvModem<*1>: Cannot get information for serial port.
ttyUSB0<*1>: ATQ0 V1 E1 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 Z -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyUSB0<*1>: Modem Identifier: ATI -- Manufacturer: huawei
ttyUSB0<*1>: Speed 9600: AT -- OK
ttyUSB0<*1>: Max speed is 9600; that should be safe.
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
WvModem<*1>: Cannot get information for serial port.
ttyUSB1<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyUSB1<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 9600 baud
ttyUSB1<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
WvModem<*1>: Cannot get information for serial port.
ttyUSB2<*1>: ATQ0 V1 E1 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 Z -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyUSB2<*1>: Modem Identifier: ATI -- Manufacturer: huawei
ttyUSB2<*1>: Speed 9600: AT -- OK
ttyUSB2<*1>: Max speed is 9600; that should be safe.
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found a modem on /dev/ttyUSB0.
/etc/wvdial.conf<Warn>: Can't open '/etc/wvdial.conf' for reading: No such file or directory
/etc/wvdial.conf<Warn>: ...starting with blank configuration.
Modem configuration written to /etc/wvdial.conf.
ttyUSB0<Info>: Speed 9600; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
ttyUSB2<Info>: Speed 9600; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"


The file should look like these now:

Code: Select all
# cat /etc/wvdial.conf

[Dialer Defaults]
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
; Phone = <Target Phone Number>
ISDN = 0
; Username = <Your Login Name>
Init1 = ATZ
; Password = <Your Password>
Modem = /dev/ttyUSB0
Baud = 9600



As you can see, before "Phone", "Username" and "Password" there is a ";". (Those are commented lines).
So, edit the file, and delete the ";", put your real data (usually phone is *99# and user is [email protected]) and add to the end 2 more lines: "Stupid Mode = 1" and "Dial Command = ATDT".

So at the end the file looks like this:

Code: Select all
# cat /etc/wvdial.conf

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Phone = *99#
ISDN = 0
Password = myPassWord
Username = [email protected]
Modem = /dev/ttyUSB0
Baud = 9600
Stupid Mode = 1
Dial Command = ATDT


The, all you need to do to connect your PC to Internet is:

Code: Select all
# wvdial


So, it's another choice, without the touch of Portage :)
"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former."
"Sólo dos cosas son infinitas, el universo y la estupidez humana, y no estoy seguro acerca de la primera."
- Albert Einstein
_cnfss_
Growing Hen
 
Posts: 158
Joined: Wed Jan 20, 2010 17:09

Re: Huawei E160 Mobile Broadband Modem [Solved]

Postby magesha » Sun Oct 24, 2010 15:20

_cnfss_ wrote:I didn't wanted to mess with Portage and Network Manager, so I found another solution to the Huawei Mobile Modem problem, (Mine is E176, but I think it should work with the others)
......
The, all you need to do to connect your PC to Internet is:

Code: Select all
# wvdial


So, it's another choice, without the touch of Portage :)


Thanks _cnfss_. I have used wvdial, then gnome-ppp and finally kppp in other distros I used before (ubuntu, kubuntu, pclinuxos etc). But, I thought having it in the notification and to be able to connect automatically is worth doing the one-time setup that it takes, as long as someone can vouch for its safety.

It is really cool that you can just plug in your modem and start your system in linux and have it all connect automaticallly, whereas under Windows, for example, you have to start the connection and make it dial the number and after 25 clicks it connects. It's a matter of personal taste, I guess :D

PS: I did your fix about the masking Fitzcarraldo, and that works too. I like how Sabayon doesn't conceal the system innards while making it easy to learn so that you can learn about the system as you do things to fix it.
magesha
Young Hen
 
Posts: 21
Joined: Fri Oct 22, 2010 21:09

Re: Huawei E160 Mobile Broadband Modem [Solved]

Postby vaettchen » Sat Dec 18, 2010 8:56

There is downside to that, though: A regular system upgrade actually downgrades networkmanager and a lot of other stuff, see here:

Code: Select all
>>  ## [D] [spm-db->sabayonlinux.org] net-misc/networkmanager-0.8-r1|3   [0.8.2-r2|9999]


or my whole story here:

Code: Select all
augeatur rainer # equo upgrade
>>  @@ Calculating System Updates...
>>  @@ Calculating dependencies ...
>>  ## [D] [spm-db->sabayonlinux.org] app-admin/eselect-cblas-0.1|1   [0.1|9999]
>>  ## [U] [spm-db->sabayonlinux.org] sci-chemistry/bodr-9-r1|0   [8|9999]
>>  ## [U] [spm-db->sabayonlinux.org] app-text/wgetpaste-2.18|0   [2.16|9999]
>>  ## [D] [spm-db->sabayonlinux.org] dev-tex/xcolor-2.11|0   [2.11|9999]
>>  ## [D] [spm-db->sabayonlinux.org] dev-tex/pgf-2.00|1   [2.10|9999]
>>  ## [D] [spm-db->sabayonlinux.org] dev-tex/latex-beamer-3.10|0   [3.10-r1|9999]
>>  ## [D] [spm-db->sabayonlinux.org] sci-chemistry/openbabel-2.2.3|0   [2.2.3|9999]
>>  ## [U] [spm-db->sabayonlinux.org] dev-texlive/texlive-genericrecommended-2010|0   [2008|9999]
>>  ## [U] [spm-db->sabayonlinux.org] dev-texlive/texlive-texinfo-2010|0   [2008|9999]
>>  ## [D] [spm-db->sabayonlinux.org] virtual/texi2dvi-0|0   [0|9999]
>>  ## [U] [spm-db->sabayonlinux.org] dev-cpp/eigen-2.0.15|0   [2.0.9|9999]
>>  ## [D] [spm-db->sabayonlinux.org] app-office/koffice-data-2.2.2|0   [2.2.2|9999]
>>  ## [D] [spm-db->sabayonlinux.org] app-office/koffice-libs-2.2.2|0   [2.2.2|9999]
>>  ## [D] [spm-db->sabayonlinux.org] app-office/kchart-2.2.2|0   [2.2.2|9999]
>>  ## [U] [spm-db->sabayonlinux.org] app-office/kplato-2.2.2|0   [2.1.0|9999]
>>  ## [U] [spm-db->sabayonlinux.org] sci-mathematics/gmm-4.1|0   [3.1|9999]
>>  ## [D] [spm-db->sabayonlinux.org] net-misc/networkmanager-0.8-r1|3   [0.8.2-r2|9999]
>>  ## [D] [spm-db->sabayonlinux.org] dev-perl/DelimMatch-1.06|3   [1.06|9999]
>>  ## [D] [spm-db->sabayonlinux.org] dev-util/libconf-0.42.10-r2|2   [0.42.10-r2|9999]
>>  ## [D] [spm-db->sabayonlinux.org] app-portage/flagedit-0.0.8|0   [0.0.8|9999]
>>  ## [N] [sabayonlinux.org] dev-libs/qjson-0.7.1|0
>>  ## [U] [spm-db->sabayonlinux.org] kde-misc/tellico-2.3|0   [2.0|9999]
>>  ## [U] [spm-db->sabayonlinux.org] www-client/firefox-bin-3.6.9|0   [3.6.8|9999]
>>  ## [D] [spm-db->sabayonlinux.org] app-text/scrollkeeper-9999-r1|0   [9999-r1|9999]
>>  ## [D] [spm-db->sabayonlinux.org] app-office/kpresenter-2.2.2|0   [2.2.2|9999]
>>  ## [D] [spm-db->sabayonlinux.org] app-office/kword-2.2.2|0   [2.2.2|9999]
>>  ## [D] [spm-db->sabayonlinux.org] app-office/koffice-l10n-2.2.2|0   [2.2.2|9999]
>>  ## [D] [spm-db->sabayonlinux.org] app-office/kspread-2.2.2|0   [2.2.2|9999]
>>  ## [D] [spm-db->sabayonlinux.org] app-office/kexi-2.2.2|0   [2.2.2|9999]
>>  ## [U] [spm-db->sabayonlinux.org] media-gfx/pstoedit-3.50-r1|0   [3.50|9999]
>>  ## [D] [spm-db->sabayonlinux.org] app-office/karbon-2.2.2|0   [2.2.2|9999]
>>  ## [D] [spm-db->sabayonlinux.org] app-office/krita-2.2.2|0   [2.2.2|9999]
>>  ## [D] [spm-db->sabayonlinux.org] app-office/koffice-meta-2.2.2|0   [2.2.2|9999]
>>  ## [D] [spm-db->sabayonlinux.org] app-portage/euses-2.5.7|0   [2.5.7|9999]
>>  ## [U] [spm-db->sabayonlinux.org] sys-apps/portage-2.2_rc91|0   [2.1.9.25|9999]
>>  ## [D] [spm-db->sabayonlinux.org] dev-perl/Class-MethodMaker-2.16|1   [2.16|9999]
>>  ## [D] [spm-db->sabayonlinux.org] dev-perl/Shell-EnvImporter-1.07|2   [1.07|9999]
>>  ## [D] [spm-db->sabayonlinux.org] perl-core/Term-ANSIColor-3.00|1   [3.00|9999]
>>  ## [D] [spm-db->sabayonlinux.org] virtual/perl-Term-ANSIColor-3.00|1   [3.00|9999]
>>  ## [D] [spm-db->sabayonlinux.org] dev-perl/PortageXS-0.02.10-r1|1   [0.02.10-r1|9999]
>>  ## [D] [spm-db->sabayonlinux.org] app-portage/autounmask-0.27|0   [0.27|9999]
>>  ## [U] [spm-db->sabayonlinux.org] dev-texlive/texlive-bibtexextra-2010|0   [2008|9999]
>>  ## [D] [spm-db->sabayonlinux.org] dev-lang/R-2.11.1|1   [2.12.0|9999]
>>  ## [UR] [spm-db->sabayonlinux.org] sci-libs/fftw-3.2.2|0   [3.2.2|0]
>>  ## [U] [spm-db->sabayonlinux.org] net-misc/youtube-dl-2010.11.19|0   [2010.02.13|9999]
>>  ## [UR] [spm-db->sabayonlinux.org] media-libs/glitz-0.5.6|3   [0.5.6|3]
>>  ## [D] [spm-db->sabayonlinux.org] dev-texlive/texlive-fontutils-2010|0   [2010|9999]
>>  ## [U] [spm-db->sabayonlinux.org] app-text/dvipng-1.13|1   [1.12|9999]
>>  ## [U] [spm-db->sabayonlinux.org] app-text/dvipdfmx-20100328-r1|1   [20071115-r1|9999]
>>  ## [U] [spm-db->sabayonlinux.org] app-editors/kile-2.1_beta4|0   [2.1_beta2|9999]


so that one probably faces the same problem over and over again - or keeps balancing the Gentoo and Sabayon versions manually...
vaettchen
Simple Hen
 
Posts: 97
Joined: Sun Jan 21, 2007 8:47

Re: Huawei E160 Mobile Broadband Modem [Solved]

Postby Fitzcarraldo » Sat Dec 18, 2010 10:38

Fitzcarraldo wrote:Add the following line to the file/etc/entropy/packages/package.mask:

Code: Select all
<net-misc/networkmanager-0.8-r6

and enable the option ignore-spm-downgrades in the file /etc/entropy/client.conf:

Code: Select all
ignore-spm-downgrades|enable


For more information on mixing Entropy and Portage, see the thread entropy in gentoo.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Previous

Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 2 guests

cron