log in remotely via xdmcp from windows [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

log in remotely via xdmcp from windows [Solved]

Postby jspeybro » Tue Feb 16, 2010 23:42

Hi,

Not really sure where I should post this...

I'm trying to connect from a windows machine to my sabayon linux computer using cygwin, xming or x-min, whatever works, none until now.
I followed the steps that can be found all over the internet to enable XDMCP (edit xdm-conf, Xaccess,Xservers), but whenever I try to connect to the machine, I'm just getting a plain black background, or the gray-ish X background, while I would expect the chooser so I can log in.
I checked with netstat that there is a connection, restarted xdm, restarted computer, flushed any iptables rules if there were any, disabled firewall on connecting machine, still nothing.

I tried to see if I could find anything in the logfiles, but I don't see anything about me trying to connect. Anybody knows which logfile I should be looking in?
Currently it is unclear where the problem is, so my first concern is to find out what is going wrong so I know if it's sabayon linux which is not configured correctly or the windows computer doing it wrong.

does anyone else uses such setup?

thanks in advance,

regards,
Johan

ps1, is there a reason why there are 2 xdm-config files? 1 in /etc and 1 in /etc/X11/xdm. I edited both files to be sure.
ps2, why do I see messages about restarting kdm if I did "/etc/init.d/xdm restart"? which of the 2 is actually being used?
Last edited by jspeybro on Wed Feb 17, 2010 22:24, edited 1 time in total.
jspeybro
Simple Hen
 
Posts: 48
Joined: Fri Dec 28, 2007 14:34

Re: log in remotely via xdmcp from windows

Postby Fac3kk » Wed Feb 17, 2010 7:47

You sure there is no more -nolisten tcp option for X?


I do not use xdmcp so I still have it:
Code: Select all
lapek ~ # ps -ef |grep X
root      5650  5623  6 06:58 tty7     00:03:06 /usr/bin/X -br -novtswitch -quiet -nolisten tcp :0 vt7 -auth /var/run/xauth/A:0-1WcXPP
Fac3kk
Simple Hen
 
Posts: 67
Joined: Fri Oct 16, 2009 16:26

Re: log in remotely via xdmcp from windows

Postby Thev00d00 » Wed Feb 17, 2010 16:07

Install X11vnc and run it, install vnc client on windows. Connect.
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Re: log in remotely via xdmcp from windows

Postby jspeybro » Wed Feb 17, 2010 17:20

thanks for the suggestion. vnc is good for general purpose remote management of a computer, but less practical when you actually want to really do work on the computer. I've seen both (and also remote desktop) working at work, and for me the choice is clear.

Johan
jspeybro
Simple Hen
 
Posts: 48
Joined: Fri Dec 28, 2007 14:34

Re: log in remotely via xdmcp from windows

Postby jspeybro » Wed Feb 17, 2010 19:35

Fac3kk wrote:You sure there is no more -nolisten tcp option for X?


I do not use xdmcp so I still have it:
Code: Select all
lapek ~ # ps -ef |grep X
root      5650  5623  6 06:58 tty7     00:03:06 /usr/bin/X -br -novtswitch -quiet -nolisten tcp :0 vt7 -auth /var/run/xauth/A:0-1WcXPP


yup, that's seems to be the problem.
So, my question becomes, how do I remove this -nolisten option?
I did a search in /etc, and found the -nolisten tcp paramters in /etc/X11/xinit/xserverrc and removed them after taking a backup of the file. I restarted xdm but the parameter is still there. when I ps -el|grep X.

any other place that this parameter is passed to X?

thanks,
Johan
jspeybro
Simple Hen
 
Posts: 48
Joined: Fri Dec 28, 2007 14:34

Re: log in remotely via xdmcp from windows

Postby Fac3kk » Wed Feb 17, 2010 21:35

Hi,

As far as I know that should be controlled in xdm/kdm


For xdm it would be one of xdm-config

Code: Select all
[email protected] /etc $ cat xdm-config
....
! SECURITY: do not listen for XDMCP or Chooser requests
! Comment out this line if you want to manage X terminals with xdm
DisplayManager.requestPort:     0
[email protected] /etc $


The last line should be commented out.

We however use kdm.
In the config file it should be like this

Code: Select all
[Xdmcp]
# Whether KDM should listen to incoming XDMCP requests.
# Default is true
Enable=true
# The UDP port on which KDM should listen for XDMCP requests. Do not change.
# Default is 177
#Port=177


This is where it gets strange - I can not find any config file for kdm!

Code: Select all
equo query files kdm


does not show any either besides example file in /usr/share/config/kdm/kdmrc.

At this point I dunno how to change it :<.
There is a 'login manager' section in 'system-settings' which must save kdm config somewhere but I had no luck finding it.

Most intriguing :)
Fac3kk
Simple Hen
 
Posts: 67
Joined: Fri Oct 16, 2009 16:26

Re: log in remotely via xdmcp from windows

Postby jspeybro » Wed Feb 17, 2010 21:45

ok thanks, so it's not just me :roll:

I guess my 'ps2' in the first post already indicated strange things were going on here.
I already comented the line in xdm-config so that should be ok.
I also allowed * to connect to the computer, and enabled the chooser in the xdm config files.

I also had a look at the startup scripts of xdm as I thought it would give me info on how X is started, but didn't see anything related (but have limited knowledge of startup procedures.

Anybody know what is going on with the xdm/kdm thing?

Johan
jspeybro
Simple Hen
 
Posts: 48
Joined: Fri Dec 28, 2007 14:34

Re: log in remotely via xdmcp from windows

Postby Fac3kk » Wed Feb 17, 2010 22:12

jspeybro wrote:ps2, why do I see messages about restarting kdm if I did "/etc/init.d/xdm restart"? which of the 2 is actually being used?


This has actually always been like that.

you define which display manager to use i /etc/conf.d/xdm

Code: Select all
[email protected] /etc/X11 $ cat /etc/conf.d/xdm
# We always try and start X on a static VT. The various DMs normally default
# to using VT7. If you wish to use the xdm init script, then you should ensure
# that the VT checked is the same VT your DM wants to use. We do this check to
# ensure that you have't accidently configured something to run on the VT
# in your /etc/inittab file so that you don't get a dead keyboard.
CHECKVT=7

# What display manager do you use ?  [ xdm | gdm | kdm | kdm-3.5 | kdm-4.0 | entrance ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
# KDE-specific note: kdm-3.5 and kdm-4.0 are just examples. You will find all
# possible versions by looking at the directories in /usr/kde/.
DISPLAYMANAGER="kdm"


Now we need to find kdm config files :)
Fac3kk
Simple Hen
 
Posts: 67
Joined: Fri Oct 16, 2009 16:26

Re: log in remotely via xdmcp from windows

Postby jspeybro » Wed Feb 17, 2010 22:18

ok, fixed it! :D

the trick is:
Code: Select all
locate kdmrc

That will give you a path in /usr/share/config/kdm/kdmrc
Here you just need to allow xdmcp by setting it to true and restart xdm and you're done.

regards
Johan
jspeybro
Simple Hen
 
Posts: 48
Joined: Fri Dec 28, 2007 14:34

Re: log in remotely via xdmcp from windows

Postby Fac3kk » Wed Feb 17, 2010 22:21

lul I never thought it might be the actual working file. I mentioned it few posts before but tought about it only as example :F

Mark as solved :)
Fac3kk
Simple Hen
 
Posts: 67
Joined: Fri Oct 16, 2009 16:26


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 2 guests

cron