wireless wont connect after 4.4 kde upgrade [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Re: wireless wont connect after 4.4 kde upgrade [Solved]

Postby hanz » Mon Mar 01, 2010 23:43

i obiously didn't read the answers here very good. they guys in the chat helped me. and for the stupid ones like me, again:

Code: Select all
rc-update add wicd default
rc-update del NetworkManager
/etc/init.d/NetworkManager stop
/etc/init.d/wicd start
wicd-client


i my old 4.x version i ran both at the same time. not best practice. i know :)
hanz
Baby Hen
 
Posts: 15
Joined: Tue Jul 07, 2009 11:22

Re: wireless wont connect after 4.4 kde upgrade [Solved]

Postby dave_p_b » Tue Mar 02, 2010 9:26

Hi

When you have logged in open up a konsole window and type SU, entering your root password.
If you are using WICD then try typing the following into the konsole window:
1) /etc/init.d/wicd status (you want the output to this command to say STARTED)
2) if it is not running then type /etc/init.d/wicd start
3) To get it running on boot type rc-update add wicd

Simalarly, if you are using NetworkManager, then type the following in the konsole window:
1) /etc/init.d/NetworkManager status (you want the output to this command to say STARTED)
2) if it is not running then type /etc/init.d/NetworkManager start
3) To get it running on boot type rc-update add NetworkManager

After you have performed step 3, if it's still not working then try rebooting and trying again.
Make sure your wireless password has all its capitol letters in the write place (if that applys to you)

Good luck

Dave
dave_p_b
Old Dear Hen
 
Posts: 607
Joined: Fri Dec 15, 2006 1:39
Location: Exeter, UK

Re: wireless wont connect after 4.4 kde upgrade [Solved]

Postby dave_p_b » Tue Mar 02, 2010 9:28

opps, sorry hanz

I didn't see your last post before typing that reply. I should have read the post properly :D
dave_p_b
Old Dear Hen
 
Posts: 607
Joined: Fri Dec 15, 2006 1:39
Location: Exeter, UK

Re: wireless wont connect after 4.4 kde upgrade [Solved]

Postby bevisc » Mon Mar 22, 2010 6:11

I hate to reopen this thread, but I'm fairly new to linux and even newer to sabayon. I did a world upgrade in equo and my network manager switched to wicd, which my computer isn't fond of. Unfortunately I can no longer connect to the internet, even if I directly plug in an ethernet cable, so I can't download and install knetworkmanager. Anyway I was wondering if anyone has an suggestions or if there a procedure that I am just unaware of for how to go about fixing this problem. I've tried the techniques outlined in this thread, but my lack of internet is really hindering me, an input would be greatly appreciated. Thanks.
bevisc
Baby Hen
 
Posts: 1
Joined: Mon Mar 22, 2010 5:58

Re: wireless wont connect after 4.4 kde upgrade [Solved]

Postby Fitzcarraldo » Mon Mar 22, 2010 10:41

Try removing Wicd (equo remove wicd) and see if you can launch knetworkmanger as root user in a Konsole window (or nm-applet from a Terminal window if you're a GNOME user).
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: wireless wont connect after 4.4 kde upgrade [Solved]

Postby argonaut » Sat Apr 03, 2010 20:39

Hello all - I'm also awfully sorry to post on a [Solved] topic. Apologies for this, but I am missing the final step to success!

I have a freshly installed SL 5.2 and followed the advice on this topic to get knetworkmanager work.

1. I basically uninstalled and reinstalled 2 broadcom packages since this action was much helpful in the past:
Code: Select all
 su
equo remove b43-fwcutter
equo remove b43-firmware
equo install b43-fwcutter
equo install b43-firmware


2. Only and only after that the wlan0 segment was listed with the command:
Code: Select all
 ifconfig

(before, the wlan0 was indeed listed with the ifwconfig, but modprobe-ing b43 was not yielding anything)

3. To connect wirelessly to my router I have to type, as suggested earlier on this topic:
Code: Select all
su
modprobe b43


4. Obviously, I have to redo this every time I start my laptop. Any help with how to make it automatically? Probably it's very obvious and already suggested, but I really don't get it! :?

On a different tone: guys, congratulations for Sabayon Linux. Especially 5.2 seems to be a very, very well-functioning distribution (although I disagree with the new artwork choice) and I think it is one of the best things linux has to offer nowadays.
argonaut
Simple Hen
 
Posts: 40
Joined: Tue Dec 29, 2009 16:14
Location: Helsinki

Re: wireless wont connect after 4.4 kde upgrade [Solved]

Postby Fitzcarraldo » Sun Apr 04, 2010 13:42

argonaut, if the only thing you need to do is load the b43 module at start-up, then simply add it to the file /etc/conf.d/modules:

Code: Select all
# You can define a list modules for a specific kernel version,
# a released kernel version, a main kernel version or just a list.
#modules_2_6_23_gentoo_r5="ieee1394 ohci1394"
#modules_2_6_23="tun ieee1394"
#modules_2_6="tun"
#modules="ohci1394"

# You can give modules a different name when they load - the new name
# will also be used to pick arguments below.
#modules="dummy:dummy1"

# Give the modules some arguments if needed, per version if necessary.
#module_ieee1394_args="debug"
#module_ieee1394_args_2_6_23_gentoo_r5="ieee1394 ohci1394"
#module_ieee1394_args_2_6_23="tun ieee1394"
#module_ieee1394_args_2_6="tun"

# You should consult your kernel documentation and configuration
# for a list of modules and their options.

modules="b43"


N.B. If you have to load more than one module at start-up then they all have to be declared in one line as explained in the comment header in /etc/conf.d/modules -- see my file for example:

Code: Select all
# You can define a list modules for a specific kernel version,
# a released kernel version, a main kernel version or just a list.
#modules_2_6_23_gentoo_r5="ieee1394 ohci1394"
#modules_2_6_23="tun ieee1394"
#modules_2_6="tun"
#modules="ohci1394"

# You can give modules a different name when they load - the new name
# will also be used to pick arguments below.
#modules="dummy:dummy1"

# Give the modules some arguments if needed, per version if necessary.
#module_ieee1394_args="debug"
#module_ieee1394_args_2_6_23_gentoo_r5="ieee1394 ohci1394"
#module_ieee1394_args_2_6_23="tun ieee1394"
#module_ieee1394_args_2_6="tun"

# You should consult your kernel documentation and configuration
# for a list of modules and their options.

modules="vboxdrv vboxnetflt vboxnetadp"
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: wireless wont connect after 4.4 kde upgrade [Solved]

Postby argonaut » Sun Apr 04, 2010 18:15

Yes, that worked (and it was embarrassingly simple)- thanks Fitzcarraldo :mrgreen:
Sabayon 5.4 AMD64 KDE 4.5.4
on Compaq Presario v5000us notebook
xorg-server-1.8.2, linux-sabayon-2.6.36-r1
1.5 GiB RAM
AMD Turion ML-32 64
ATI Radeon Xpress 200M
argonaut
Simple Hen
 
Posts: 40
Joined: Tue Dec 29, 2009 16:14
Location: Helsinki

Previous

Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 3 guests