wireless wont connect after 4.4 kde upgrade [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

wireless wont connect after 4.4 kde upgrade [Solved]

Postby TheConsaw » Thu Feb 11, 2010 18:26

so as the title says wireless wont connect after 4.4 kde upgrade !!
everything was sweet before hand,

now it seems wicd is my network manager, I dont think it was before, its see's my network ssid, but when i try connect it tells me "authentication failed, bad password" which isn't right, i paste my key from a file i have, its wpa, password is 100% correct and the default wicd settings all seem fine
any ideas folks thanks
Last edited by TheConsaw on Fri Feb 12, 2010 21:44, edited 1 time in total.
TheConsaw
Baby Hen
 
Posts: 16
Joined: Wed May 27, 2009 20:45
Location: Ireland

Re: wireless wont connect after 4.4 kde upgrade

Postby joeoden » Fri Feb 12, 2010 0:12

Looks like this is your problem
viewtopic.php?f=53&t=19657
Desktop ASUS M2N-MX SE Plus, AMD 64 X2 Dual Core 5200, 4 Gb RAM, GeForce 9500 1GB
Notebook HP CQ61-311AX, AMD CPU M320, 4 Gb RAM, Radeon HD 4300 512 MB
Wireless AR9285, Audio ATI SBx00 (IDT 92hd75B2x5)
Some mistakes are too much fun to only make once!
joeoden
Old Dear Hen
 
Posts: 477
Joined: Sun Mar 15, 2009 10:35
Location: Back in the 'swamp land' Moe, Australia 38°10′20″S 146°16′04″E

Re: wireless wont connect after 4.4 kde upgrade

Postby Sqens » Fri Feb 12, 2010 6:52

I get a similar problem, minus the password prompting. Wicd simply stopped noticing any networks. It's the network manager I used before the update, so I know it can work, but something happened. I'm currently testing to see if it will password prompt on gksudo. Also, it now creates two tray icons on startup, even after deleting /usr/share/autostart/wicd....

Any suggestions would be appreciated. Note that I can't install anything directly, since I don't have wireless or a sufficiently long ethernet cord.

EDIT: Well, I think I know what isn't working, though I have no idea why. wlan0 no longer shows up as a network interface. The wireless card (Broadcom BCM4318) still shows up on lspci though. I'm completely stuck.

-S
Sqens
Baby Hen
 
Posts: 19
Joined: Sat Feb 14, 2009 21:53

Re: wireless wont connect after 4.4 kde upgrade

Postby sjieke » Fri Feb 12, 2010 8:05

Try the following as root
Code: Select all
modprobe b43

If that succeeded try
Code: Select all
ifconfig

and if wlan0 is back add the 'b43' module to your module autoloads.

I had the same issue and this solved it.
sjieke
Technological Hen
 
Posts: 321
Joined: Thu Mar 01, 2007 10:46
Location: Maldegem, Belgium

Re: wireless wont connect after 4.4 kde upgrade

Postby Sqens » Fri Feb 12, 2010 8:23

Thanks, it worked! ifconfig still doesn't show wlan0, but iwconfig does, and wicd detects it. Now just to get sound working properly and KDE to stop throwing unknown errors.
Sqens
Baby Hen
 
Posts: 19
Joined: Sat Feb 14, 2009 21:53

Re: wireless wont connect after 4.4 kde upgrade

Postby joost » Fri Feb 12, 2010 12:15

A newer Knetworkmanager4 just got added to Entropy.

:D

Hope it works for everybody.

http://www.sabayon.org/repository/searc ... nager-9999
joost
Sagely Hen
 
Posts: 2574
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: wireless wont connect after 4.4 kde upgrade

Postby TheConsaw » Fri Feb 12, 2010 21:41

sweet, removed wicd, installed latest knetworkmanager, everything is great again thanks
TheConsaw
Baby Hen
 
Posts: 16
Joined: Wed May 27, 2009 20:45
Location: Ireland

Re: wireless wont connect after 4.4 kde upgrade [Solved]

Postby corktowner » Sat Feb 13, 2010 17:53

I have lost the ability to connect to the internet after the upgrade as well. I am using a Hawkings Technology HWU54G Mini-adapter, which uses the zd1211rw module. I can see wireless networks, however I cannot connect with either knetworkmanager or WICD. WICD attempts to connect yet always fails on "Bad Password". I have not changed the password and have verified it is correct. Knetworkmanager does nothing at all. Help please. I really miss my sabayon. :(
corktowner
Simple Hen
 
Posts: 48
Joined: Sun Jun 21, 2009 9:50

Re: wireless wont connect after 4.4 kde upgrade [Solved]

Postby dave_p_b » Tue Feb 16, 2010 12:40

Hi

For those of you currently stuck with wicd this is how you get it to work.
1) Open up a root konsole (E.g type su and enter root password)
2) Next type /etc/init.d/wicd start

Now your wicd should work. You might have to kill the wicd icon (bottom-right of screen for most of you) and restart wicd (by looking for it in the sabayon menu bottom-left of screen)

To make this permenant then just do step 3 in the root konsole.
3) rc-update add wicd default

Hope this helps anyone stuck.

All the best

Dave
dave_p_b
Old Dear Hen
 
Posts: 607
Joined: Fri Dec 15, 2006 1:39
Location: Exeter, UK

Re: wireless wont connect after 4.4 kde upgrade [Solved]

Postby hanz » Sun Feb 28, 2010 23:52

Hi,

I'm really sorry to open this up again, but I'm stucked with my wireless.
I just installed 5.1 and with the kde knetworkmanager everything worked fine.
Then I updated to the newest version (equo world), which left me with wicd. wicd itself is working (I see all the wireless networks), but I can't connect to my wireless router anymore (WPA2).
Before I updated today to 5.x I worked with the latest 4.x version and also used wicd. Everything worked.

It's my second try installing 5.1. With the first try I also installed the newest knetworkmanager and nm-applet, but nothing worked. I'm not sure if I should just wait for an update (and use cable till then) or install it a third time and don't update to the newest version*.

Cheers, Hannes

* ah, bad idea, sound wasn't working and now it is
hanz
Baby Hen
 
Posts: 15
Joined: Tue Jul 07, 2009 11:22

Next

Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest

cron