Using a proxy with KDE

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Using a proxy with KDE

Postby Fons » Tue Feb 09, 2010 18:05

Is there an easy way to get all of my applications to use a proxy of localhost 8080 with no authentication?
Fons
Baby Hen
 
Posts: 11
Joined: Tue Feb 02, 2010 17:37

Re: Using a proxy with KDE

Postby DHalens » Tue Feb 09, 2010 21:17

Have you take a look in the system settings? There are some options related to proxy there.
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: Using a proxy with KDE

Postby Fons » Wed Feb 10, 2010 0:59

Sadly inputting the proxy in system settings doesn't seem to work is there a config file that I can edit?
Fons
Baby Hen
 
Posts: 11
Joined: Tue Feb 02, 2010 17:37

Re: Using a proxy with KDE

Postby DHalens » Wed Feb 10, 2010 12:22

There is an update for the whole kde that may make it work if it was a bug in the previous version.
Anyway, if for example firefox is not set to use proxy data from the system, of course it won't work.
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: Using a proxy with KDE

Postby spacesyl » Tue Jun 15, 2010 15:04

About proxys, it's always possible to export proxys variables such as http_proxy
For instance, you can use this command:
Code: Select all
export http_proxy="http://username:[email protected]:port"


But this solution is not suitable for some browser ( if I remember well Firefox and chrome don't like this kind of settings ... ).
Also, this need to edit your /etc/profile file (this way, all user will have your proxy settings) or your ~/.bashrc
spacesyl
Baby Hen
 
Posts: 9
Joined: Tue Oct 06, 2009 14:41


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest