tightvnc display

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Post Reply
timpagden
Baby Hen
Posts: 2
Joined: Wed Sep 02, 2009 20:48

tightvnc display

Post by timpagden » Fri Feb 05, 2010 10:34

Hello, fellow Sabayoners,

Well, after a couple of hours faffing about on my home network, I can finally use vncviewer on a windows box to access a sabayon server running tightvnc - but the desktop looks like something from the 1980s! Can anyone shed any light on this? I'd really like to see the pretty Sabayon desktop.

Tim.
vncviewer.png

joost
Sagely Hen
Posts: 2675
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: tightvnc display

Post by joost » Fri Feb 05, 2010 11:57

You need to start gnome or kde or whatever from the vnc startup script. (~/.vnc/xstartup)

http://forums.gentoo.org/viewtopic.php?t=72893

You can also post your startup script here so we can have a look.
Image
My blog | Twitter

Please support Sabayon: Image

timpagden
Baby Hen
Posts: 2
Joined: Wed Sep 02, 2009 20:48

Re: tightvnc display

Post by timpagden » Fri Feb 05, 2010 15:57

I read through the Xvnc Terminal Server tutorial and made the suggested changes (except the port 177 part, I just enabled Xdmcp) and skipped steps 7-9. I figured I would just use vncserver to start with to get a remote session running then set up vnc as a service later.

Step 11 dumped me back at the command line so I ran startx and I ended up in 1980s display mode. I rebooted - bad move!
The machine IS rebooting, albeit very slowly because at every point it is 'waiting for xdm'.

Hmmm...

Anyway, the vnc startup script was something like:

xrdb ????/.Xresources
xsetroot -solid grey
xterm -geometry ???? "$VNCDESKTOP Desktop" &
twm &

joost
Sagely Hen
Posts: 2675
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: tightvnc display

Post by joost » Fri Feb 05, 2010 16:03

you need to replace the twm (what you see now) with startkde or gnome-session.
Image
My blog | Twitter

Please support Sabayon: Image

Post Reply