Wireless don't connects [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Post Reply
vovotux
Baby Hen
Posts: 2
Joined: Mon Dec 28, 2009 12:49

Wireless don't connects [Solved]

Post by vovotux » Mon Dec 28, 2009 14:13

First I ask your patience because I have difficulties with the English language.
I have a wireless connection WEP encrypted and I hadn't success in connecting to the web running through the sabayon live dvd.
Even so I installed the system. After installation, as before, I could not connect either through knetworkmanager as the wicd.
Likewise, trying to connect using the iwconfig command, I only can connect after killing NetworkManager process and all instances of wpa-supplicant.
By killing NetworkManager, connection it's too possible trough wicd gui.
So, I ask you how to automate these changes and make them permanent.
Last edited by vovotux on Mon Dec 28, 2009 20:24, edited 1 time in total.

micia
Sagely Hen
Posts: 2718
Joined: Wed Nov 26, 2008 16:41
Contact:

Re: Wireless don't connects

Post by micia » Mon Dec 28, 2009 15:51

It is normal that you cannot connect using Wicd if NetworkManager is active, because they will
both try to manage the network.

To disable NetworkManager remove it using (as root):

Code: Select all

rc-update del NetworkManager
and disable any autostart application that relies on it (like KNetworkManager).

Now set Wicd to start on boot using (as root):

Code: Select all

rc-update add wicd
and reboot.

Azerthoth
Simple Hen
Posts: 86
Joined: Wed Dec 27, 2006 20:03
Location: Bethel, Alaska

Re: Wireless don't connects

Post by Azerthoth » Mon Dec 28, 2009 20:13

Code: Select all

rc-update add wicd default

vovotux
Baby Hen
Posts: 2
Joined: Mon Dec 28, 2009 12:49

Re: Wireless don't connects

Post by vovotux » Mon Dec 28, 2009 20:23

I have did that then my connection is up on boot.
Thanks. Now I can learn how to use Sabayon!

Post Reply