Can't connect to Windows 7 share from Sabayon 4

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Can't connect to Windows 7 share from Sabayon 4

Postby NotExcessive » Tue Dec 15, 2009 12:35

Hi;

Have a little problem here which is driving me nuts - I know it must be something simple but I can't see it at the moment.

I've built up a laptop with 4.1 and tested it out with an XP box by setting up a file and printer share on the XP box. When I go to add a file or printer on the laptop, the XP box shows up, I can click on it, enter user name and password, and it just runs as it should. The laptop can see the shared directory and send a print job to the XP box without any trouble.

Now I've taken the laptop back to the customer's place and want to do the same file/printer share thing with their Windows 7 box. The Windows 7 box shows up in the network, and I can click on the icon to launch the authentication message box. However, entering the user name and password doesn't succeed, and the message box just keeps coming back: it's not authenticating.

The user name and password for the Windows 7 box are correct, the appropriate network/machine names show up from the LAN in Sabayon, and the share on the Windows 7 box is set to public/everyone RW, so it should be open season.

Am I missing something? Or is there some simple trap that I'm falling into?
NotExcessive
Simple Hen
 
Posts: 77
Joined: Mon May 12, 2008 7:26

Re: Can't connect to Windows 7 share from Sabayon 4

Postby Thev00d00 » Tue Dec 15, 2009 15:16

Tried this with my GFs win7 laptop about a week ago.

Using dolphin with the smb kio slave it worked fine.

ie smb://computername/share

Are you using KDE or Gnome?
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Re: Can't connect to Windows 7 share from Sabayon 4

Postby Fitzcarraldo » Tue Dec 15, 2009 15:30

I had a similar problem but with Windows Vista: sharing worked fine with a Windows XP box but not with a Windows Vista box until I enabled authentication in the way described in the SL Wiki article: HOWTO: Vista printer sharing. I have not yet used Windows 7, so don't know if much has changed w.r.t. SMB authentication, but perhaps the aforementioned SL Wiki article may help if the address format given by Thev00d00 does not work for you. Also, have you seen the forum thread Re: smb problem after KDE 4.3.2 update: Sabayon 5.0 KDE [Solved]?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Can't connect to Windows 7 share from Sabayon 4

Postby NotExcessive » Tue Dec 15, 2009 21:44

Thev00d00 wrote:Tried this with my GFs win7 laptop about a week ago.

Using dolphin with the smb kio slave it worked fine.

ie smb://computername/share

Are you using KDE or Gnome?


I'm using KDE.
NotExcessive
Simple Hen
 
Posts: 77
Joined: Mon May 12, 2008 7:26

Re: Can't connect to Windows 7 share from Sabayon 4

Postby NotExcessive » Tue Dec 22, 2009 14:32

OK I've upgraded the laptop to 5.1-r1 (and it's very slick indeed) but I still have the same problem: trying to do a file share from the Windows 7 machine, the authentication box pops up, I enter the user name and password used for booting up the Windows 7 machine, and it just keeps going in circles. Authentication just doesn't work. I've tried the trick of creating a registry entry (lmcompatibility) and setting it to 1, but to no avail.

Can anyone point me in the right direction please? This should be a 10-second job.
NotExcessive
Simple Hen
 
Posts: 77
Joined: Mon May 12, 2008 7:26


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest

cron