Some problems with pppoe [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Post Reply
Budyn
Baby Hen
Posts: 2
Joined: Wed Dec 02, 2009 9:16

Some problems with pppoe [Solved]

Post by Budyn » Wed Dec 02, 2009 9:18

Hello. I have problems with instal packages.

Code: Select all

MindFuck PHI # ls
4images                       dev-lang-tcl-8.5.7~0.tbz2  media-libs-fontconfig-2.8.0~0.tbz2      www.sabayonlinux.org • View topic - pppoe in sabayon 5 not exist [Solved]_files
bookmarks.html                dev-lang-tk-8.5.7~0.tbz2   Muzyka                                  www.sabayonlinux.org • View topic - pppoe in sabayon 5 not exist [Solved].htm  
BOOTEX.LOG                    error.log                  net-dialup-rp-pppoe-3.10-r1~0 (1).tbz2  x11-libs-libX11-1.3.2~0.tbz2                                                   
contacts.txt                  FileZillaPortable          net-dialup.tbz2                                                                                                        
debian-503-i386-kde-CD-1.iso  format                     ubudsl-1.0.0.286-14.1.i586.rpm                                                                                         
MindFuck PHI # equo install --ask '/media/PHI/net-dialup-rp-pppoe-3.10-r1~0 (1).tbz2'                                                                                          
>> Repository sabayonlinux.org hasn't been downloaded yet.                                                                                                                     
>> Repository sabayonlinux.org is not available. Cannot validate                                                                                                               
>> !!! Please update your repositories now in order to remove this message!                                                                                                    
>> Repository sabayonlinux.org hasn't been downloaded yet.                                                                                                                     
>> Repository sabayonlinux.org is not available. Cannot validate                                                                                                               
>> !!! Please update your repositories now in order to remove this message!                                                                                                    
>> Repository sabayonlinux.org hasn't been downloaded yet.                                                                                                                     
>> Repository sabayonlinux.org is not available. Cannot validate                                                                                                               
>> !!! Please update your repositories now in order to remove this message!                                                                                                    
>>  @@ These are the chosen packages:                                                                                                                                          
>>    # (1/1) net-dialup/rp-pppoe-3.10-r1 >>> Dynamic database from net-dialup-rp-pppoe-3.10-r1~0 (1).tbz2                                                                     
>>      Versions:        Not installed / NoTag / NoRev ===> 3.10-r1 / NoTag / 0                                                                                                
>>      Action:          Install                                                                                                                                               
>>  @@ Packages involved: 1                                                                                                                                                    
     Would you like to continue with dependencies calculation ? [Yes/No] y                                                                                                     
     >>  @@ Calculating dependencies ...                                                                                                                                            
     >>  @@ Cannot find needed dependencies:                                                                                                                                        
     >>     # Not found: dev-lang/tk                                                                                                                                                
     >>       # Probably needed by:                                                                                                                                                 
     >>         #  [from:net-dialup-rp-pppoe-3.10-r1~0 (1).tbz2] net-dialup/rp-pppoe-3.10-r1                                                                                        
     >>     # Not found: net-dialup/ppp                                                                                                                                             
     >>       # Probably needed by:                                                                                                                                                 
     >>         #  [from:net-dialup-rp-pppoe-3.10-r1~0 (1).tbz2] net-dialup/rp-pppoe-3.10-r1                                                                                        
     >>  @@ Caching complete.                                                                                                                                                       
     MindFuck PHI # equo install --ask '/media/PHI/dev-lang-tk-8.5.7~0.tbz2'
     >> Repository sabayonlinux.org hasn't been downloaded yet.             
     >> Repository sabayonlinux.org is not available. Cannot validate       
     >> !!! Please update your repositories now in order to remove this message!
     >> Repository sabayonlinux.org hasn't been downloaded yet.                 
     >> Repository sabayonlinux.org is not available. Cannot validate           
     >> !!! Please update your repositories now in order to remove this message!
     >> Repository sabayonlinux.org hasn't been downloaded yet.                 
     >> Repository sabayonlinux.org is not available. Cannot validate           
     >> !!! Please update your repositories now in order to remove this message!
     >>  @@ These are the chosen packages:                                      
     >>    # (1/1) dev-lang/tk-8.5.7 >>> Dynamic database from dev-lang-tk-8.5.7~0.tbz2
     >>      Versions:        Not installed / NoTag / NoRev ===> 8.5.7 / NoTag / 0     
     >>      Action:          Install                                                  
     >>  @@ Packages involved: 1                                                       
          Would you like to continue with dependencies calculation ? [Yes/No] y        
	  >>  @@ Calculating dependencies ...                                               
	  >>  @@ Cannot find needed dependencies:                                           
	  >>     # Not found: x11-libs/libX11                                               
	  >>       # Probably needed by:                                                    
	  >>         #  [from:dev-lang-tk-8.5.7~0.tbz2] dev-lang/tk-8.5.7                   
	  >>     # Not found: media-libs/fontconfig:1.0                                     
	  >>       # Probably needed by:                                                    
	  >>         #  [from:dev-lang-tk-8.5.7~0.tbz2] dev-lang/tk-8.5.7                   
	  >>     # Not found: ~dev-lang/tcl-8.5.7                                           
	  >>       # Probably needed by:                                                    
	  >>         #  [from:dev-lang-tk-8.5.7~0.tbz2] dev-lang/tk-8.5.7                   
	  >>  @@ Caching complete.                                                          
	  MindFuck PHI # equo install --ask '/media/PHI/x11-libs-libX11-1.3.2~0.tbz2'
	  >> Repository sabayonlinux.org hasn't been downloaded yet.                 
	  >> Repository sabayonlinux.org is not available. Cannot validate           
	  >> !!! Please update your repositories now in order to remove this message!
	  >> Repository sabayonlinux.org hasn't been downloaded yet.                 
	  >> Repository sabayonlinux.org is not available. Cannot validate           
	  >> !!! Please update your repositories now in order to remove this message!
	  >> Repository sabayonlinux.org hasn't been downloaded yet.
	  >> Repository sabayonlinux.org is not available. Cannot validate
	  >> !!! Please update your repositories now in order to remove this message!
	  >>  @@ These are the chosen packages:
	  >>    # (1/1) x11-libs/libX11-1.3.2 >>> Dynamic database from x11-libs-libX11-1.3.2~0.tbz2
	  >>      Versions:        1.2.2 / NoTag / 0 ===> 1.3.2 / NoTag / 0
	  >>      Action:          Upgrade
	  >>  @@ Packages involved: 1
	       Would you like to continue with dependencies calculation ? [Yes/No] y
	       >>  @@ Calculating dependencies ...
	       >>  @@ Cannot find needed dependencies:
	       >>     # Not found: x11-proto/kbproto
	       >>       # Probably needed by:
	       >>         #  [from:x11-libs-libX11-1.3.2~0.tbz2] x11-libs/libX11-1.3.2
	       >>     # Not found: >=x11-proto/xproto-7.0.13
	       >>       # Probably needed by:
	       >>         #  [from:x11-libs-libX11-1.3.2~0.tbz2] x11-libs/libX11-1.3.2
	       >>     # Not found: >=x11-libs/xtrans-1.2.3
	       >>       # Probably needed by:
	       >>         #  [from:x11-libs-libX11-1.3.2~0.tbz2] x11-libs/libX11-1.3.2
	       >>     # Not found: >=x11-libs/libxcb-1.1.92
	       >>       # Probably needed by:
	       >>         #  [from:x11-libs-libX11-1.3.2~0.tbz2] x11-libs/libX11-1.3.2
	       >>  @@ Caching complete.
	       MindFuck PHI # equo install --ask '/media/PHI/media-libs-fontconfig-2.8.0~0.tbz2'
	       >> Repository sabayonlinux.org hasn't been downloaded yet.
	       >> Repository sabayonlinux.org is not available. Cannot validate
	       >> !!! Please update your repositories now in order to remove this message!
	       >> Repository sabayonlinux.org hasn't been downloaded yet.
	       >> Repository sabayonlinux.org is not available. Cannot validate
	       >> !!! Please update your repositories now in order to remove this message!
	       >> Repository sabayonlinux.org hasn't been downloaded yet.
	       >> Repository sabayonlinux.org is not available. Cannot validate
	       >> !!! Please update your repositories now in order to remove this message!
	       >>  @@ These are the chosen packages:
	       >>    # (1/1) media-libs/fontconfig-2.8.0 >>> Dynamic database from media-libs-fontconfig-2.8.0~0.tbz2
	       >>      Versions:        2.7.2 / NoTag / 0 ===> 2.8.0 / NoTag / 0
	       >>      Action:          Upgrade
	       >>  @@ Packages involved: 1
	            Would you like to continue with dependencies calculation ? [Yes/No] y
		    >>  @@ Calculating dependencies ...
		    >>  @@ Cannot find needed dependencies:
		    >>     # Not found: app-admin/eselect-fontconfig
		    >>       # Probably needed by:
		    >>         #  [from:media-libs-fontconfig-2.8.0~0.tbz2] media-libs/fontconfig-2.8.0
		    >>     # Not found: >=dev-libs/expat-1.95.3
		    >>       # Probably needed by:
		    >>         #  [from:media-libs-fontconfig-2.8.0~0.tbz2] media-libs/fontconfig-2.8.0
		    >>     # Not found: >=media-libs/freetype-2.2.1
		    >>       # Probably needed by:
		    >>         #  [from:media-libs-fontconfig-2.8.0~0.tbz2] media-libs/fontconfig-2.8.0
		    >>  @@ Caching complete.
Any idea?
Last edited by Budyn on Wed Dec 02, 2009 16:45, edited 1 time in total.

micia
Sagely Hen
Posts: 2718
Joined: Wed Nov 26, 2008 16:41
Contact:

Re: Some problems with pppoe

Post by micia » Wed Dec 02, 2009 11:47

you need eselect-fontconfig package.
You need also to provide all the packages at the same time,
like:

Code: Select all

equo install --ask '/media/PHI/dev-lang-tcl-8.5.7~0.tbz2'  '/media/PHI/media-libs-fontconfig-2.8.0~0.tbz2' '/media/PHI/dev-lang-tk-8.5.7~0.tbz2' '/media/PHI/net-dialup-rp-pppoe-3.10-r1~0 (1).tbz2'  '/media/PHI/x11-libs-libX11-1.3.2~0.tbz2'
It is really some pain...
You could use --nodeps option to force the most important packages to be installed, then, when online, fix dependencies using:

Code: Select all

equo update
equo deptest
for example:

Code: Select all

equo install --ask --nodeps '/media/PHI/dev-lang-tcl-8.5.7~0.tbz2'  '/media/PHI/media-libs-fontconfig-2.8.0~0.tbz2' '/media/PHI/dev-lang-tk-8.5.7~0.tbz2' '/media/PHI/net-dialup-rp-pppoe-3.10-r1~0 (1).tbz2'
hoping that pppoe will work even without its dependencies (at least for some time).

Budyn
Baby Hen
Posts: 2
Joined: Wed Dec 02, 2009 9:16

Re: Some problems with pppoe

Post by Budyn » Wed Dec 02, 2009 14:14

budyn # pppoe-status
pppoe-status: Link is up and running on interface ppp0
ppp0 Link encap:Point-to-Point Protocol

:)
God job. Thanks.

Code: Select all

equo install --ask --nodeps '/media/PHI/dev-lang-tcl-8.5.7~0.tbz2'  '/media/PHI/media-libs-fontconfig-2.8.0~0.tbz2' '/media/PHI/dev-lang-tk-8.5.7~0.tbz2' '/media/PHI/net-dialup-rp-pppoe-3.10-r1~0 (1).tbz2'  '/media/PHI/x11-libs-libX11-1.3.2~0.tbz2'

pavav
Simple Hen
Posts: 59
Joined: Thu Dec 10, 2009 1:12

Re: Some problems with pppoe [Solved]

Post by pavav » Thu Dec 17, 2009 2:14

You can just download this package (with some live distro for example): net-dialup:rp-pppoe-3.10-r1~0.tbz2 (and md5 file) from sabayon repositories and install it with:
# equo install --nodeps net-dialup:rp-pppoe-3.10-r1~0.tbz2

You dont need gui at this moment, when you connect you can install other dependencies

Post Reply