Wireless not working at all.

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Wireless not working at all.

Postby GoTTsProfeT » Sun Nov 01, 2009 8:53

My wireless is not working at all.

Sabayon KDE 5.0 (wireless didnt work with 4.2 either)

System: Inspiron 1525

IWconfig output:
Code: Select all
sabayon gottsprofet # iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sabayon gottsprofet # ifconfig lo
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:72 errors:0 dropped:0 overruns:0 frame:0
          TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5776 (5.6 KiB)  TX bytes:5776 (5.6 KiB)


I assume this means its not even finding my wireless card?!
GoTTsProfeT
Baby Hen
 
Posts: 11
Joined: Wed Dec 10, 2008 18:26

Re: Wireless not working at all.

Postby micia » Sun Nov 01, 2009 11:52

Could you tell us your wireless card model and the
output of (as root):
Code: Select all
lspci
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Wireless not working at all.

Postby GoTTsProfeT » Sun Nov 01, 2009 11:56

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
02:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
02:09.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
02:09.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
02:09.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
09:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller (rev 12)
0b:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
GoTTsProfeT
Baby Hen
 
Posts: 11
Joined: Wed Dec 10, 2008 18:26

Re: Wireless not working at all.

Postby micia » Sun Nov 01, 2009 12:07

micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Wireless not working at all.

Postby Charred » Sun Nov 01, 2009 16:47

I just installed version 5 and I'm trying to get wireless working. The output from lspci for my wirless card is:
0c:00.0 Network controller: Broadcom Corporation BCM4328 802.11a/b/g/n (rev 03)

I blacklisted the modules according to the wiki and rebooted, but still no wireless. Any ideas? I've double checked and it is enabled in the bios.
Charred
Baby Hen
 
Posts: 1
Joined: Sun Nov 01, 2009 16:39

Re: Wireless not working at all.

Postby pepe999 » Thu Nov 12, 2009 21:05

Charred wrote:I just installed version 5 and I'm trying to get wireless working. The output from lspci for my wirless card is:
0c:00.0 Network controller: Broadcom Corporation BCM4328 802.11a/b/g/n (rev 03)

I blacklisted the modules according to the wiki and rebooted, but still no wireless. Any ideas? I've double checked and it is enabled in the bios.

I have no BCM43XX wireless card but when I started with linux I had to use ndiswrapper. I suggest to blacklist the bXY module in the kernel and then install a bcmwl5.inf driver in ndiswrapper...
Dell L502X - Core i7-2840QM/8GB DDR3/GF 540M 2GB/Corsair GT 240GB/Full HD
Debian 7
Win 7 still installed
Linux user no. 491024
pepe999
Advanced Hen
 
Posts: 258
Joined: Fri Mar 06, 2009 19:24
Location: Manchester

Re: Wireless not working at all.

Postby GoTTsProfeT » Sat Dec 12, 2009 1:31

is there a way to apply the blacklisting without rebooting, as i have no hard drive and I am in a live session, and rebooting will cause the information to be lost anyways.
GoTTsProfeT
Baby Hen
 
Posts: 11
Joined: Wed Dec 10, 2008 18:26

getting wireless to work inlive mode(blacklisting no reboot)

Postby GoTTsProfeT » Sat Dec 12, 2009 2:37

How do i make the wireless work in livemode by black listing without reboot.

is there maybe someway I can reload the moduals without rebooting?

I have no hard drive, the system is completley live and I need the wireless to work.



MODERATOR EDIT: Merged the two threads by GoTTsProfeT as they deal with the same topic.
GoTTsProfeT
Baby Hen
 
Posts: 11
Joined: Wed Dec 10, 2008 18:26

Re: Wireless not working at all.

Postby micia » Sat Dec 12, 2009 16:06

Try using modprobe -r as root:

Code: Select all
modprobe -r ssb
modprobe -r b43
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Wireless not working at all.

Postby Ocean » Sun Jan 17, 2010 22:34

I know this is an old topic, but now I have the exact problem. I have the exact computer as him too. (I posted a topic on this issue but it didn't show up? so im guessing it's either moderator approved, or I didn't submit it?)

Anyway, I've tried everything in this thread that's been listed and I still cannot cannot to wi-fi. Can anyone help?

I found this for ndiswrapper. http://sourceforge.net/apps/mediawiki/n ... eless_1390

Which would be my card, do I just save bcmw15.inf and bcmw15.sys and use those? i don't understand how to use ndiswrapper.

Further fooling around with ndiswrapper, I was able to install the driver because it said "bcmw15.inf" is already installed. but i still have no wireless...hmmm
Ocean
Baby Hen
 
Posts: 3
Joined: Sun Jan 17, 2010 21:14

Next

Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest

cron