Great connection, but not automatic

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Post Reply
farfnarf
Simple Hen
Posts: 57
Joined: Thu Jun 14, 2007 13:26
Location: Lincoln, Nebraska, U.S.A.

Great connection, but not automatic

Post by farfnarf » Tue Jul 07, 2009 17:07

I am running around in circles on such a simple issue that I'm embarrassed to even post it in here,
but I have to because I can't figure it out:

This is a laptop that is used by only one person here, me. I have no need for "keyring" password
protection for my wireless connection (I also need to figure out how to get this Gnome version of
Sabayon to just log me in automatically, but that needs to be posted elsewhere I know).

How do I make it so the network tool/manager remembers my long wpa2 pass key for the
wireless without having to enter a "keyring" password?

micia
Sagely Hen
Posts: 2718
Joined: Wed Nov 26, 2008 16:41
Contact:

Re: Great connection, but not automatic

Post by micia » Tue Jul 07, 2009 18:03

I think that without Gnome Keyring you won't be able to achieve it...
My advice is to live with Gnome Keyring...
Or you could try to use wicd in place of NetworkManager.
See this wiki article:
http://wiki.sabayonlinux.org/index.php? ... _with_WICD

As for the autologin, there is a wiki article on it too, check it out:
http://wiki.sabayonlinux.org/index.php? ... _Autologin

farfnarf
Simple Hen
Posts: 57
Joined: Thu Jun 14, 2007 13:26
Location: Lincoln, Nebraska, U.S.A.

Re: Great connection, but not automatic

Post by farfnarf » Wed Jul 08, 2009 3:12

Thanx for replying.

The auto-login thing worked.. I'm surprised I did not notice that before.

But the wicd was all greyed out and contained no configurable data. Just empty.

Meanwhile the network manager has been working fine, I just wanted to stop
having to enter either my long pass phrase or the keyring pass word.

I'll just leave that as it is because I'm afraid if I try messing with the settings
I'll end up in a situation much worse than now.

Fitzcarraldo
Sagely Hen
Posts: 8218
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Great connection, but not automatic

Post by Fitzcarraldo » Wed Jul 08, 2009 22:52

Is this the same question as the one that pops up all the time on the Ubuntu forums, by any chance? When I used Ubuntu a couple of years ago it used to pop up two prompts: the login prompt and then, after I had logged in, the keyring password prompt which I had to enter in order to enable the wireless networking. It may be an ultra secure way of doing things, but it's a PITA none the same. Anyway, back in 2006 people were posting asking how to stop this happening, and, if you visit the Ubuntu forums today you'll find people are still posting about it. Anyway, the fix I used for Ubuntu is summarised in the Ubuntu Forums post Re: Must enter password for default keyring to unlock.... and may be applicable in SL GNOME too, although I don't use SL GNOME so I can't be sure. Hope it helps.

farfnarf
Simple Hen
Posts: 57
Joined: Thu Jun 14, 2007 13:26
Location: Lincoln, Nebraska, U.S.A.

Re: Great connection, but not automatic

Post by farfnarf » Thu Jul 09, 2009 12:20

Looks like it is the same question. I'll check out the solution over there, thanks for the link.

I think we should have a choice as to the level and strength of our security measures and not
have things forced on us like that. I can't even stand it when there is a "strength meter" telling
us how good our passwords are as we type them in; some of us just do not even need a
pass word at all.

If it's some "linux community responsibility" thing, then it needs to be talked about alongside
a discussion of what linux purports to be about: choices and freedom.

Rant over. :lol:

farfnarf
Simple Hen
Posts: 57
Joined: Thu Jun 14, 2007 13:26
Location: Lincoln, Nebraska, U.S.A.

Re: Great connection, but not automatic

Post by farfnarf » Thu Jul 09, 2009 13:52

Fitzcarraldo wrote:Is this the same question as the one that pops up all the time on the Ubuntu forums, by any chance? When I used Ubuntu a couple of years ago it used to pop up two prompts: the login prompt and then, after I had logged in, the keyring password prompt which I had to enter in order to enable the wireless networking. It may be an ultra secure way of doing things, but it's a PITA none the same. Anyway, back in 2006 people were posting asking how to stop this happening, and, if you visit the Ubuntu forums today you'll find people are still posting about it. Anyway, the fix I used for Ubuntu is summarised in the Ubuntu Forums post Re: Must enter password for default keyring to unlock.... and may be applicable in SL GNOME too, although I don't use SL GNOME so I can't be sure. Hope it helps.
No help.

Here're the instructions as posted in that link:

Changing/removing the keyring password is quite easy to do (no need to remove the current keyring or mess with user accounts):

1. open the keyring manager (Applications/Accessories/Passwords and Encryption Keys)

2. *****Go to Edit/Preferences*****

3. On the Password Keyrings-tab select the "login"-keyring & click "Change Unlock Password"

Now you can change the keyring password. If you use normal login set the password to same as your login password is to unlock the keyring automatically. If you use automatic login leave the new password fields empty to remove the keyring password.




The asterisks I put in to highlight the section that is not possible in Sabayon's (Gnome's?) keyring manager. No
"edit."

Post Reply