No network connection at all [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

No network connection at all [Solved]

Postby GileZ » Tue Feb 10, 2009 23:37

Hi. I just installed Sabayon 4.0 for the first time this week, and initially everything worked fine. I connected to the internet via my USRobotics Wireless USB Adapter, entered the encryption data (passwords etc) and it saved the profile ok (it's still saved in the network profile manager).

Then then next day i logged in and it wont connect to the internet no matter what i try. I've even tried a wired connection directly to the router but that wont work either. The connection on Win XP is fine on both wired and wireless connection, so i know everything is working fine on that end. When i try to manually add configuration data to either the wired connection of the wireless one it wont save it and doesn't give me a connection. :(

GileZ
cchheecckk yyoouurr dduupplleexx sswwiittcchh
GileZ
Baby Hen
 
Posts: 6
Joined: Mon Feb 09, 2009 19:04
Location: In a Box

Re: No network connection at all

Postby Darksurf » Wed Feb 11, 2009 0:49

This is due to the Network Manager 0.7.0 update. Not everything is compatible with the new Network Manager. This issue is something the team is working on. For a Fix you can do one of two things.
#first open a root terminal
Open konsole/terminal
sudo su
(type password)
# plug ethernet cable into computer, then reset your NIC/ethernet card and get an IP
ifconfig eth0 down
ifconfig eth0 up
# this should get your NIC an IP address if it doesn't do this
dhcpcd eth0
# Now that we have an IP address and are connected to the internet we need to fix the problem. My first choice is USE WICD.
equo install wicd
rc-update add wicd default
#Now we have wicd installed. Now copy an icon from the kmenu (any icon, preferable pertaining to network apps) to the desktop
#now right click the icon and click through the tabs until you find "command" which is the command the icon runs when clicked and replace the #command with "wicd-client" without parenthesis. Now open up konqueror and go to the address bar and go to "/home/(user)/.kde/Autostart"
# and move that icon from your desktop into that folder. You now have a new easy to use network manager doesn't depend on KDE, Gnome,
#or any DE, but can be used in all DEs. Or if you don't like the autostart idea then just run the command "wicd-client" when you login.


#Now if you don't want to use another Network Manager, then just
equo search NetworkManager
#Now find the version that was available before 0.7.0 and equo install that version and refrain from updating to 0.7.0 .

I prefer wicd, as it doesn't depend on networkmanager and is very easy to use. It is very user friendly and can be used in any environment!
~ Y </0 5+Up1</ P30p[Ez +Ry 2 R34</ D1s? ~
Darksurf
Old Dear Hen
 
Posts: 782
Joined: Sat Sep 16, 2006 4:01

Re: No network connection at all

Postby GileZ » Thu Feb 12, 2009 0:37

Thanks! I've done this stuff and it's working fine now! I'd also recommend wicd for managing your wireless networks. It's really easy to use and seems to be able to cope with encrypted networks well too.

Thanks again!
cchheecckk yyoouurr dduupplleexx sswwiittcchh
GileZ
Baby Hen
 
Posts: 6
Joined: Mon Feb 09, 2009 19:04
Location: In a Box

Re: No network connection at all [Solved]

Postby earth » Sat Feb 14, 2009 19:01

darksurf, your instructions worked like a charm! I was trying to configure a wireless dongle last night & somehow it ruined my wired ethernet connection. The default network program just would not fix it but WICD, per your line commands, did the job! Thank you!!
earth
Baby Hen
 
Posts: 2
Joined: Mon Aug 13, 2007 5:04

Re: No network connection at all [Solved]

Postby aZiXx » Fri Mar 20, 2009 22:28

Great tip! It gets the IP quicker than KNetworkManager and so far hasn't given me a bogus default 169.... internal IP address.

One silly note to add: don't forget to disable the Network Manager from starting up automatically. For me, it was assigning the bogus internal 169.... IP after WICD assigned the real internet IP. After disabling, no more problems!!! Great application. Thanks!
aZiXx
Young Hen
 
Posts: 25
Joined: Wed Mar 18, 2009 1:18

Re: No network connection at all [Solved]

Postby fenius » Wed Mar 25, 2009 23:14

Nice tip darksurf ...wicd is a very nice app... thank you! :D
fenius
Growing Hen
 
Posts: 140
Joined: Thu Mar 15, 2007 17:39
Location: Roma


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest