wireless problems in SL 3.5

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

wireless problems in SL 3.5

Postby panzer » Fri Jul 11, 2008 22:30

hello everybody,
i'm running SL 3.5 on an asus x51rl notebook that comes with a wifi card based on the atheros AR242x chip as reported by "lspci"
no wireless network is available in knetworkmanager and "dmesg" throws these lines
Code: Select all
PCI: Enabling device 0000:02:00.0 (0000 -> 0002)
[ 2666.501927] ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 16 (level, low) -> IRQ 16
[ 2666.501949] PCI: Setting latency timer of device 0000:02:00.0 to 64
[ 2666.501990] ath5k_pci 0000:02:00.0: registered as 'phy1'
[ 2667.510633] ath5k phy1: failed to wakeup the MAC Chip
[ 2667.510727] ACPI: PCI interrupt for device 0000:02:00.0 disabled
[ 2667.510823] ath5k_pci: probe of 0000:02:00.0 failed with error -5

as i tried to "modprobe -r ath5k" and then "modprobe ath5k"
any help about fixing the wireless network would by much appreciated
bye
panzer
Baby Hen
 
Posts: 2
Joined: Fri Jul 11, 2008 22:21

Re: wireless problems in SL 3.5

Postby momocore » Sat Jul 12, 2008 16:54

The quick and dirty fix:

compile madwifi-ng-0.9.4, that should take care of it.

Code: Select all
emerge =net-wireless/madwifi-ng-0.9.4


the ath5k drivers seem incomplete. I have not tried messing with the kernel, but if I do later, I'll post my results.

ToneDeaf posted the fix first:

http://test.sabayonlinux.org/forum/viewtopic.php?f=52&t=13938
momocore
Simple Hen
 
Posts: 96
Joined: Thu Jul 05, 2007 13:27

Re: wireless problems in SL 3.5

Postby panzer » Mon Jul 14, 2008 14:08

already tried to use madwifi-ng-0.9.4 but with no success as the activation process for the wireless adapter gets stuck at 28% and then it fails with a message like "could not connect to the network xxxxxx"
panzer
Baby Hen
 
Posts: 2
Joined: Fri Jul 11, 2008 22:21


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 2 guests