Bluetooth - Dell Wireless 350 3.5_x64 - Not recognized

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Post Reply
Young Hen
Posts: 21
Joined: Tue Jan 08, 2008 3:17

Bluetooth - Dell Wireless 350 3.5_x64 - Not recognized

Post by tyranny12 » Fri Jul 04, 2008 4:05

Alright, I've combed the forums for gentoo and sabayon, looked at the wikis too, and spent the last 4 hours hacking at this thing. Used the IRC channel too...

I have a Dell Latitude D820 running 3.5_x64. It has an internal Dell Bluetooth 350 card. This card worked on Sabayon 3.4. It has not worked on any loop, and now that I'm running 3.5 final, I want to use my external mouse again when I travel.

System details under gentoo here:

The crux is that the internal bluetooth card is not recognized. DMESG shows bluetooth starting up:
And if I toggle the wireless switch it shows that it (sort of) registers, but it also shows the root of the problem - my system is identifying it as a HID keyboard (USB ID 8105, where bluetooth is 8103/6)

This card is known to work under linux, and did in 3.4. It's listed under the hci_usb modules page.

hciconfig shows no output. hcitools -dev shows a blank 'Devices:' line.

Bluetooth services start up fine - *but* sdpd (as per the Gentoo bluetooth guide) doesn't show up in the list.

According to the Gentoo bluetooth guide, I needed to make sure HCI_USB was loaded as a kernel module. I did so. Then after reading a forum post I reinstalled bluez-libs, bluez-utils, and kbluetooth. No change.

lsmod output here:
lspci output here:
lsusb output below. you can see my poor bluetooth module listed as USB ID 413c:8105
Detailed lsusb output on that device here:

Any ideas what to try next? I may have tried it - I don't remember all my steps. And for the record, kbluemon crashes on load.

Post Reply