Problems with proxy

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Problems with proxy

Postby elorc » Tue Jun 03, 2008 18:05

I've set up a Sabayon machine behind a proxy on my company's network. I've attempted to set the proxy information but it still does not work.

What I've done:
  1. Opened Control Center
    1. Went to Internet & Network
    2. Selected Proxy
    3. Selected "Manually specify the proxy settings" and clicked the Setup button to the right.
    4. Entered my proxy information: administrator:[email protected]:8080 (alternately I did it without user:password but the previous screen does not allow me to change "Authorization" to "Use the following information." It only lets me select "Prompt as needed" which makes no sense at all)
    5. Selected to apply to all proxies.
    6. Clicked OK.
    7. Clicked Apply, OK.
  2. Attempted to open Konqueror and navigate to http://www.google.com . The page does not load and gives me an error: "An error occurred while loading http://www.google.com . The file or folder http://www.google.com does not exist."
  3. Verified the proxy settings appear correct through Konqueror's settings.
  4. Opened a terminal window and su into root.
  5. Attempted to run emerge --sync but got an error:
    >>> Starting rsync with rsync://134.68.220.97/gentoo-portage ...
    timed out
    rsync error: received SIGINT, SIGTERM, or SIGHUP (code 20) at rsync.c(503) [receiver=3.0.0pre8]
    >>> retrying...
  6. Aborted emerge --sync
  7. Attempted to ping http://www.google.com . No response.
  8. Attempted to set proxy information manually:
    1. export http_proxy="http://administrator:[email protected]:8080"
    2. export ftp_proxy="ftp://administrator:[email protected]:8080"
    3. export rsync_proxy="rsync://administrator:[email protected]:8080"
    4. Verified these by echoing each.
  9. Attempted to repeat steps 2-7 with the same results as before.
  10. Contemplated throwing machine out the window but opted not to.

I'm not sure what the problem is. I set up an Ubuntu machine using the same information/credentials without any issue at all. The proxy is ISA 2000. I tried running net-setup to verify my settings. Everything is correct, and eth0 is pulling a valid IP address. What I'm particularly curious about:

  1. Why it's not connecting to the internet. I don't get it. The only thing I can think of (which I haven't yet tried) is instead of using administrator:password, trying domain\administrator:password. I've never had to do it that way though, and I don't think it'd work anyway.
  2. Why I can't manually set the proxy authorization. Under Control Center/Internet&Network/Proxy/Authorization, it only allows me to select "Prompt as needed" (and it never prompts for it). "Use the following login information" is disabled and cannot be selected.

Any ideas? Thanks.
elorc
Baby Hen
 
Posts: 3
Joined: Sun Jun 10, 2007 19:37

Re: Problems with proxy

Postby Drain » Sat Jun 07, 2008 1:15

with isa proxy my experience say to use ntlmaps package

check it out: http://gentoo-wiki.com/HOWTO_ACCESS_ISA_PROXY


i have to test ntlmaps with equo/entropy, cause i have isa server at work too

some things don't work with ntlmaps (surely in my work spot), one is MSN client (amsn pigdin etc) :evil:
Image
Drain
Simple Hen
 
Posts: 46
Joined: Tue Oct 31, 2006 0:51


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest