named service not accessible [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

named service not accessible [Solved]

Postby lytithwyn » Wed May 21, 2008 15:44

I just installed and configure the bind dns server. It works fine from the local host, I get ports 53 and 953 just like I should; however, I cannot connect from another computer on the network. When I do `nmap hostname-of-computer-with-dns`, I don't see port 53 OR 953 open. I see all my other ports just fine: ssh, ftp, httpd, mysql, etc. Also, if I try to telnet directly to port 53, it get the error "connection refused".

I haven't set up any sort of firewall, and I even check to be sure that ipchains isn't even installed. Why can't I see those ports?

Sabayon 3.4
net-dns/bind-9.4.1_p1
lytithwyn
Baby Hen
 
Posts: 4
Joined: Fri Jan 04, 2008 13:31

Re: named service not accessible

Postby chickpea » Wed May 21, 2008 16:11

We don't use ipchains, we use iptables. I think ipchains has been deprecated for awhile.

Although I think by default the firewall is off in sabayon.
chickpea
Sagely Hen
 
Posts: 1084
Joined: Fri Jan 05, 2007 15:08
Location: Washington, DC

Re: named service not accessible

Postby lytithwyn » Thu May 22, 2008 13:25

I figured it out. Once you told me to look at iptables, I found that and removed it. That didn't fix it.

Then Ifound a gentoo DNS tutorial, and it turns out there is a default setting in named.conf that keeps bind from listening on any address but 127.0.0.1. This setting was not listed on the tutorial I was following at http://tldp.org/HOWTO/DNS-HOWTO.html. I fixed this by changing this line in named.conf:

Code: Select all
listen-on { 127.0.0.1 };

becomes

listen-on { any; };


Thanks for getting me pointed in the right direction, chickpea!
lytithwyn
Baby Hen
 
Posts: 4
Joined: Fri Jan 04, 2008 13:31


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest

cron