No wireless ipw3945 after upgrading kernel to 2.6.25[Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Re: No wireless ipw3945 after upgrading kernel to 2.6.25

Postby Fitzcarraldo » Wed May 21, 2008 15:31

chickpea wrote:Fitz, are you perhaps running into the wpa issue I was having in the OpenRC thread? Have you checked your ps aux | grep wpa to see if you have several instances of wpa_supplicant loading at boot? If you kill them, you will be able to connect to WPA encrypted networks normally. I think you tried this before and it wasn't the problem, but I am still curious because really all other solutions have not panned out.

Here's the latest result:

# ps aux | grep wpa
root 12873 0.0 0.0 5148 744 pts/1 R+ 14:25 0:00 grep --colour=auto wpa
#

As you are using WPA-encryption, do your files /etc/udev/rules.d/70-persistent-net.rules, /etc/conf.d/net, /etc/wpa_supplicant/wpa_supplicant.conf and /etc/conf.d/modules look like the ones Tiago posted, or are they different? I know your wireless card is different, but maybe there's something I can deduce from them. Thanks.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: No wireless ipw3945 after upgrading kernel to 2.6.25

Postby chickpea » Wed May 21, 2008 15:42

Code: Select all
[email protected] ~ $ sudo cat /etc/udev/rules.d/70-persistent-net.rules
Password:
# This file was automatically generated by the /lib/udev/write_net_rules
# program, probably run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single line.

# PCI device 0x14e4:0x4311 (bcm43xx)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:1a:73:6b:51:09", ATTR{type}=="1", NAME="wlan0"

# PCI device 0x10de:0x0269 (forcedeth)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:1b:24:54:04:da", NAME="eth0"

# PCI device 0x14e4:0x4311 (ndiswrapper)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:1a:73:6b:51:09", ATTRS{type}=="1", ATTR{type}=="1", NAME="wlan0"
[email protected] ~ $


Code: Select all
[email protected] ~ $ sudo cat /etc/conf.d/net
# This network configuration was written by net-setup
iface_wlan0="dhcp"


Code: Select all
[email protected] ~ $ sudo cat /etc/wpa_supplicant/wpa_supplicant.conf
# This is a network block that connects to any unsecured access point.
# We give it a low priority so any defined blocks are preferred.
network={
        key_mgmt=NONE
        priority=-9999999
}



Code: Select all
[email protected] ~ $ sudo cat /etc/conf.d/modules
# You can define a list modules for a specific kernel version,
# a released kernel version, a main kernel version or just a list.
#modules_2_6_23_gentoo_r5="ieee1394 ohci1394"
#modules_2_6_23="tun ieee1394"
#modules_2_6="tun"
#modules="ohci1394"

# Give the modules some arguments if needed, per version if necessary.
#module_ieee1394_args="debug"
#module_ieee1394_args_2_6_23_gentoo_r5="ieee1394 ohci1394"
#module_ieee1394_args_2_6_23="tun ieee1394"
#module_ieee1394_args_2_6="tun"

# You should consult your kernel documentation and configuration
# for a list of modules and their options.

### START: Auto-converted from kernel-2.6

# /etc/modules.autoload.d/kernel-2.6:  kernel modules to load when system boots.
#
# Note that this file is for 2.6 kernels.
#
# Add the names of modules that you'd like to load when the system
# starts into this file, one per line.  Comments begin with # and
# are ignored.  Read man modules.autoload for additional details.

# For example:
# aic7xxx
modules_2_6="${modules_2_6} kvm"
module_kvm_args_2_6=""

modules_2_6="${modules_2_6} vboxdrv"
module_vboxdrv_args_2_6=""

#ndiswrapper
modules_2_6="${modules_2_6} b43"
module_b43_args_2_6=""


### END: Auto-converted from kernel-2.6


Here you are, yeah again nothing wrong with your wpa_supplicant like with the broadcom b43 module. Just checking.
chickpea
Sagely Hen
 
Posts: 1084
Joined: Fri Jan 05, 2007 15:08
Location: Washington, DC

Re: No wireless ipw3945 after upgrading kernel to 2.6.25

Postby Tiago » Wed May 21, 2008 16:39

Fitzcarraldo wrote:# ps aux | grep wpa
root 12873 0.0 0.0 5148 744 pts/1 R+ 14:25 0:00 grep --colour=auto wpa
#


I'm not using wpa but anyway:

Code: Select all
root      6667  0.0  0.1   3552  1472 ?        S    14:33   0:00 /sbin/wpa_supplicant -g /var/run/wpa_supplicant-global
root     10594  0.0  0.0   3032   800 pts/2    R+   16:37   0:00 grep --colour=auto wpa


So you don't have any wpa_supplicant running at all...
Tiago
Young Hen
 
Posts: 31
Joined: Mon Oct 29, 2007 17:13
Location: Madrid, Spain

Re: No wireless ipw3945 after upgrading kernel to 2.6.25

Postby Fitzcarraldo » Wed May 21, 2008 17:06

Well, wpa_supplicant no longer runs on my laptop. I think that when I performed the Baselayout-2/OpenRC migration something stopped it. Also, according to the OpenRC and Baselayout-2.0 thread, wpa_supplicant is no longer needed and indeed if it starts up should be killed. The details of how to kill it if it does start up at boot are even given in that thread. So I'm assuming that wpa_supplicant was in the boot run level previously and that merging the baselayout-2 and openrc packages removed wpa_supplicant from the boot run level in my case. But that's only my assumption. According to xlnagla and chickpea in the above-mentioned thread, KNetworkManager (or is it NetworkManager really?) takes care of the WPA part of things now and makes wpa_supplicant obsolete.

Anyway, out of interest I ran wpa_supplicant in a Terminal window as root and then used KNetworkManager > Connect to Other Wireless Network... to see if I could connect to my WPA-encrypted network. I entered the ESSID, ticked 'Use Encryption' and WPA Personal was in the Encryption pull-down menu this time. I selected it and entered my WPA password, selected WPA1 and TKIP as usual, and clicked Connect. But the Activating Wireless Network Connection sticks on 28% as usual and eventually the message "Connection Failure Could Not Connect to the Network BTHomeHub-47BE" pops up. In the Terminal window the following message appeared:

Code: Select all
# /sbin/wpa_supplicant -g /var/run/wpa_supplicant-global
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 -           
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: No wireless ipw3945 after upgrading kernel to 2.6.25

Postby chickpea » Wed May 21, 2008 17:56

I'm no real authority on this, but AFAIR NetworkManager (backend) aka KNetworkmanager (GUI frontend) can perform WPA authentication without wpa_supplicant, which was not true a few months ago. Despite this, I still have wpa_supplicant installed on my machine. wpa_supplicant is not a service controlled by rc system it is pulled in by /etc/conf.d/net as a dependency (I think). So your network scripts are informed to use wpa_supplicant and pass some options to the program which is controlled by the gentoo net scripts.

But, because of the new OpenRC, wpa_supplicant can get in the way of NetworkManager sometimes (at least with the broadcom chips using b43 module), not your guys' case I know. So you can have like three instances of wpa_supplicant all fighting together for control of WPA authentication, which prevents authentication and gives an error of device busy. You can fix it by killing the first instance of wpa_supplicant, but this doesn't mean that it goes away entirely, just that the gentoo net scripts restart wpa_supplicant as a single instance and it functions normally.

I realize this is a little OT, but just trying to clear up how I think this all works for you guys.
chickpea
Sagely Hen
 
Posts: 1084
Joined: Fri Jan 05, 2007 15:08
Location: Washington, DC

Re: No wireless ipw3945 after upgrading kernel to 2.6.25

Postby chickpea » Wed May 21, 2008 18:16

Fitz:

I went back over your posts in the OpenRC thread and found this:

# ls -l /sys/class/net
total 0
drwxr-xr-x 4 root root 0 2008-05-20 15:12 eth0
drwxr-xr-x 5 root root 0 2008-05-20 15:12 eth1
drwxr-xr-x 4 root root 0 2008-05-20 15:12 lo
drwxr-xr-x 4 root root 0 2008-05-20 15:12 wmaster0


Maybe try linking wmaster0 to net.lo ? Could that be an issue? I know that it is an issue with b43 which also has a wmaster0 wifi control device.

Code: Select all
[email protected] ~ $ sudo iwconfig
Password:
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"Nosso"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:0F:B5:6C:B6:84
          Bit Rate=54 Mb/s   Tx-Power=27 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX (edited for secrecy)
          Link Quality=89/100  Signal level=-58 dBm  Noise level=-73 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

[email protected] ~ $ sudo ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1b:24:54:04:da
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:20 Base address:0xc000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:878 errors:0 dropped:0 overruns:0 frame:0
          TX packets:878 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1227133 (1.1 MiB)  TX bytes:1227133 (1.1 MiB)

wlan0     Link encap:Ethernet  HWaddr 00:1a:73:6b:51:09
          inet addr:192.168.1.6  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::21a:73ff:fe6b:5109/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1478375 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1658878 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:699107424 (666.7 MiB)  TX bytes:573824298 (547.2 MiB)

wmaster0  Link encap:UNSPEC  HWaddr 00-1A-73-6B-51-09-00-00-00-00-00-00-00-00-00-00
          inet addr:169.254.26.252  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

[email protected] ~ $



Code: Select all
[email protected] ~ $ ls -la /etc/init.d/net.*
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.aol -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.ath0 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.ath1 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.ath2 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.ath3 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.ath4 -> net.lo
lrwxrwxrwx 1 root root     6 2008-05-07 21:24 /etc/init.d/net.eth0 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.eth1 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.eth2 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.eth3 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.eth4 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.eth5 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.eth6 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.eth7 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.eth8 -> net.lo
-rwxr-xr-x 1 root root 14671 2008-05-17 13:01 /etc/init.d/net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.ppp0 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.ppp1 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.ppp2 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.ppp3 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.ra0 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.ra1 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.ra2 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.ra3 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.ra4 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.ra5 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.wlan0 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.wlan1 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.wlan2 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-24 15:44 /etc/init.d/net.wlan3 -> net.lo
lrwxrwxrwx 1 root root     6 2008-05-07 21:42 /etc/init.d/net.wmaster0 -> net.lo
[email protected] ~ $
chickpea
Sagely Hen
 
Posts: 1084
Joined: Fri Jan 05, 2007 15:08
Location: Washington, DC

Re: No wireless ipw3945 after upgrading kernel to 2.6.25

Postby Fitzcarraldo » Wed May 21, 2008 22:19

Code: Select all
# cd /etc/init.d
# ln -s net.lo net.wmaster0
# ls -la net.*
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.aol -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.ath0 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.ath1 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.ath2 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.ath3 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.ath4 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.eth0 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.eth1 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.eth2 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.eth3 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.eth4 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.eth5 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.eth6 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.eth7 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.eth8 -> net.lo
lrwxrwxrwx 1 root root    18 2008-01-16 13:51 net.irda0 -> /etc/init.d/net.lo
-rwxr-xr-x 1 root root 14671 2008-05-12 17:29 net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.ppp0 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.ppp1 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.ppp2 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.ppp3 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.ra0 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.ra1 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.ra2 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.ra3 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.ra4 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.ra5 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.wlan0 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.wlan1 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.wlan2 -> net.lo
lrwxrwxrwx 1 root root     6 2008-01-16 13:14 net.wlan3 -> net.lo
lrwxrwxrwx 1 root root     6 2008-05-21 20:34 net.wmaster0 -> net.lo


But no change in the behaviour, unfortunately. Right-click on KNetworkManager, select my wireless network (or Connect to Other Wireless Network...' and specify it again), gets to 28% on the Activating Wireless Network Connection and sits there for a while then the pop-up changes to "Connection Failure, Could not connect to the network BTHomeHub-47BE".

Here's the tail of dmesg:

Code: Select all
[  165.590283] eth0: Link is Down
[  197.901863] eth1: Initial auth_alg=0
[  197.901874] eth1: authenticate with AP 00:14:7f:9b:09:1c
[  197.903775] eth1: RX authentication from 00:14:7f:9b:09:1c (alg=0 transaction=2 status=0)
[  197.903783] eth1: authenticated
[  197.903789] eth1: associate with AP 00:14:7f:9b:09:1c
[  194.858089] eth1: RX AssocResp from 00:14:7f:9b:09:1c (capab=0x411 status=0 aid=1)
[  194.858089] eth1: associated
[  194.858089] eth1: switched to short barker preamble (BSSID=00:14:7f:9b:09:1c)
[  194.861441] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[  201.813681] WEP decrypt failed (ICV)
[  204.779858] WEP decrypt failed (ICV)
[  205.360975] eth1: no IPv6 routers present
[  206.283288] WEP decrypt failed (ICV)
[  210.158993] eth0: Link is Up 10 Mbps Half Duplex, Flow Control: None
[  210.159002] eth0: 10/100 speed: disabling TSO
[  210.160135] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  210.167659] WEP decrypt failed (ICV)
[  210.663827] WEP decrypt failed (ICV)
[  211.653334] WEP decrypt failed (ICV)
[  211.658751] WEP decrypt failed (ICV)
[  211.799377] WEP decrypt failed (ICV)
[  211.802400] WEP decrypt failed (ICV)
[  212.299149] WEP decrypt failed (ICV)
[  212.494909] WEP decrypt failed (ICV)
[  212.869421] WEP decrypt failed (ICV)
[  219.525005] printk: 5 messages suppressed.
[  219.525005] WEP decrypt failed (ICV)
[  220.507009] eth0: no IPv6 routers present
[  232.328165] WEP decrypt failed (ICV)
[  235.265663] WEP decrypt failed (ICV)
[  235.816368] WEP decrypt failed (ICV)
[  241.351407] eth1: deauthenticate(reason=3)
[  238.357839] ACPI: PCI interrupt for device 0000:05:00.0 disabled
[  243.557715] ACPI: PCI Interrupt 0000:05:00.0[A] -> GSI 19 (level, low) -> IRQ 19
[  243.557878] PM: Writing back config space on device 0000:05:00.0 at offset 1 (was 100002, writing 100006)
[  239.461565] Registered led device: iwl-phy0:radio
[  239.461596] Registered led device: iwl-phy0:assoc
[  239.461615] Registered led device: iwl-phy0:RX
[  239.461634] Registered led device: iwl-phy0:TX
[  243.600432] ADDRCONF(NETDEV_UP): eth1: link is not ready
[  254.775330] eth0: no IPv6 routers present
[  698.310127] ACPI: PCI interrupt for device 0000:05:00.0 disabled
[  714.705311] eth0: no IPv6 routers present
[  719.543902] ACPI: PCI Interrupt 0000:05:00.0[A] -> GSI 19 (level, low) -> IRQ 19
[  719.544065] PM: Writing back config space on device 0000:05:00.0 at offset 1 (was 100002, writing 100006)
[  719.585541] Registered led device: iwl-phy0:radio
[  719.586108] Registered led device: iwl-phy0:assoc
[  719.586256] Registered led device: iwl-phy0:RX
[  719.587532] Registered led device: iwl-phy0:TX
[  719.592259] ADDRCONF(NETDEV_UP): eth1: link is not ready


Notice the "WEP decrypt failed (ICV)". And this also when I specifically do the 'Connect to Other Wireless Network...' and select WPA Personal. Why, oh why, is it trying to use WEP?
* Holds head in hands. *

I don't know whether it's relevant, but my LED behaves differently now than it did with the old, working ipw3945 module and the 2.6.22 kernel. Before, the LED used to pulse slowly when I switched the Kill Switch off. Then when I selected a network via KNetworkManager the LED would start to flicker fast, and then the LED would stay on permanently once connection was established. Now the LED is on permanently when the Kill Switch is off. Actually it does pulse sometimes but I can't see any pattern to it.

Something else I've just noticed: one of my neighbours has a WEP-encrypted router. When I select it via KNetworkManager, KNetworkManager only offers the three usual WEP options (WEP Passphrase, WEP 40/104-bit hex, WEP 40/104-bit ASCII). I don't know his passphrase, so of course cannot proceed further. Another neighbour has a WPA-encrypted router. When I select it via KNetworkManager, KNetworkManager only offers me the single option WPA Personal (I don't know his password, so of course cannot proceed further.). So KNetworkManager must surely understand the protocols.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: No wireless ipw3945 after upgrading kernel to 2.6.25

Postby chickpea » Wed May 21, 2008 22:26

I'm beginning to wonder if your wireless card is reporting itself correctly, or is somehow different from other ipw3945 cards. Sometimes motherboard vendors can play evil tricks with wireless cards in laptops.
chickpea
Sagely Hen
 
Posts: 1084
Joined: Fri Jan 05, 2007 15:08
Location: Washington, DC

Re: No wireless ipw3945 after upgrading kernel to 2.6.25

Postby chickpea » Wed May 21, 2008 22:31

I think you should post something on the linuxwireless dev listserv. This is just way beyond me. See if anyone of them can come up with something intelligent

http://www.linuxwireless.org/

I'm afraid that I'm just going to have your chasing your tail at this point. Sorry. :(
chickpea
Sagely Hen
 
Posts: 1084
Joined: Fri Jan 05, 2007 15:08
Location: Washington, DC

Re: No wireless ipw3945 after upgrading kernel to 2.6.25

Postby Fitzcarraldo » Wed May 21, 2008 22:37

* Falls off chair. * LMAOROTF

I've found the problem. And there is not an emoticon big enough to show my embarrassment. :oops: :oops: :oops:

My previous post about my neighbours' WEP and WPA networks got me thinking, and I decided to have a look at the wireless configuration in my hub. It was WEP!!! How? Who? When?

It turns out one of my children, who is currently working in France for a few months and departed before I got back last week from a work trip overseas, had trouble while I was away connecting her Windows XP laptop to the Internet via WiFi and performed a hard-reset on the hub (and, from what I can see in the hub, it looks like she may have been trying to change the wireless configuration in the hub too). But nobody told me!! I've just spent four days breaking my back rebuilding kernels and editing network configuration files, and posting here wasting you guys' time. My apologies, big time. :roll:
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

PreviousNext

Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest