Problem with USB CT-WN4320Z (chip ZD1211)

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Problem with USB CT-WN4320Z (chip ZD1211)

Postby keteflips » Sun Mar 02, 2008 18:20

Hi all.

I have this USB card.
When I connect it I get this message in /var/log/messages:

Code: Select all
Mar  2 18:08:26 moya rc-scripts: net.eth2 is not allowed to be hotplugged
Mar  2 18:08:40 moya [ 2281.402669] usb 1-3.4: new high speed USB device using ehci_hcd and address 9
Mar  2 18:08:40 moya [ 2281.490267] usb 1-3.4: configuration #1 chosen from 1 choice
Mar  2 18:08:40 moya NetworkManager: <debug> [1204481320.500166] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/usb_device_ace_1211_noserial_3').
Mar  2 18:08:40 moya NetworkManager: <debug> [1204481320.524340] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/usb_device_ffffffff_ffffffff_noserial').
Mar  2 18:08:40 moya [ 2281.566475] usb 1-3.4: reset high speed USB device using ehci_hcd and address 9
Mar  2 18:08:40 moya [ 2281.654303] zd1211rw 1-3.4:1.0: eth2
Mar  2 18:08:40 moya NetworkManager: <debug> [1204481320.668963] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/net_00_c0_a8_af_39_54').
Mar  2 18:08:40 moya rc-scripts: net.eth2 is not allowed to be hotplugged
Mar  2 18:08:40 moya [ 2281.761362] zd1211rw 1-3.4:1.0: firmware version 4605
Mar  2 18:08:40 moya [ 2281.801317] zd1211rw 1-3.4:1.0: zd1211 chip 0ace:1211 v4330 high 00-c0-a8 RF2959_RF pa0 g7---
Mar  2 18:08:41 moya [ 2282.803813] zd1211rw 1-3.4:1.0: error ioread32(CR_REG1): -110


When I disconnect the card this other:

Code: Select all
Mar  2 18:09:26 moya NetworkManager: <info>  Deactivating device eth2.
Mar  2 18:09:26 moya NetworkManager: <WARN>  nm_device_802_11_wireless_get_mode(): error getting card mode on eth2: No such device
Mar  2 18:09:27 moya NetworkManager: <debug> [1204481367.017043] nm_hal_device_removed(): Device removed (hal udi is '/org/freedesktop/Hal/devices/usb_device_ffffffff_ffffffff_noserial').
Mar  2 18:09:27 moya NetworkManager: <debug> [1204481367.017116] nm_hal_device_removed(): Device removed (hal udi is '/org/freedesktop/Hal/devices/usb_device_ace_1211_noserial_3_usbraw').
Mar  2 18:09:28 moya rc-scripts: net.eth2 is not allowed to be hotplugged


I have the module loaded:

Code: Select all
moya ~ # lsmod |grep zd1211rw
zd1211rw               58120  0
ieee80211softmac       31488  1 zd1211rw
ieee80211              35400  2 zd1211rw,ieee80211softmac



And but when I start it:

Code: Select all
moya ~ # /etc/init.d/net.eth2 start
 * Starting eth2
 *   Configuration not set for eth2 - assuming DHCP
 *   Bringing up eth2
 *     dhcp
 *       network interface eth2 does not exist
 *       Please verify hardware or kernel module (driver)                                                                      [ !! ]
moya ~ #



What I can do? sure, its a easy solution but im newbie in advanced network configuration.

Thanks a lot :)
Image
keteflips
Growing Hen
 
Posts: 147
Joined: Mon Mar 19, 2007 19:24

Re: Problem with USB CT-WN4320Z (chip ZD1211)

Postby keteflips » Sun Mar 02, 2008 18:31

And why net.eth2 and not wlanX ¿?
Image
keteflips
Growing Hen
 
Posts: 147
Joined: Mon Mar 19, 2007 19:24

Re: Problem with USB CT-WN4320Z (chip ZD1211)

Postby keteflips » Mon Mar 03, 2008 10:23

No body cant help me¿?

I see a problem, the module its not auto loaded, then I added to autoload.
Image
keteflips
Growing Hen
 
Posts: 147
Joined: Mon Mar 19, 2007 19:24


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 2 guests