Cannot connect to WPA Enterprise WLAN

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Cannot connect to WPA Enterprise WLAN

Postby plopkus » Tue Jan 22, 2008 15:33

Hello,
I am new to sabayon, and still knew to Linux. I recently migrated from debian etch and I am liking sabayon. My problem is that I cannot connect to WPA Enterprise (my schools wireless network). My problem seems to arise with the CA certificate. After hours of googling and following others' howtos I still cannot connect.

I am running sabayon 3.4f on a dell insipron 2200 with an internal bcm43xx wireless card and I have a netgear WG511T PCMCIA wireless card. Both support WPA Ent in windows. I use Knetworkmanager and the wireless broadcasts are recognized. When I setup the wireless connection ("Connect to other wireless networks...") I enter the SSID, select EPA Enterprise encryption, enter my username and PW. I have tried many many combinations of the EAP Method and Phase Two options to no avail.

The online tuts keep pointing me toward the CA certificate, which other schools have generously posted for download. However, my school does not. The NetAdmin at my school says they have no certificate and that the wireless security is purely based on the login credentials. They are running both WPA1 (TKIP) and WPA2 (AES).

Please, what advice do you have for me?? How can I get connected to the wireless.
Thank you in advance for your help and I will post any info requested to aid in this process.
plopkus
Baby Hen
 
Posts: 3
Joined: Wed Jan 16, 2008 13:02

Re: Cannot connect to WPA Enterprise WLAN

Postby chickpea » Tue Jan 22, 2008 22:32

Have you tried just straight up WPA1 connection (no enterprise stuff). From what your sysadmin says, it sounds like just plain WPA1 to me. Just try normal WPA, maybe you get lucky?
chickpea
Sagely Hen
 
Posts: 1084
Joined: Fri Jan 05, 2007 15:08
Location: Washington, DC

Re: Cannot connect to WPA Enterprise WLAN

Postby plopkus » Wed Jan 23, 2008 17:45

THanks for the Reply!!!!

In Knetworkmanager I can choose either WPA1 or 2, but I still must select WPA Personal or WPA Enterprise. I can connect to the testing network I have setup with WPA1 Personal. I have tried many variations involving the TLS, TTLS, MSCHAPv2, TKIP AES, etc. to no avail.

Connecting via WPA1 to the network still requires the CA cert. It is a difficult wall to overcome. I tried creating the CA cert but that didn't work (possibly a user error though).

I am quickly cluttering up my system with various attempts and apps so I may need to reinstall to get a fresh start.
plopkus
Baby Hen
 
Posts: 3
Joined: Wed Jan 16, 2008 13:02

Re: Cannot connect to WPA Enterprise WLAN

Postby plopkus » Fri Jan 25, 2008 18:51

I have almost solved the problem.
I updated knetworkmanager and was able to connect with the netgear card. still unable to connnect with the broadcom card, but I am not so upset.
plopkus
Baby Hen
 
Posts: 3
Joined: Wed Jan 16, 2008 13:02

Re: Cannot connect to WPA Enterprise WLAN

Postby chickpea » Fri Jan 25, 2008 19:19

so from your reply I can assume that trying WPA1 personal does not work on your schools wireless? You tried it right? That was my point. Seems like your sysadmin was saying that simple (non-enterprise) WPA should work. But then again, what do I know.
chickpea
Sagely Hen
 
Posts: 1084
Joined: Fri Jan 05, 2007 15:08
Location: Washington, DC


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 2 guests