Page 1 of 1

Madwifi 0.9.4 on x86 architecture?

Posted: Sat Jan 12, 2008 11:53
by PaulFXH
Perhaps this is a newbie question but I still need to know.
I'm using Sabayon 3.4f on a new MacBook (Atheros chipset on wifi card). The wireless driver that was automatically installed was madwifi 0.9.4
Now if I look in Kuroo for this driver it says: 0.9.4 (Not on x86)
What does "(Not on x86)" imply?
Sounds perhaps like I shouldn't have it on my machine which has this architecture or have I misinterpreted something?

Re: Madwifi 0.9.4 on x86 architecture?

Posted: Sat Jan 12, 2008 12:35
by WarraWarra
Actual answer = /etc/make.conf look for x86 or ~x86
x86= stable software
~x86 = unstable or testing software will be used / installed.
3.4F is default ~x86 and not related to specific hardware ie: ppc or arm or x86 only to stable software or non stable / testing.

You can change from x86 to ~x86 or vica versa but have to emerge --sync after change and tehn install new software if needed to make it recognize the changes or at least used to work like this in my laptop. This will result in lots more software available + updates and stuff but could make it a bit more unstable or like windows normal LOL.

Re: Madwifi 0.9.4 on x86 architecture?

Posted: Sat Jan 12, 2008 15:45
by PaulFXH
OK, thank you for that comprehensive reply.
Seems I was barking up the wrong tree :?
Paul

Re: Madwifi 0.9.4 on x86 architecture?

Posted: Sun Jan 13, 2008 9:57
by WarraWarra
No problem I found this out by accident as well.

We have a newby guide think it is linked close to ibiblio.org pic below my posts or in the wiki "how-to" encyclopedia type thingy top right of this page that would help explain some stuff and have interesting info.

Don't be so hard on yourself this / gentoo based distro's is more difficult to learn but once you know it any linux is dirt easy. That is why the team is working on 3.5 beta + equo and other stuff to make live easier and faster etc. You can also do stuff with gentoo / source linux that most other Linux based distro's like windows / osx / whatever else can not do.