How to start wireless at boot

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Post Reply
PaulFXH
Baby Hen
Posts: 15
Joined: Wed Jan 09, 2008 23:46

How to start wireless at boot

Post by PaulFXH » Fri Jan 11, 2008 1:54

I'm running Sabayon 3.4f on a MacBook C2D (Wireless card has Atheros chipset).
Wireless works OK (can't really say more than "OK") but what's really annoying is that it has to be started up manually after every boot.
I saw that running this

Code: Select all

 rc-update add net.ath0 default
should allow my wireless to automatically connect on boot.
But, 'fraid not, it doesn't.
Anybody know how to do this?

freeallbadgers
Growing Hen
Posts: 181
Joined: Sun Mar 11, 2007 8:12
Location: Glasgow, UK.
Contact:

Re: How to start wireless at boot

Post by freeallbadgers » Fri Jan 11, 2008 8:59

“I just finished compiling glibc and now it says there is a new update available? Arrgh! It never ends!!”

PaulFXH
Baby Hen
Posts: 15
Joined: Wed Jan 09, 2008 23:46

Re: How to start wireless at boot

Post by PaulFXH » Sat Jan 12, 2008 1:16

OK, thanks for that link.
However, things have not improved. Indeed, the first page of your link provides the same advice to get wireless to connect on boot as I gave in my first post but I still can't get this to work
I tried also many of the suggestions in the wifi section (4.3) of this guide http://gentoo-wiki.com/HARDWARE_Apple_MacBook but always with the same negative result.
Actually, I have the feeling now that because I have tried so many things to get wireless to connect at boot, I probably have some conflicting commands/instructions on my system. Maybe it's time to clean up everything, and start afresh. However, I'm not quite sure how to do this wihout totally messing up my network configuration.
Any clues?

Post Reply