DNS lookup fails in browser but not in nslookup? [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Post Reply
Baby Hen
Posts: 1
Joined: Tue Dec 18, 2007 21:10

DNS lookup fails in browser but not in nslookup? [Solved]

Post by -CL- » Tue Dec 18, 2007 21:22

when I try to connect to a site using firefox it can't find it.
but if i connect to that site using its ip in stead of the domain name it can connect and successfully loads the site.
I figured it was a dns problem so i rechecked my settings but they were all fine.
when i tried to verify that the problem was indeed the dns using the nslookup command,
it succesfully contacted the dns according to my settings and retrieved the ip without a problem.

so now i am clueless as to how my browser cant do a dns lookup but i can using a shell command.

this gives me two main questions:

1 Am i right when i say the problem is dns related and then why does a manual lookup succeed?

2 how do i fix this so i can use the internet normally?

(the dns server in /etc/resolv.conf is correct.)

Found solution on this toppic:
http://www.sabayonlinux.org/forum/viewt ... =52&t=9677

this thread can be closed.

Post Reply