Page 1 of 1

Knetworkmanager a nuisance!

PostPosted: Tue Sep 04, 2007 6:28
by Shanghaied
I'm running 3.4a all packages updated (not downgraded!) to stable if available otherwise untouched.
Hardware is a Dell Inspiron XPS Gen2 using a wireless Intel Pro b,g (driver IPW2200).
My wireless network is using WPA encryption (I filled in the Key first time only it doesn't ask for it anymore which is fine by me).
Everytime I boot I have to click twice on the knetwork manager icon to select my network then after approximately 30 seconds it disconnects and I have to click it a third time to reconnect and after that it stays! Every time same procedure totally three times to click to connect ?? :shock:
I have tried with other unencrypted networks and it connects automatically.
Anyway it works it's just annoying so if anyone has any ideas it would be much appreciated!!

Re: Knetworkmanager a nuisance!

PostPosted: Wed Sep 05, 2007 11:36
by Fitzcarraldo
The following helped in my case (SL x86-64 3.4 Loop 2b):

1. Edit the file /etc/portage/package.use and add the following line for avahi (or add the following USE flags to the line for avahi, if it already exists):

Code: Select all
net-dns/avahi howl-compat mdnsresponder-compat

2. Type the following commands as root:

Code: Select all
emerge -C mDNSResponder
emerge avahi

Re: Knetworkmanager a nuisance!

PostPosted: Thu Sep 06, 2007 15:17
by Shanghaied
Thanks but it didn't work for me.
Mdnsresponder was already uninstalled due to a conflict the flags was also already set.
I also updated to latest avahi (compiling with the flags you mentioned) but knetwork manager is still acting weird.

Re: Knetworkmanager a nuisance!

PostPosted: Mon Sep 17, 2007 16:25
by Shanghaied
If I store my wpa password in the wallet instead of unencrypted it seems to work better now the only nuisance is that when I connect I have to key in my wallet password.

Re: Knetworkmanager a nuisance!

PostPosted: Wed Sep 19, 2007 4:51
by WarraWarra
I have a ipw3945 = closest I have to yours and 3.4f now running.
E1705 / 9400 , 7950gtx + extra 7800gtx dell 1390 laying around.
Look at knetwork the 2nd option instead of the first could be that it uses different source code for both or something and is causing the issues. No Idea. I presume you checked the signal quality or if the mac address is blocked or not in the router.
The intel wifi cards is sensitive to bad signal quality or more so than the broadcom bcm43xx types = weaker signal and more failed connections. Ebay has the dell 1390 for $13.50 + shipping or there about and is worth the upgrade if you need to.

Also check one of the dhcp versions gave us hell a few months ago. Think it was 3.0.8 not sure.

Code: Select all
      Latest version available: 3.0
      Latest version installed: 3.0
      Size of files: 263 kB
      Description:   Firmware for the Intel PRO/Wireless 2200BG/2915ABG miniPCI and 2225BG PCI adapters
      License:       ipw2200-fw

Code: Select all
      Latest version available: 0.2_p20070831
      Latest version installed: [ Not Installed ]
      Size of files: 411 kB
      Description:   A KDE frontend for NetworkManager
      License:       GPL-2

*  net-misc/knetworkmanager
      Latest version available: 0.2_pre20070702-r1
      Latest version installed: 0.2_pre20070702-r1
      Size of files: 338 kB
      Description:   A NetworkManager front-end for KDE
      License:       GPL-2

Code: Select all
      Latest version available: 3.1.0
      Latest version installed: 3.0.5-r1
      Size of files: 778 kB
      Description:   ISC Dynamic Host Configuration Protocol
      License:       isc-dhcp

*  net-misc/dhcpcd
      Latest version available: 3.1.5
      Latest version installed: 3.1.5
      Size of files: 39 kB
      Description:   A DHCP client
      License:       GPL-2

Code: Select all
      Latest version available: 0.1.2
      Latest version installed: 0.1.2
      Size of files: 738 kB
      Description:   DNS Service Discovery kioslave using Avahi (rather than mDNSResponder)
      License:       GPL-2

*  net-dns/avahi
      Latest version available: 0.6.21
      Latest version installed: 0.6.18
      Size of files: 953 kB
      Description:   System which facilitates service discovery on a local network
      License:       LGPL-2.1

Code: Select all
      Latest version available: 12-r5
      Latest version installed: 12-r5
      Size of files: 31,296 kB
      Description:   Eric Welsh's GUS patches for TiMidity
      License:       as-is

*  net-wireless/wpa_supplicant
      Latest version available: 0.5.8
      Latest version installed: 0.6.0-r10
      Size of files: 697 kB
      Description:   IEEE 802.1X/WPA supplicant for secure wireless transfers
      License:       || ( GPL-2 BSD )

See if you can get yours to this as my ipw3945 works fine maybe your ipw2200 could as well by cloning it to this.

Hope this helps.

Re: Knetworkmanager a nuisance!

PostPosted: Wed Sep 19, 2007 18:14
by sjieke
I had the exact same problem. Needed to click connect 2 or 3 times before it worked. But thanks to WarraWarra I found a solution. The packages installed were the same as WarraWarra, so I thought wy not try 'kde-misc/knetworkmanager' instead of 'net-misc/knetworkmanager' and it worked. Now knetworkmanager automatically connects on login :D

For the ones needing a step by step guide:
1) Re-emerge the package currently installed to make sure you have the files downloaded and it compiles installs correct. To be able to revert back without internet connection.
Code: Select all
emerge net-misc/knetworkmanager

2) Close knetworkmanager
Code: Select all
right-click the icon in the system-tray and choose quite

3) Remove the package
Code: Select all
emerge -C net-misc/knetworkmanager

3) Now install the other package
Code: Select all
emerge kde-misc/knetworkmanager

4) Start knetworkmanager
Code: Select all
In SabayonMenu -> Applications -> Internet -> KNetwork Manager
In KMenu -> Internet -> KNetwork Manager

5) Everything should work now, to test the autoconnect on login
a) Make sure you are connected to a network
b) reboot

Re: Knetworkmanager a nuisance!

PostPosted: Fri Sep 21, 2007 7:35
by Shanghaied
Warra Warra,
It's not a problem with stability once I have clicked three times it's rock solid no disconnects.
As I said above changing knetwork manager to the other option encrypted (wallet) I only have to click once and then key in my wallet password but if I use the option unencrypted (I still have the password in the router and it's different from my wallet password) I have to click three times. In debian distros like Ubuntu there is a workaround to not have to key in the password every time using Pam (which would be same as option disable wallet) and it would auto login just like winblows.

Sound like you had the same annoyance as I. I will try your tip and emerge the other knetwork manager and see if the auto logon works.
Why are they different?

Re: Knetworkmanager a nuisance!

PostPosted: Fri Sep 21, 2007 8:49
by WarraWarra
No idea have not yet figured it out why the difference.

It should first time connect and then always keep the pass phrase / word , but think the other knetworkmanager is the fix for your problem.

Re: Knetworkmanager a nuisance!

PostPosted: Fri Sep 21, 2007 21:57
by Fitzcarraldo
^If one uses the KDE Wallet, it is supposed to ask for a password (nothing to do with the WPA or WEP password) after you log in and first fire up WiFi. Which it correctly does.

Although net-misc/knetworkmanager was working fine on my laptop, by chance last week I too noticed that there is a kde-misc/knetworkmanager in Portage when I rebuilt the entire KDE software (don't ask). So out of curiosity I decided to uninstall the net-misc/knetworkmanager version and install the kde-misc/knetworkmanager version. It also works fine on my laptop. I can't see any difference in performance between the two, but I'll use it for a few days and make a final judgement then. Anyway, they both seem to work so, like Shanghaied, I'm curious why there are two versions and what the difference is (if any).

Re: Knetworkmanager a nuisance!

PostPosted: Sun Sep 23, 2007 0:47
by Fitzcarraldo
OK, from the little I have read about this so far on the Web, my guess is that the net-misc version was created by the SL devs because KNetworkManager was not put in the Gentoo Portage repository until recently. Then the Gentoo devs added KNetworkManager to Portage under kde-misc. So my hunch is that the kde-misc version is the one to choose as it's more likely to be a later version of KNetworkManager than the net-misc one.