Problem with atheros

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Post Reply
markorians
Baby Hen
Posts: 4
Joined: Sun Feb 12, 2017 14:02

Problem with atheros

Post by markorians » Sat Feb 18, 2017 19:32

Hi,
I can't use wpa_supplicant it tell me that I use a wrong key.
But if I boot in safe mode wpa_supplicant works.
Any ideas ???

Please help

markorians
Baby Hen
Posts: 4
Joined: Sun Feb 12, 2017 14:02

Re: Problem with atheros

Post by markorians » Sun Feb 19, 2017 17:43

I solved in this way:
( I use sabayon minimal )
- fresh install of system
- equo update && equo upgrade
- reboot
- equo i networkmanager
- reboot

User avatar
sabayonino
Sagely Hen
Posts: 3182
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Problem with atheros

Post by sabayonino » Sun Feb 19, 2017 19:18

markorians wrote:I solved in this way:
( I use sabayon minimal )
- fresh install of system
- equo update && equo upgrade
- reboot
- equo i networkmanager
- reboot
is networkmanager service enabled ?

Code: Select all

# systemctl enable NetworkManager
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

markorians
Baby Hen
Posts: 4
Joined: Sun Feb 12, 2017 14:02

Re: Problem with atheros

Post by markorians » Thu Feb 23, 2017 19:28

sabayonino wrote:
markorians wrote:I solved in this way:
( I use sabayon minimal )
- fresh install of system
- equo update && equo upgrade
- reboot
- equo i networkmanager
- reboot
is networkmanager service enabled ?

Code: Select all

# systemctl enable NetworkManager
Yep !
I never use network manager as my default options.
4 days ago I have discovered this service and I disable them
because it busy wext and nl80211 driver and cause me trouble.
After disabled I configure my wpa_supplicant.conf
and i enable this service

Code: Select all

# systemctl enable [email protected]
This start a wpa association at boot and if I want
I connect with dhcpcd (dhclinet has seg fault).

This is strange for me because dhcpcd not have the hook to auto
call wpa supplicant. In archlinux i enable only [email protected]
service, little different but not a problem :D

Post Reply