Update installer not version specific ?

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Update installer not version specific ?

Postby Raqua » Fri Aug 31, 2007 11:30

Hello.

I recently installed Sabayon mini 3.3 on another computer of mine. I installed 3.3 because I wanted mini version and 3.4 mini seems to be somehow delayed. I am now trying to do world update on that system which is quite fun and a good learning experience. :D

One thing I noticed was, that right after installation, some things were not configured as they should. I had to fix those, which I managed to do. Is it possible, that it is due to installer being upgraded and suited for 3.4 version not 3.3 anymore ? When I installed 3.3 mini on my main machine I installer did not let me to choose which packages I want to omit, but this time it did, so maybe the installer is too new for 3.3 version ?

I think it would be better to leave some older installers to update to a specific version.

Some of the problems installer did not configure :

- Konsole prompt for root is localhost
- Could not log to KDE as user, but I could log as root. When I logged as user, I got error message (in X) - something like "Could not find Kstartupconfig". I am not sure about it, it was week ago . :? It was a permissions problem on one file. Or symlink ??

There were some more minor problems that I really do not remember, but you might get my point. :D
Raqua
Growing Hen
 
Posts: 175
Joined: Sun Apr 22, 2007 10:17

Re: Update installer not version specific ?

Postby WarraWarra » Fri Aug 31, 2007 21:27

Could be as there used to be one specific to 3.3 cd version and 1 for BE version .
I just use the default 3.3 cd install and once in hd version " emerge --sync ; emerge portage ; layman -S " as this should update the new and old files then you can update to latest corrected packages etc .
WarraWarra
Sagely Hen
 
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: Update installer not version specific ?

Postby Raqua » Fri Aug 31, 2007 21:53

This guy here viewtopic.php?f=57&t=9785
had the same problem when installing 3.4 version, so maybe it is not a problem of old version, but a bug in a installer.
Raqua
Growing Hen
 
Posts: 175
Joined: Sun Apr 22, 2007 10:17

Re: Update installer not version specific ?

Postby WarraWarra » Fri Aug 31, 2007 22:32

I am sure LX would look into it and fix what he can.
WarraWarra
Sagely Hen
 
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: Update installer not version specific ?

Postby Raqua » Sat Sep 01, 2007 23:33

This is another thing I had to fix and more people seems to have this problem.
viewtopic.php?f=50&t=9992
Raqua
Growing Hen
 
Posts: 175
Joined: Sun Apr 22, 2007 10:17

Re: Update installer not version specific ?

Postby Fitzcarraldo » Wed Sep 05, 2007 1:03

A couple of days ago I too discovered that Update Installer is not version-specific when I decided to adjust the sizes of my partitions and re-install SL x86-64 3.4 Loop 2b.

Although the updated installer would not let me select KDE and displayed the GNOME package selection page whatever I selected, I managed to re-install but I wonder if this would still be possible if there are further changes to the installer.

It could be useful to have the ability to update the installer on the LiveDVD/CD of a specific older version of SL to a specific installer version. Perhaps the updated version of the installer just before the next release of the SL LiveDVD could be saved to the mirrors each time a new version of SL is released?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7978
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 2 guests