cannot execute "/sbin/rc"

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Post Reply
Baby Hen
Posts: 15
Joined: Sat Sep 02, 2006 12:12

cannot execute "/sbin/rc"

Post by circleback » Sat Aug 18, 2007 4:37

I get the following error message when booting after I tried to upgrade the GCC (following guide)

cannot execute /sbin/rc

and it just stops

Sagely Hen
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Post by WarraWarra » Sat Aug 18, 2007 5:05

Could try to boot with the live dvd and then chroot into your installed SL and fix it using the -> manual -> x86 -> all in one page and should be chapter 5 about "chrooting"

Possible working options:
# gcc-config -l
# gcc-config 8

# env-update
# source /etc/profile
then rebuild the whole system / world , takes a long time then think test again and finally unmerge older gcc version , remeber to do the libsh ??? something to update something ??

I have had little or no luck doing it this way and 1100 prog's emerge later it starts on mine but ends up with several bug's and as root. Basically you have to know how and what to look for if doing it as there will be bugs and I do not have the patience / time to try and find / fix them in mine.
( Using mpentoo 208mb it has enlightenment , might be a good start as I had very good luck with gcc 4.2.0 and it in virtualbox. )

I think if you are going to try a total recompile you might as well build your own from scratch / stage3 and then only have a few progs installed / minimal + before restarting get gcc 4.2.0 in there and compile then build the kernel.
This seems to be the easier way + you can later pull in the layman -S and overlay's + SL art + you then know it works with your system / stable on your pc + add fancy parts of SL later. Eitherway it is small enough and uses little enough time this way to be able to delete it and start over where delete + start over on 3.4? is not really a option for me.

If doing it this way might as well have 2 partitions 1 for SL and another for this gcc4.2.x new stage3 version and copy the portage folder over / mount it and reuse the downloaded files in there.

Hope any of this makes sense or helps.

Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: cannot execute "/sbin/rc"

Post by wolfden » Sat Aug 18, 2007 15:31

circleback wrote:I get the following error message when booting after I tried to upgrade the GCC (following guide)

cannot execute /sbin/rc

and it just stops
Can you be less vague :?

Did you follow the how to on our wiki?
Did you recompile the kernel?
Did you update your profile?
Did you recompile all your packages?

I mean, what did you all do exactly???

Post Reply