problem with root device

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

problem with root device

Postby Stupot » Wed Aug 15, 2007 5:28

I'm attempting to install Sabayon on my sisters eMachines (yuck). Anyway, the LiveDVD worked fine and the installation went fine enough. After it installed I went straight to boot into Windows XP to make sure that worked fine. Well, it didn't, I saw my mistake, went back to the LiveDVD and did the bootloader recovery option.

Long story short, I can now boot into Windows XP just fine, but when I try to boot into Sabayon I get this message....

!! Block device /dev/disk/by-uuid/7f08e225-1ac5-423e-9609-e877d91d3af1 is not a valid root device...
!! The root block device is unspecified or not detected.

Any ideas? I tried looking at the grub.conf but I couldn't see where the problem was. This installation was using Loop3.
Stupot
Sagely Hen
 
Posts: 1538
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Postby dave_p_b » Thu Aug 16, 2007 4:52

Hi

If you look in the grub.conf file for the sabayon entry it might say something like real_root=/dev/disk/by-uuid/7f08e225-1ac5-423e-9609-e877d91d3af1
you can change it to read real_root=/dev/hda2 (or where ever your sabayon partition is).

All the best

Dave
dave_p_b
Old Dear Hen
 
Posts: 607
Joined: Fri Dec 15, 2006 1:39
Location: Exeter, UK

Re: problem with root device

Postby ka9qlq » Mon Sep 10, 2007 19:56

uuid is the worst idea I've heard of. I had problems mounting my swap drive in Kubuntu with it.
Alvin
ka9qlq
ka9qlq
Young Hen
 
Posts: 20
Joined: Sun Oct 01, 2006 18:07
Location: Columbus, INDIANA


Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 1 guest

cron