Page 2 of 5

Posted: Thu Jul 19, 2007 20:14
by edgevision
phzi wrote:This is a serious problem that still hasn't been corrected. I have manually partitioned my disks via the install program and via fdisk. Even with a manual setup, no LVM, this exception still occurs!

These bugs are all the same problem: (mine)

The only time I managed to get past this error, I received an error (not an exception) about being unable to initialize swap, and then anaconda exited.
I'm running into the exact same problems using the 3.4 loop3 installer. Was on the IRC channel yesterday and was told that it was my fault because I burned the DVD too fast. Burned it again at 1x, fired it up, same problem occurred. I'm not impressed. I've used the same DVD to install SL on 3 other systems, what could be different about this one?

Windows XP install CD detects and formats the drive no problem, scanned it for errors, bad sectors.. nothing. Next I'm going to try a GParted live CD or the Ultimate Boot CD... either way still pretty pissed that this won't work.

Posted: Thu Jul 19, 2007 20:17
by WarraWarra
It could be that SL still wanted to keep control of the hd and or did not recognize the changes .
It should have worked if you then rebooted with new partitions and once inside SL live update and again manual + format then it usually continues on mine.
In the bios something like a antivirus feature blocking writes to the MBR , my old desktop had something like this and even in windows it did not want to properly partition = disable this feature.

The terminal part how-to :
Only cfdisk / del , create and apply then reboot and once back inside either using gparted or installer let it format and to be sure reboot again just for the heck of it.
Then the installer must work and if a partition is already formated only add the /boot or swap or / to the partition config and "no format , leave as is" then continue to install.
If not sure then only format the /boot and root partitions as it might already use the swap ?

Sorry this is so nasty but it is trail and error until you got to the root of this.

As a last resort this will work:
It will install / run with only a root partition allocated and can later edit the swap space / mkswap but have to add it manually to /etc/fstab once inside the installed working SL. It might complain about no swap = ignore and continue. Just leave / create the space for a swap partition if going to use it this way.

Hope this helps.

Posted: Thu Jul 19, 2007 21:46
by lxnay
I just fixed the swap error :)
I'm trying to figure out if there's a way to workaround LVM failure, but they're often caused by a broken partition table. :(

Posted: Thu Jul 19, 2007 23:30
by phzi
lxnay wrote:I just fixed the swap error :)
I'm trying to figure out if there's a way to workaround LVM failure, but they're often caused by a broken partition table. :(
woot! Did it get pushed to installer updates, or do we have to wait for 4.3 Final?

I did an Installer Update, cleaned the partition table on my drive (I unplugged all drives except sda), and ran the installer - manually created 3 partitions from the installer. I get a swap error, although the 3 partitions seem to be created properly (fdisk shows them after).

Posted: Thu Jul 19, 2007 23:35
by lxnay
the updated installer will show up via the desktop icon tomorrow... time to rest a little bit now :)

Posted: Thu Jul 19, 2007 23:54
by JaymzGS
Well, even if it doesn't work for me... developer response = JOYGASM!

Posted: Fri Jul 20, 2007 0:13
by edgevision
Thanks, Ixnay. Your responsiveness is greatly appreciated.

Posted: Fri Jul 20, 2007 0:35
by WarraWarra
Any idea if the ext4 partitions after install I could now be booted form.

Think it was in 3.4 loop3 , 2 days before BE release. Have no tried it in BE.

LVM will see if I can find something.

Thanks for all the hard work.

Sorry I know you know all this but there might be something there that is missing in SL
" modprobe dm-mod "
Unmount "vgchange -a n"

This link has a fix not sure if it is a solution. ... _or_m.html ... e1#1542401
Bottom 2 post in last link looks good.

Hope it helps.

Posted: Fri Jul 20, 2007 12:13
by edgevision
I think I'll just wait it out for the installer update. Hopefully it's available today.

Posted: Sat Jul 21, 2007 22:05
by phzi
Still having the swap error after updating the installer. Ah well, time to go back to a gentoo system I guess.