Page 1 of 1

installer cannot create partition(s)

Posted: Wed Aug 28, 2019 16:42
by jyoung
I'm trying to setup Sabayon with manual partitioning, and I keep running into the error that the installer is unable to create partitions. I've been able to partition the disk with fdisk, so I'm sure that the physical device will accept partitioning. I've tried the option that says manual partitioning, and I've also tried the option to install on just one partition (after partitioning with fdisk).

The installer does succeed when I use the option to let it have the entire disk, so I think that the installer and the drive are working okay, I'm just doing something funny with the manual partitioning.

Re: installer cannot create partition(s)

Posted: Sat Aug 31, 2019 15:59
by Mercurybird
I was having an issue with this on a new install as well. I got around it by deleting the partition and creating a new one. Then formatted it. I was able to install this morning. But still getting the comreset issues in my other thread.

Re: installer cannot create partition(s)

Posted: Mon Sep 02, 2019 4:26
by jyoung
I tried deleting the old partitions with fdisk before starting the installer, no luck.

I eventually found that it's critical to check the 'root' box in the partition flags list when you create the root partition. This is a distinct action from just identifying the mount point as '/', which I'd done before.