Encrypted installation impossible with 19.03

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Post Reply
Freier Radikaler
Simple Hen
Posts: 54
Joined: Tue Dec 03, 2013 16:12

Encrypted installation impossible with 19.03

Post by Freier Radikaler » Tue Apr 30, 2019 22:43


I just tried to install an encrypted installation using the 19.03 liveDVD. Anaconda either crashes via a segfault or isn't able to generate the encrypted volumes. Could somebody try this? For me its reproducible. :cry:

Sagely Hen
Posts: 8200
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Encrypted installation impossible with 19.03

Post by Fitzcarraldo » Wed May 01, 2019 14:46

At the moment I don't have a spare machine to try an installation onto 'bare metal', but I have just now installed Sabayon Linux 19.03 KDE spin successfully onto an encrypted (AES-XTS256-PLAIN64 encryption cipher) virtual machine (VirtualBox), and it works correctly. Calamares (the LiveDVD does not use Anaconda) neither crashed nor had trouble producing the encrypted volumes in the virtual machine in my case.

Baby Hen
Posts: 1
Joined: Sun May 12, 2019 1:36

Re: Encrypted installation impossible with 19.03

Post by CarDGee » Sun May 12, 2019 1:45

Not sure if its the same bug but I seem to have this one https://github.com/calamares/calamares/issues/697 on both nvme and ssd I have tried daily builds and different versions like server mate etc.. and end up getting that same error message from the first post,

Baby Hen
Posts: 1
Joined: Mon Apr 28, 2014 2:01

Re: Encrypted installation impossible with 19.03

Post by reithdaeva » Sun Aug 25, 2019 2:50

I've also been having this issue with my laptop ssd on 19.03 KDE and all daily builds I've tried since. Just using the default partitions with encryption checked and calamares always chokes on the following command.

Code: Select all

cryptsetup -s 512 --batch-mode --force-password --type luks1 luksFormat /dev/sda3
I've tried different combinations of manual partitions but still end up with it dying on cryptsetup anyway. I found a couple similar sounding errors in the manjaro forums, but nothing that worked for me. I did notice that there was a CVE encryption affecting the calamares version the latest daily is using. It seemed easy enough to mitigate after install though.

Post Reply