Installed Sabayon on EFI system but it still boots Windows?

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Post Reply
Baby Hen
Posts: 2
Joined: Sat Mar 14, 2015 7:47

Installed Sabayon on EFI system but it still boots Windows?

Post by Bobbert » Thu Jan 28, 2016 0:04

I've disabled SecureBoot and installed Sabayon successfully on an EFI-based system, but when it restarted after the installation, the Windows bootloader booted up Windows. This is my first time ever having an EFI-based system, what am I missing?
For reference, the system is a brand new HP 15-p265TX, it came with Windows 8.1 but I let it upgrade to Windows 10 shortly after purchase then immediately installed Sabayon because Windows 10 is heinous. The Sabayon I used was 15.12 Xfce if that's pertinent.
What do I need to do to get Sabayon booting and/or offering me the option to boot into Windows? I've tried digging around in the "Boot from EFI file" but I can't see any options there that aren't in a folder named Microsoft or HP.

Thanks a lot for your help.

Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Installed Sabayon on EFI system but it still boots Windo

Post by wolfden » Sun Jan 31, 2016 20:28

I just ran into a similar situation with my new laptop. Sabyon live USB boots and installs just fine, but after restart the only option is windows boot manager. The issue I had was, the boot manage was unable to find the sabayon efi file.

I made 3 partitions /boot / and /swap all on a single drive, which also contained the windows layout partitions. This was my first time messing with uefi stuff so I was kinda lost. What helped me was refind boot manager, I made a live usb of it and booted it up and it found the sabayon efi file and was able to boot it.

Once I was in my installation I had to get familiar with the command efibootmanager. I used command blkid to view all my partitions to locate the efi boot system partion, which was /dev/sda2, which held the bootmgfw.efi. My grubx64.efi file was like on /dev/sda6 my /boot partition

So I decided to test something after mounting my /dev/sda2 to access the efi partition

Code: Select all

mount -t vfat /dev/sda2 /home/spongebob/mount/

Code: Select all

mv /home/spongebob/mount/EFI/Microsoft/Boot/bootmgfw.efi /home/spongebob/mount/EFI/Microsoft/
than copy and rename by current grubx64.efi to the efi partition

Code: Select all

cp /boot/efi/EFI/Sabayon_Linux/grubx64.efi /home/spongebob/mount/EFI/Microsoft/Boot/bootmgfw.efi
Rebooted the computer and it boot straight into sabayon without me have to do anything

So after that I figured I need to have both efi files in the same spot to be able to boot both so I removed the bootmgfw.efi and copied over the real bootmgfw.efi file I moved earlier

Code: Select all

rm /home/spongebob/mount/EFI/Microsoft/Boot/bootmgfw.efi

Code: Select all

cp /home/spongebob/mount/EFI/Microsoft/bootmgfw.efi /home/spongebob/mount/EFI/Microsoft/Boot/
than moved my grubx64.efi file to same spot

Code: Select all

cp /boot/efi/EFI/Sabayon_Linux/grubx64.efi /home/spongebob/mount/EFI/Microsoft/Boot/grubx64.efi
Now I had to provide the boot manager with a new entry telling it of my Sabayon location. Since my efi patition is sda2 I used the command

Code: Select all

efibootmgr -c -g -d /dev/sda -p 2 -w -L "Sabayon" -l /EFI/Microsoft/Boot/grubx64.efi
Reboot and now my boot manager sees both and able to boot both. I still need to use the boot option upon boot to tell which OS to boot too. I suppose I could add windows to my grub, but haven't gotten that far yet.

You may have to disable secure boot if you have issues booting usb drives. I used rufus to create my live usb and used the efi option when creating my live usb so I didn't have issues.

So I am assuming if one has windows partitions formated as pure efi the boot manager isn't going to pickup other systems. If the partition windows is on is partitioned efi/bios than it should work fine. If you are unsure how your partitions are, you can download and use easybcd run it in windows and if it errors out saying it can't do anything due to efi than you gonna have to do what I did, if the program doesn't have errors, the program can easily add you linux install to the windows boot manager.

Talk about a learning experience

Baby Hen
Posts: 4
Joined: Wed Oct 12, 2016 0:44

Re: Installed Sabayon on EFI system but it still boots Windo

Post by mr_y82 » Wed Oct 12, 2016 13:41

Wow Wolfden, thanks for that! I killed my Windows (intentionally), but if I ever decide I want it back....

I have an Acer Aspire-One (that unfortunately has Mint on it currently instead of Sabayon, or some other rolling distro... more about my problem installing here: viewtopic.php?f=50&t=33372&p=178427#p178427) that HAD windows 10... I tried several distros and, as stated by OP, Windows just kept loading even with "fast boot" (or whatever) turned off in Windows and UEFI secure boot setup as it should be...

I got the feeling that Microsoft was just trying to make life more difficult for those smart enough want a duel booting Linux box, and when my frustration reached it's pinnacle (and the methods of getting a dual boot seemed pretty tedious from my research) I decided to say "---- you Microsoft, and ---- you Windows"... I've only got a 60gb eMMC drive anyway, so I made a windows recovery usb on a 16gb Kingston flash drive and wiped Windows off the hard drive... GOOD RIDDANCE! I would have preferred to duel boot (all I really wanted windows for was the "maps" program that I could use offline), but I really got fed up with looking at Windows and did not want to spend anymore time using it instead of Linux... So it had to be obliterated... I just wish I had download the daily iso so I would be using Sabayon right now instead of trendy Mint (every rolling distro I tried had some sort of issue that steered me away, except Sabayon, which failed to boot after installation as described in the link above... I guess Sabayon will be waiting when I decide to try again!).

Well, I just lost an unrelated rant about how XFCE (and even Manjaro Fluxbox and others) desktop environments seem so much better than some of these newer ones... but I suppose retying it would be silly...


Post Reply