USB flash drive install issue with 15.01 (14.01 works!)

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

abadonna
Young Hen
Posts: 24
Joined: Mon Jun 21, 2010 5:49

USB flash drive install issue with 15.01 (14.01 works!)

Post by abadonna » Fri Jan 09, 2015 10:06

I am not sure if this is the right place to report this issue. If not, please move it.

There is a strange problem with latest (15.01) installation iso. I have tried to install it on Dell Latitude E7440 from USB flash drive. Whatever I have tried - failed with "Could not find CD to boot, something else needed."

I have also tried to install version 14.01 and this one works fine!

I am happy to provide more information, so please tell me what to provide in order to help you with fixing this bug in 15.01.

joost
Sagely Hen
Posts: 2778
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: USB flash drive install issue with 15.01 (14.01 works!)

Post by joost » Fri Jan 09, 2015 11:28

I bumped into the same issue using a very recently build daily -dev iso (MATE)
My blog | Mastodon | Please support Sabayon: Become a Patron

ph03
Young Hen
Posts: 30
Joined: Thu Oct 27, 2011 11:43

Re: USB flash drive install issue with 15.01 (14.01 works!)

Post by ph03 » Sun Jan 18, 2015 23:05

I have exactly the same problem installing 15.01 on UEFI Lenovo W540 with deactivated secure boot. Using 14.12 I get a different error: "Executing cdupdate.sh failed!" Is there a fix for this problem (using / correcting some kernel commands?)?

Where can I find older Sabayon versions, in particular the working 14.01? Every help on this is highly appreciated!

curse
Simple Hen
Posts: 53
Joined: Tue Jul 03, 2007 13:15
Location: Gran Canaria
Contact:

Re: USB flash drive install issue with 15.01 (14.01 works!)

Post by curse » Mon Jan 19, 2015 11:46

I got the "No CD" problem as well on MATE-dev.
At the time I was using USB-3 port, and remembered that sometimes USB-3 is wonky with installs, so I popped it in the USB-2 port, and got past it.(my laptop got 2xUSB3 and 1xUSB2)
However... Then X didn't start correctly or something, it just left me with a blank screen.
Gonna test with Gnome-dev now and see if it get past.

joost
Sagely Hen
Posts: 2778
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: USB flash drive install issue with 15.01 (14.01 works!)

Post by joost » Mon Jan 19, 2015 12:00

Hmm interesting!
I think you are correct, might be that the xhci-hcd module is not included in the initramfs.

I'll go see if I can test that properly. :mrgreen:

Thus far, trying both USB 2.0 and USB 3.0 ports and devices (tested visa versa) it still fails.

//Edit
If I disable USB 3.0 support in the BIOS and use a USB 2.0 port the system finally boots.
My blog | Mastodon | Please support Sabayon: Become a Patron

ph03
Young Hen
Posts: 30
Joined: Thu Oct 27, 2011 11:43

Re: USB flash drive install issue with 15.01 (14.01 works!)

Post by ph03 » Mon Jan 19, 2015 17:25

Great news! Will test it when I finish work, but that seems to be very related to my problem.

joost
Sagely Hen
Posts: 2778
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: USB flash drive install issue with 15.01 (14.01 works!)

Post by joost » Tue Jan 20, 2015 10:52

A perm. fix is on it's way.

https://github.com/Sabayon/genkernel-ne ... 6b5ed7e578

It might take a few days before the fixed images hit the mirrors.
My blog | Mastodon | Please support Sabayon: Become a Patron

curse
Simple Hen
Posts: 53
Joined: Tue Jul 03, 2007 13:15
Location: Gran Canaria
Contact:

Re: USB flash drive install issue with 15.01 (14.01 works!)

Post by curse » Tue Jan 20, 2015 11:53

Sweet, thanks joost.
Now, if I only could get it to start X so I can install it... What was the kernel parameter you could use to change what driver to use for AMD graphics?

joost
Sagely Hen
Posts: 2778
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: USB flash drive install issue with 15.01 (14.01 works!)

Post by joost » Tue Jan 20, 2015 13:47

xdriver=radeon

fglrx driver seem to be broken with GDM.
http://oliverchang.github.io/2014/12/22 ... ivers-gdm/
My blog | Mastodon | Please support Sabayon: Become a Patron

curse
Simple Hen
Posts: 53
Joined: Tue Jul 03, 2007 13:15
Location: Gran Canaria
Contact:

Re: USB flash drive install issue with 15.01 (14.01 works!)

Post by curse » Tue Jan 20, 2015 14:18

Thanks Joost!
Edit//
Managed to finally boot into the líve environment, however. that felt like I wasted a lot of time for no use on that, since the installer is broken and have been for months.
BugZilla https://bugs.sabayon.org/show_bug.cgi?id=4881
Forum post starting January 13, 2015viewtopic.php?f=50&t=32242
Forum post starting December 09, 2014 viewtopic.php?f=50&t=32185
Forum post starting December 17, 2014 viewtopic.php?f=50&t=32201
To show a few mentions of the error.

Anyone know a daily date when the installer worked? I might as well install that and update...
//Endedit

Post Reply