Page 1 of 1

Unable to install in legacy mode [Solved]

Posted: Mon Mar 10, 2014 23:50
by zeitdroid
Hi everybody.
Since i tried the sabayon kde 11 release on my old laptop i had not problems with that and i enjoyed it.
Now i got the new laptop and i'm getting crazy with installation troubles.
My laptop is an HP 15-b040sl (i5, intel hd4000+geforce630m,8gbRam,500GbSataHDD) with a preinstalled win8x64.
I did all the stuff to get ready with the downgrade to win7 and the installation of Sabayon. Gpt partition table was changed to normal partition table, win7 was installed succesfully, but i can't install Sabayon 14.01. When i set the partitions it always ask for a uefi boot partition that i don't need to have and i can't go on it.
So i tried to install the older release i had before (Sabayon KDE 11 wasn't UEFI ready so it had to be simpler) and i did it without any problems..untill i tried to upgrade the system using Rigo.When it cames with the latest updates available, after the reboot the system can't start X.
What i have to do?How i can install the 14.01 that could be better?
Many thanks.

Re: Installation problem

Posted: Tue Mar 11, 2014 10:14
by Provia
Hi zeitdroid!

Maybe you had problems updating Sabayon 11 because we have now switched to systemd.
Anyway, can you first try an new installation with the last monthly iso (14.03)?

Re: Installation problem

Posted: Tue Mar 11, 2014 20:15
by zeitdroid
oh..14.03?i give it a try!
thanks!

Re: Sabayon doesn't install install in legacy mode

Posted: Wed Mar 12, 2014 21:51
by zeitdroid
Ok i tried with 14.03 x64 kde and nothing changed.Always asking for a boot/uefi partition also in legacy mode installation. Please fix it.

Re: Sabayon 14.xx KDE x64 doesn't get installed in legacy mo

Posted: Mon Aug 04, 2014 19:07
by zeitdroid
Hi again, i want to notice to you that i tried sabayon xfce 14.08 and always i got an error while i'm partitioning.I use linux mint xfce and no problems..what's wrong?
Please HELP, it's unbelievable that i can't install my preferred linux distro!!

Re: Sabayon 14.xx KDE x64 doesn't get installed in legacy mo

Posted: Mon Mar 09, 2015 22:56
by zeitdroid
After all this time i'm happy to run again a sabayon distro on my laptop.
What i did? I finally understood that the partitioning program went crazy if i tried to create the partitions by myself. Don't ask me why, i really don't know it. But, if i'm not wrong the installation is very similar to the fedora one, so i don't know where is the difference if i were able to use fedora and many different distros too.
In the end i can say that, in legacy mode, if i try to set a default partition mode, i'm able to install sabayon only if i made before an unallocated disk space and let the system to be able to create the new partitions by itself after choosing the appropriated voice menu. After that, i need to manually modify them because it chooses, for example, to create a 8gb partition for the swap.
If i try to create every partition by myself the installation abort with an unknow problem.
That's it.