Acer C720 Chromebook (Haswell)

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Post Reply
Young Hen
Posts: 25
Joined: Sat Jan 25, 2014 19:20

Acer C720 Chromebook (Haswell)

Post by redwood » Sat Jan 25, 2014 21:36


I am trying to install Sayayon on an Acer C720 Chromebook.
I downloaded Sabayon_Linux_14.01_amd64_KDE.iso and
used unetbootin to make a bootable live usb stick.

I followed the Chrubuntu guide on how to dual boot linux on the Acer C720:

In developer mode I ran the installation script 9sgchs which
shrunk the ChromeOS artition down to 12G leaving 103G for Linux on my 128G M.2 (NGFF) mSSD.

After successfully rebooting, the reparitioning all went well.
So I stopped at Step #7 before installing the Chrubuntu OS in order to install Sabayon.

Pressing Ctrl-L for Legacy SeaBIOS mode, I got the SeaBIOS prompt to boot from either my SSD or pendrive.
So I chose the Sabayon liveusb pendrive, and at the Anaconda Menu chose to boot KDE,
pressed "tab" to edit the kernel commandline and added "mem=1536m" and then booted.
KDE loaded with everything working (except for the trackpad)
which I knew needed patching to work from IntelMiner's blog on installing Gentoo on the Acer C720:

I ran the Anaconda and installed LVM on top of /dev/sda7 with 3 logical volumes:

root / 30G
boot / 500M
home / 50G (encrypted with passphrase)
free ~ 32G of unused LVM space for future use

After completing successfully I then rebooted
and at the SeaBIOS prompt selected booting from my new Sabayon partition,
then the bootloader hangs:

Decompressing Linux... Parsing ELF...Performing relocations... done.
Booting the kernel.

So I rebooted from the Sabayon liveusb pendrive to try repairing the bootloader by adding the
mem=1536m kernel commandline option to /boot/grub/grub.cfg (as well as in /etc/default/grub)
I originally had /boot formatted as ext2, but Anaconda said it could migrate that to a better format,
so I said OK. (All it did was just change from ext2 to ext3). The next time running Anaconda
bootloader repair it said that the /boot was ext3 which didn't match fstab and so it then aborted :(
So I just edited /etc/fstab to change /boot to ext3 and reran the bootloader repair. This time all
went well.

But after rebooting, SeaBIOS hangs at the same spot.

Thanks for any ideas on getting Sabayon booting from the SSD and not just the pendrive.

Young Hen
Posts: 25
Joined: Sat Jan 25, 2014 19:20

Re: Acer C720 Chromebook (Haswell)

Post by redwood » Sat Jan 25, 2014 23:34

I'm going to try to repair this Sabayon installation
by type Ctrl-T to get a chrome shell "crosh"
then typing "shell"
and "sudo su -" to get root privileges.

Then get a chroot following Gentoo quick installation guide:

Code: Select all

mkdir /tmp/rfs
lvs && vgchange -ay
mount -t ext4 /dev/mapper/vg_sabayon_root /tmp/rfs
mount -t ext3 /dev/mapper/vg_sabayon_boot /tmp/rfs/boot
mount -t proc proc /tmp/rfs/proc
mount --rbind /sys /tmp/rfs/sys
mount --rbind /dev /tmp/rfs/dev
cp -L /etc/resolv.conf /tmp/rfs/etc/
chroot /tmp/rfs /bin/bash
source /etc/profile && env-update
After doing this and trying to run "equo update"
I kept getting a Fetch timeout error trying to download the repositories.

Then I looked at my resolv.conf copied from Google's ChromeOS:

Code: Select all

options single-request timeout:1 attempts:5
The first two nameservers are Google's and so is the options line
so after deleting those lines from my resolv.conf I was able to
dowload my repositories with
equo update
Now I'm doing an
equo upgrade
following Sabayon's post-installation configuration guide.
Next I'll try fixing grub.

Young Hen
Posts: 25
Joined: Sat Jan 25, 2014 19:20

Re: Acer C720 Chromebook (Haswell)

Post by redwood » Mon Jan 27, 2014 2:34

Code: Select all

#uname -a
Linux ChroSab 3.12.0-sabayon #1 SMP Fri Dec 13 02:47:32 UTC 2013 x86_64 Intel(R) Celeron(R) 2955U @ 1.40GHz GenuineIntel GNU/Linux
Well I finally got Sabayon 14.0 KDE installed and up and running on Acer C720 Chromebook
by starting over and letting Anaconda just format the ROOT-C /dev/sda7 partition as ext4 mounted at /
So for anyone interested in running Sabayon on the new Acer C720 Chromebook with Intel Haswell
this setup is tested and works with the caveat that I have not yet patched the synaptic trackpad to work
so I'm writing this post using a usb mouse.

Of course this is not a secure setup. I'll have to look into putting /boot and LUKS keys on a usb pendrive
and encrypting root.

The GPT specs say that the bios boot partition (type EF02) needs to be at least 2M but can be located anywhere.
So since ROOT-C (/dev/sda7) is actually at the end of the disk (except for an unallocated 16.31M reserved space)
I decided to reduce the size of my PV on /dev/sda7 with pvreduce and then use cgdisk to delete that partition
and create two new ones out of that space a new ~103G partition for LVM and an 16M sliver for the GPT Bios Boot partition
for grub2.

But after rebooting, I got the error message "ChromeOS Disk corrputed, please insert recovery disk"
no SeaBIOS boot menu and no ChromeOS. So the 12 partitions and 3 reserved unallocated spaces are
probably hardwired in the firmware? I know Jay's 9sgchs script used cgpt to set the boot priorities, attempted tried and default flags. I didn't use cgpt though. Not sure if that would have helped the firmware accept my changes to partitionn

Post Reply