Issue w/ Nvidia legacy cards - udev modprobing cpu to death

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Issue w/ Nvidia legacy cards - udev modprobing cpu to death

Postby life-on-mars » Mon Jul 15, 2013 14:48

I've recently installed four systems all with different Nvidia legacy cards. I was able to boot to GUI in safe mode effortlessly, but after starting the installer everything got extremely slow. It took me more than 6 hours to complete the installation process (or even longer... I don't really remember).

Anyway, it seems that the udev service tries to find the "correct" Nvidia card for the newest driver (instead of finding a driver for the installed card). As a result, the modprobing ate up to 90% cpu power (on the slowest of the four systems) slowing down installation to snail speed.

IMHO, probing for video cards shouldn't be activated in safe mode at all. If video fails during normal boot of the live system, I doubt the installation would benefit from further hardware probes anyway. On the other hand, I do not really understand what udev does during installation.

:idea: Killing the udev service seemed to provide a workaround:
Code: Select all
/etc/init.d/udev stop


I'm not really sure if there are any adverse effects. Apparently, grub wasn't properly installed, as the UUID in the boot parameters was incorrect (though it might be that I'm using an 8GB DOM instead of a traditional HDD?). I simply changed it to /dev/sda1, and it worked.
sɹɐɯ uo əɟıɿ sı əɹəɥʇ -- ⠐⠮ ⠊⠎ ⠇⠊⠋⠑ ⠕⠝ ⠍⠜⠎⠖
life-on-mars
Simple Hen
 
Posts: 83
Joined: Fri Jul 12, 2013 14:05

Re: Issue w/ Nvidia legacy cards - udev modprobing cpu to de

Postby life-on-mars » Tue Jul 16, 2013 4:12

Ok, I have to admit that simply stopping udev wasn't such a good idea. It created a series of issues (e.g. network is down after boot, LANG setting wrong etc.).

Anyway, the solution is to edit the modprobe blacklist to prevent udev from creating a modprobe loop:

Code: Select all
sed -e 's/blacklist nouveau//g' -i /etc/modprobe.d/blacklist.conf
echo 'blacklist nvidia' >> /etc/modprobe.d/blacklist.conf
/etc/init.d/udev restart


I wonder if it wouldn't be better to use Nouveau as the default driver during installation, as it supports a lot more cards than the vanilla Nvidia driver.
sɹɐɯ uo əɟıɿ sı əɹəɥʇ -- ⠐⠮ ⠊⠎ ⠇⠊⠋⠑ ⠕⠝ ⠍⠜⠎⠖
life-on-mars
Simple Hen
 
Posts: 83
Joined: Fri Jul 12, 2013 14:05


Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 3 guests