Update: Can't install SL Daily from 26 June 2013 [Solved]

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Update: Can't install SL Daily from 26 June 2013 [Solved]

Postby linuxfluesterer » Mon Jul 01, 2013 12:26

Hallo guys.
First, friendly greetings from Thailand, where I just stay.
Due to more than 401 updates and insufficient internet speed, I wanted to install a daily Sabayon.
In an internet cafe I'd rather could download
Code: Select all
Sabayon_Linux_DAILY_amd64_KDE.iso with date 25/06/2013

Then I've created a USB memory stick with
Code: Select all
dd if=Sabayon_Linux_DAILY_amd64_KDE.iso of=/dev/sdc
.
When I booted with USB memory stick now, then I received the blue Sabayon entry menu with
Code: Select all
Start Sabayon 20130625 KDE
Start Sabayon Media Center
.
.
Check disc for media defects

So far, so good. I changed my language with F2 to German, then I started to install Sabayon, like I do ever.
The screen turned into black, but neither the splash screen nor any text is displayed even after waiting more than 1 minute. However, I can do change to first terminal (Alt+F1) blind. Then I can type
Code: Select all
root

and
Code: Select all
halt <Enter>

After this blind command, the laptop shuts down.
Then I have made a md5sum of the iso file. Matches with checksum on download site.
Then I've made another test with my running Virtual Box. Here I created a new machine with my Sabayon_Linux_DAILY_amd64_KDE.iso file as boot media.
And here's the surprise:
I receive the same blue menu, and after changing my language and starting Sabayon Live,
I get a splash screen and the Live system is completely booted up in this virtual machine.
I made another test also. I wrote an older Sabayon iso file to my (the same) USB memory stick with the same dd command. That was without problem, I could start that old Sabayon version from USB stick and reached the desktop of the live system.
So, I have no idea, what is different to my older Sabayon iso file before. Maybe a graphics problem?
Here my hardware:
Acer V3-571G Laptop
Intel Core i5-3210M
8 GByte Ram
About 40 GByte sdd space to install Sabayon
NVidia GForce GT630M (switchable with integrated Intel graphics).

What can I try else? Any help is appreciated.
Thank you in advance.

-Linuxfluesterer (I love KDE ...)
Last edited by linuxfluesterer on Thu Jul 04, 2013 6:11, edited 2 times in total.
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 725
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Can't install SL Daily from 26 June 2013

Postby Ryuno-Ki » Mon Jul 01, 2013 12:44

Regards to Thailand.
I scanned several threads by now and it seems, that the ISOs are somewhat damaged (at least in combination with particular hardware).
I'm currently trying to install Sabayon 13.06 MATE amd64 monthly on my notebook and encouncter the very same issue.
I also tried x86 and 13.04 isos.

Strangely I haven't noticed any mentions on the mailing list, yet.

My advice: Sit and wait. I hope, the bug can be detected in the near future.
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: Can't install SL Daily from 26 June 2013

Postby lxnay » Mon Jul 01, 2013 14:15

Can you try the following things:

1. Change the video= parameter to this (TEST ALL OF THEM SEPARATELY):
Code: Select all
video=uvesafb:1024x768-32

or this:
Code: Select all
video=uvesafb:1024x768-16

or this:
Code: Select all
video=uvesafb:1024x768-16,ywrap,mtrr:3

or this:
Code: Select all
video=uvesafb:1024x768,ywrap,mtrr:3


2. Switch to vesafb (from uvesafb, mind the "u"):
Code: Select all
video=vesafb:ywrap,mtrr:3


3. Just drop the graphical splash, remove "splash" from the boot command line
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Can't install SL Daily from 26 June 2013

Postby Ryuno-Ki » Mon Jul 01, 2013 21:16

My guess: Splash is broken somehow.
I can boot into Console only if I skip Splash.

However I'm interested in debugging this situation, too.
If you need a quick solution, boot into Console skipping Splash and run "liveinst" resp. "installer" from xterm.
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: Can't install SL Daily from 26 June 2013

Postby lxnay » Mon Jul 01, 2013 21:29

I don't think it's plymouth, I think it's the resolution and other uvesafb parameters.
Run the tests I mentioned above.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Can't install SL Daily from 26 June 2013

Postby linuxfluesterer » Tue Jul 02, 2013 4:33

Thank you very much, both, Ryuno-Ki and especially Lxnay. You were right.
Indeed it was the change from video=uvesafb to video=vesafb (2.).
Only then, I can run into Live Desktop with a Splash screen before also.
I guess, after installation, I'd have to change the /boot/grub/grub.cfg file by deleting the 'u' from video=uvesafb also (if existing). A quick check of the /boot/grub/grub.cfg on my actual (old Sabayon 11) shows, that there is no video=uvesafb parameter in the linux line of 'menuentry', only video=vesafb.

As I said, thank you for (quick) help.

-Linuxfluesterer (I love KDE ...)
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 725
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Can't install SL Daily from 26 June 2013

Postby lxnay » Tue Jul 02, 2013 6:35

You did not run all the tests separately and reported the results.
You're not really helping us this way...
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Can't install SL Daily from 26 June 2013

Postby linuxfluesterer » Wed Jul 03, 2013 7:46

lxnay wrote:You did not run all the tests separately and reported the results.
You're not really helping us this way...

I'm really sorry, if I'd left that impression....
I ran all tests seperately, there was no change, there was always a black screen.
But since I started with video=vesafb the result was positive and I coul see finally the Live Desktop.
But I said this already in my last post, see here:
linuxfluesterer wrote:Thank you very much, both, Ryuno-Ki and especially Lxnay. You were right.
Indeed it was the change from video=uvesafb to video=vesafb (2.).
Only then, I can run into Live Desktop with a Splash screen before also.
...
As I said, thank you for (quick) help.

-Linuxfluesterer (I love KDE ...)
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 725
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Can't install SL Daily from 26 June 2013 [Solved]

Postby lxnay » Wed Jul 03, 2013 9:30

No problem.
Can you try (for science and other users!) these parameters as well (replace the current video= parameter):

1.
Code: Select all
video=uvesafb:800x600


2.
Code: Select all
video=uvesafb:1024x768


3.
Code: Select all
video=uvesafb


Does your laptop have UEFI? Are you using it?
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Can't install SL Daily from 26 June 2013 [Solved]

Postby linuxfluesterer » Wed Jul 03, 2013 14:47

lxnay wrote:No problem.
Can you try (for science and other users!) these parameters as well (replace the current video= parameter):

1.
Code: Select all
video=uvesafb:800x600


2.
Code: Select all
video=uvesafb:1024x768


3.
Code: Select all
video=uvesafb


I will try tomorrow ...

lxnay wrote:Does your laptop have UEFI? Are you using it?

My laptop has UEFI. Usually I don't activate it. But I activated it once for starting my SL USB memory stick. But then I received the error, that this USB media is not UEFI.

-Linuxfluesterer (I love KDE ...)
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 725
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Next

Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 1 guest