Disable forced UEFI adherence on UEFI MB [Solved]

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Post Reply
Baby Hen
Posts: 4
Joined: Sun Apr 14, 2013 4:43

Disable forced UEFI adherence on UEFI MB [Solved]

Post by Dreyeth » Sat Apr 27, 2013 4:06

Installing Sabayon 11 on a UEFI BIOS forces adherence to certain UEFI specifications and parameters,
like having a GPT partition table and having a /boot/efi partion, that some people
might not be able to easily satisfy especially on a full hard disk with nothing to backup
data to.

I tried doing a installation on my new UEFI computer with my old hard disk (which was full)
which had a MSDOS partion table on it with a couple linux partitions, and half way
thru the installation it told me I needed a /boot/efi partition and a GPT formatted
hard drive and refused to continue (all the UEFI features I can are disabled and my MB has good
BIOS emulation)

It wasn't easy to figure out a way to backup all my data so that I could perform a full
hard drive wipe, but after doing that it happily installed, later on though I realized
I needed to keep a copy of Windows around that doesn't support UEFI for a couple reasons,
and wanted to try a few linux distros on my spare partions that also don't support UEFI yet.

I looked for a boot switch to ignore UEFI online and couldn't find one, so I went fishing for one
tried a couple things until after clicking F5 while booting the
Sabayon Linux live DVD and closing the little popup with commonly disabled BIOS functions
and manually editing the line of boot switches and adding uefi=off.

Sabayon happily ignored the UEFI requirements and installed correctly,
though use it at your own risk.
I don't have much experience with UEFI computers and I don't even know if they all
have any BIOS emulation at all.
Even though it worked faultlessly on my PC yours could easily
be different etc. :mrgreen:

Also verify you have disabled secure boot and your other UEFI features and switched
your UEFI BIOS into legacy mode if your motherboard requires configuring that.

Post Reply