en_GB language missing after install [Solved]

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

en_GB language missing after install [Solved]

Postby chris_debian » Thu Mar 31, 2011 16:03

Hi, all!

Just done a fresh install and for some strange reason, the 'British English' language stuff didn't install, so when I log-in, it falls back to en_US. Anyone know which package I need to install to get the en_GB stuff?

Appreciate your help.

Cheers,

Chris.
Last edited by chris_debian on Sat Apr 02, 2011 8:28, edited 2 times in total.
chris_debian
Simple Hen
 
Posts: 53
Joined: Tue Mar 08, 2011 22:13

Re: en_GB language missing after install.

Postby Fitzcarraldo » Thu Mar 31, 2011 16:29

I've had the same problem with a couple of installations now: SL 5.4 x86 E17 and SL 5.5 amd64 KDE. You can fix it. All the below must be done as root user.

1. Make sure /etc/conf.d/keymaps has keymap="uk" (this is for the console).

2. Add the following to /etc/X11/xorg.conf and reboot:

Code: Select all
Section "InputClass"
    Identifier             "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option                 "XkbLayout" "gb"
EndSection

If the above two steps alone do not fix it, carry on with the following steps:

3. Edit the file /etc/env.d/02locale and make it:

Code: Select all
LANG="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LANGUAGE="en_GB.UTF-8"
GDM_LANG="en_GB.UTF-8"
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
SYSFONT="latarcyrheb-sun16"

then update the environment:

Code: Select all
env-update && source /etc/profile

4. Edit the file /etc/locale.gen and make it the following (you can just comment out the other locales rather than deleting them if you want):

Code: Select all
en_GB ISO-8859-1
en_GB.UTF-8 UTF-8

5. Enter the command:

Code: Select all
locale-gen

6. If you're using KDE, make sure you have selected British English and United Kingdom keyboard layout via, respectively, Kickoff > System Settings > Locale | Languages | Preferred Languages and Kickoff > System Settings > Input Devices > Keyboard | Layouts | Add Layout.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 8078
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: en_GB language missing after install.

Postby chris_debian » Thu Mar 31, 2011 17:04

Thanks for this. I haven't tried it yet, but when I tried to add en_GB from the log-in manager, it told me that the language was missing, so although everything should point to the right place (i'll check), I think I need to install a language pack, just not sure which.

Cheers,

Chris.
chris_debian
Simple Hen
 
Posts: 53
Joined: Tue Mar 08, 2011 22:13

Re: en_GB language missing after install.

Postby Fitzcarraldo » Fri Apr 01, 2011 20:43

It's not a "language pack" issue, it's a locale configuration issue. If you follow the complete procedure I gave you above it should straighten things out.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 8078
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: en_GB language missing after install.

Postby chris_debian » Sat Apr 02, 2011 8:27

Done, thank you :-)

Chris.
chris_debian
Simple Hen
 
Posts: 53
Joined: Tue Mar 08, 2011 22:13


Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 1 guest

cron