after install of 5.2 I get grub prompt

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

after install of 5.2 I get grub prompt

Postby moonrise » Mon Apr 26, 2010 22:19

I downloaded Sabayon_Linux_CoreCD_5.2_x86.iso checked the checksum
b092b982150b83332723406637e09726

Followed the procedure here:
http://wiki.sabayonlinux.org/index.php? ... _The_Image

After following those procedures I rebooted and sabayon started I saw the leaf logo with sabayon below.
The screen flashed between text and the logo (kind of annoying) then there was an error:
something like "linux installer service not running" then it just hung there.

Then I ctrl-alt-F6
Then I typed "installer"
and installed, the installer completed
I rebooted
and I am now booted into a grub 0.97 menu
maybe the device.map is wrong??

I installed to CF card and there is also a internal drive.

What next?
moonrise
Baby Hen
 
Posts: 6
Joined: Mon Apr 26, 2010 22:03

Re: after install of 5.2 I get grub prompt

Postby donnie » Mon Apr 26, 2010 22:40

After install completed you could run
Code: Select all
# mount /dev/sda? /mnt/floppy
# grub2-install --root-directory=/mnt/floppy /dev/sda
# grub-mkconfig -o /mnt/floppy/boot/grub/grub.cfg

(sda? - is where you just installed CoreCD)

Also you can run this from any distro that have GRUB2 installed (just create mount point directory if needed, in Sabayon there is a /mnt/floppy).

Seems you just installed grub to run CoreCD, but didn't install any bootloader to MBR during process (there are english letters there - HIGHLY recommended or you know what you're doing)
Last edited by donnie on Mon Apr 26, 2010 23:25, edited 1 time in total.
donnie
 

Re: after install of 5.2 I get grub prompt

Postby donnie » Mon Apr 26, 2010 22:58

Always try check bootloader by for example this:
Code: Select all
# sync ; echo 3 > /proc/sys/vm/drop_caches ; qemu -hda /dev/sda

Remove and emerge QEMU if it does not work.
donnie
 

Re: after install of 5.2 I get grub prompt

Postby moonrise » Mon Apr 26, 2010 23:18

qemu?

Not sure what you're talking about. Did you mean to post that somewhere else?
moonrise
Baby Hen
 
Posts: 6
Joined: Mon Apr 26, 2010 22:03

Re: after install of 5.2 I get grub prompt

Postby donnie » Mon Apr 26, 2010 23:24

QEMU is a virtual machine, you can install something, and after that try to see what you get, without booting.

It will take 1-1.5 hours to get qemu working, because a version with Sabayon didn't worked for me.
Code: Select all
# emerge --sync
# emerge portage
# equo remove qemu --nodeps --ask
# emerge qemu


But you don't actually need it that badly.

Boot to that install partition again, and run that commands in my first post.
donnie
 

Re: after install of 5.2 I get grub prompt

Postby moonrise » Mon Apr 26, 2010 23:48

I am guessing you don't understand something here. But I cannot boot to "that install partition". Not sure
what else to tell you. But if you look back at the steps I took you will see that the procedure I used was for installing 5.2 from a harddrive.

Is the 5.2 installer broken or not? I am not too excited about redoing the install just to get back to the grub prompt.
moonrise
Baby Hen
 
Posts: 6
Joined: Mon Apr 26, 2010 22:03

Re: after install of 5.2 I get grub prompt

Postby donnie » Tue Apr 27, 2010 0:04

If you can boot to install partition (using much the same sequance as in that wiki article) and install it again, CoreCD will be in GRUB menu. I installed it myself yesterday. Be sure to select Install bootloader to MBR and Install bootloader to partition.
donnie
 

Re: after install of 5.2 I get grub prompt

Postby donnie » Tue Apr 27, 2010 0:07

I now try to find out my own boot sequence for CoreCD 5.2 x86, you can use it and then add to grub.cfg
donnie
 

Re: after install of 5.2 I get grub prompt

Postby donnie » Tue Apr 27, 2010 0:13

Here:
Code: Select all
menuentry "Sabayon CoreCD x86-2.6.33-sabayon" --class sabayon --class gnu-linux --class gnu --class os {
   insmod ext2
   set root='(hd0,6)'
   search --no-floppy --fs-uuid --set 7d9501e8-8b76-4f4a-b7de-ebe6a8789baf
   echo   Loading Linux x86-2.6.33-sabayon ...
   linux   /boot/kernel-genkernel-x86-2.6.33-sabayon ro root=/dev/ram0 ramdisk=8192 real_root=/dev/sda6 dolvm init=/linuxrc splash=silent,theme:sabayon console=tty1 quiet gentoo=nox resume=swap:/dev/sda9 real_resume=/dev/sda9
   echo   Loading initial ramdisk ...
   initrd   /boot/initramfs-genkernel-x86-2.6.33-sabayon
}


Installed to /dev/sda6, so edit appropriately
donnie
 

Re: after install of 5.2 I get grub prompt

Postby moonrise » Tue Apr 27, 2010 0:24

My grub.cfg entry looks about the same.
moonrise
Baby Hen
 
Posts: 6
Joined: Mon Apr 26, 2010 22:03

Next

Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 6 guests

cron