More than one Interface Language in Sabayon 5

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Re: More than one Interface Language in Sabayon 5

Postby adXok » Fri Mar 26, 2010 12:36

Code: Select all
adxok@sabayon ~ $ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=bg.UTF-8
LC_CTYPE="bg.UTF-8"
LC_NUMERIC="bg.UTF-8"
LC_TIME="bg.UTF-8"
LC_COLLATE="bg.UTF-8"
LC_MONETARY="bg.UTF-8"
LC_MESSAGES="bg.UTF-8"
LC_PAPER="bg.UTF-8"
LC_NAME="bg.UTF-8"
LC_ADDRESS="bg.UTF-8"
LC_TELEPHONE="bg.UTF-8"
LC_MEASUREMENT="bg.UTF-8"
LC_IDENTIFICATION="bg.UTF-8"
LC_ALL=bg.UTF-8
adxok@sabayon ~ $


Hm... it sdhouldn't be that maybe...
adXok
Baby Hen
 
Posts: 14
Joined: Thu Mar 25, 2010 17:46

Re: More than one Interface Language in Sabayon 5

Postby micia » Fri Mar 26, 2010 12:46

So, let me understand how things are going:

- You generated a bg.UTF8 locale using locale-gen
- Your current locale is now bg.UTF8
- locale -a | grep bg results are:
Code: Select all
sabayon adxok # locale -a | grep bg
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
bg_BG
bg_BG.iso88591
bg_BG.utf8


Now, instead of editing all your files to use bg.UTF8, which does not exist and is generated in a (probably) incorrect way, use bg_BG.utf8 or bg_BG, edit the appropriate files to use it, as indicated in the gentoo guide:
/etc/env.d/02locale (for system-wide settings) and ~/.bashrc (for user-specific settings) file.

And run:
(For system-wide default locale:)
# env-update && source /etc/profile

(For user-specific locale:)
$ source ~/.bashrc

If there is some error report it,
otherwise reboot and check again the locale using:
Code: Select all
locale
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: More than one Interface Language in Sabayon 5

Postby adXok » Sat Mar 27, 2010 11:42

I thoughth it is very messed up by now so... I did a fresh and clean new Sabayoin 5.2 installation. When I was struggling with the language problem there came up the 5.2 version. I installed it and everything is perfect. So for comparioson my files as discussed above look like this and everything is in Bulgarian (english is available too i think):

/etc/make.conf: (the important line is: LINGUAS="bg")
Code: Select all
    ...EOPTS="-j4 -s "
FEATURES="parallel-fetch collision-protect"
#PORTAGE_NICENESS="8"
LINGUAS="bg"
#ACCEPT_LICENSE="*"

## USE ARRAYS ##
BAD="-kdeprefix -arts -qt3 -beagle -gnome -evo -mono -eds -apm -oss -branding -esd"
MEDIA="musicbrainz sdl pul...


/etc/locale.gen:
Code: Select all
en_US.UTF-8 UTF-8
en_US ISO-8859-1
bg_BG.UTF-8 UTF-8
bg_BG CP1251


/etc/env.d/02locale:
Code: Select all
LANG="bg_BG.UTF-8"
LC_MESSAGES="bg_BG.UTF-8"
LANGUAGE="bg_BG.UTF-8"
GDM_LANG="bg_BG.UTF-8"
LC_ALL="bg_BG.UTF-8"
SYSFONT="latarcyrheb-sun16"


no other files need to be compared.

Everithyng is PERFECT now. Sabayon 5.2 rules!!!
adXok
Baby Hen
 
Posts: 14
Joined: Thu Mar 25, 2010 17:46

Re: More than one Interface Language in Sabayon 5

Postby adXok » Sat Mar 27, 2010 12:27

For nVidia card owners ONLY!!!
Just for the protocol for anyone who was annoyed like me of Xorg.conf and nvidia-settings not saving after restart.

Open Terminal and write: su
Enter your 'root' (admin) password.
write: nvidia-settings

nVidia Settings pannel opens up. Go to resolution and freq settings adjust your preffered resolution, in my case it is: 1152x864 pixels and 85Hz freq refresh
Press 'Advanced' and choose once again, in my case it is: 10. 1152x864_85 +0+0

Press Save configuration! Close the porgram by pressing the 'x' window button (up-right).

IMPORTANT!!!
Go to Places, Computer, File System (Sabayon): /etc/X11/xorg.conf
right click, Open With Application... choose 'gedit' and open the Option command line (the triangle button below menu)!!!
You'll see: gedit
Just type: gksu
(it should read: gksu gedit)
then hit Open... now you may save in gedit as Administrator!

Scroll down in gedit (you have opened xorg.conf as admin) to the Section:
Code: Select all
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "nvidia-auto-select +0+0; 1152x864_85 +0+0; 1152x864_85 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


Imoprtant line is: Option "metamodes" "nvidia-auto-select +0+0; 1152x864_85 +0+0; 1152x864_85 +0+0"
Just delete (with backspace: +0+0;) so it becomes as:
Code: Select all
Option         "metamodes" "nvidia-auto-select 1152x864_85 +0+0; 1152x864_85 +0+0"
The resolutin should be your preffered from nvidia-settings setup window allready spoken above. The above shown is just for my monitor, so be careful not to just copy/paste this one!

Save the file!

Restart and your resolution and freq config is remebered and used every time the computer starts! :cyclops:
adXok
Baby Hen
 
Posts: 14
Joined: Thu Mar 25, 2010 17:46

Previous

Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 1 guest