installation of 5.1

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

installation of 5.1

Postby billk » Fri Dec 18, 2009 5:47

I am using 5.0 downloades iso two different times and burned two different disks for KDE AMD 64 bit, nvidia video board. After multiple attempts have abandoned the effort. When starting to format the disk the installer crashes. 5.0 continues to work. Seems absurd that the formater crashes. Any suggestions.
billk
Baby Hen
 
Posts: 10
Joined: Sat Jun 13, 2009 3:13

Re: installation of 5.1

Postby DHalens » Sat Dec 19, 2009 17:48

Did you check the md5? Did you update the installer? Where's the error output (or tell us how to read your mind so we can see it from there...)?
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: installation of 5.1

Postby cmost » Sun Dec 20, 2009 0:05

I've done a search of the forum and haven't found any clear answer to this question yet: How does one go about upgrading from 5.0 to 5.1? Do we need to change our /etc/entropy/repositories.conf file to reflect new repositories? I'm asking this because my 5.0 system is "fully up to date" according to Magneto, however, a quick comparison of the changelog for 5.1 vs. 5.0 reveals that I don't have the latest nvidia-drivers or xorg 7.5 as well as other packages new to 5.1; these don't appear to be available or upgradable in Sulfur. If I want a fully up-to-date 5.1 system, how do I achieve this via the package manager and not by using a fresh install? Thanks! :lol:

*** EDIT ***
I found the answer and am now updating...

With the 5.0 release, you should be able to roll along and stay current. Anything prior to 5 is in a different branch, hence the equo hop 5 needed to continue updates. At this point and time, I would not recommend doing it, but you are free to try it. Just make sure you have the latest entropy all the time.

As usual, Wolfden's words of wisdom:

equo update
equo install entropy equo
equo world
equo conf update

Only systems <5 need a branch hop!

*** EDIT #2 -still not fully up-to-date ***

Executed the above commands and came upon these errors:

[email protected] ~ $ sudo equo world
>> @@ Calculating System Updates...
>> @@ Nothing to update.
>> @@ Nothing to remove.

>> requirements for this branch:
app-admin/eselect-python
sys-devel/gcc:4.4
>> Entropy post-upgrade migration script
>> Repository: sabayonlinux.org
>> Root: /
>> Old branch: 5.1
>> New branch: 5

>> ATTENTION ATTENTION ATTENTION
>> - If you are upgrading from a previous branch (say, 4)
>> and you are a NetworkManager user, make sure to have
>> your users inside the netdev group.
>> - If you compile stuff manually, it is strongly
>> suggested to install lafilefixer and execute:
>> # lafilefixer --justfixit
>> ATTENTION ATTENTION ATTENTION

migration switch not found
>> @@ Caching complete.
[email protected] ~ $ sudo equo world
>> @@ Calculating System Updates...
>> @@ Nothing to update.
>> @@ Nothing to remove.
>> @@ Caching complete.

Any ideas on how to get fully updated to 5.1? Thanks!
cmost
Advanced Hen
 
Posts: 208
Joined: Wed Dec 13, 2006 22:25
Location: Cincinnati, OH


Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 2 guests