64 bit installation issues on Intel Matrix RAID

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Post Reply
Baby Hen
Posts: 3
Joined: Mon Oct 12, 2009 13:31

64 bit installation issues on Intel Matrix RAID

Post by Aryos » Mon Oct 12, 2009 13:51

I have been having installation issues with all versions 4.0, 4.2 and 5.0, 64 bit, KDE editions.
My PC is an ASUS G71V laptop (specs here: http://www.asus.com/product.aspx?P_ID=BIobfxtaVu9MPKdx):
I have changed the hard drives, using 2 WD Scorpio Blacks, 250GB each. Using the Intel Matrix RAID option, I have configured 2 RAID setups: one with 375 GB, RAID 0 (128K stripe size) and one with 96 GB (4K stripe size), also RAID 0. On the 96 GB RAID, I have created a Linux partition (primary) and a Linux swap partition (using the Sabayon 64 bit version 4.2 Live DVD), which is where I want Sabayon to be installed.

Following are the issues (all are for Sabayon x86-64, KDE editions, DVDs for versions 4.0, 4.2 and 5.0):
- Version 5.0 live DVD cannot start X, when entering the installer or the live environment (back screen, freezing and no console working either). Safe Mode works, though. However, if the live environment does this, I'm afraid the issue will re0emerge, after setting up the OS, during boot time. Since there is a freezing, I cannot go to console mode, to get any error messages.
- Version 4.0, 4.2 and 5.0 DVDs: The installer is able to perform partitioning of the 96GB RAID 0, but none of the installers in any of the version is able to format the partition, so the installation can continue. When the instalation starts, there is a general message (no exception code I can post here), something like ("There was an error formatting partition XXX. This is a serious error. Please restart the installer). Looking at the console for more detailed error code didn't help either.
- Having these issues, I used my Windows installation, using Acronis Disk Director Suite, to format the primary partition with reiserfs and the swap partition. Then went back to booting from the DVDs of these 3 editions, having the partitions just mounted and not formatted, during the installation, so the installer could bypass the format error and continue.
In all 3 versions, the setup seems to start (I see the DVD been read), but see no activity on the hard drive. Around 35%-48% of the installtion process, in all 3 versions, the installer freezes. I leave it there for 10-15 minutes, just in case, but nothing. Checking the console for errors, I receive somthing like this (in all versions):
"I/O error...(fd=5)...could not write to disk"
Seems the installer is not able to write to the partition of the RAID setup.

The checksums of all the DVD ISO files have been checked and are ok, also I have copied the contents of each of the 3 DVDs directly to the hard drive, to check if there are issues with them and it was ok.
Also note that other Linux OSs, even PC-BSD I tried can install to this disk RAID setup-partition, without issues.
Have not tried with the 32 bit versions of Sabayon, but don;t want to use these, anyway.

Any help would be appreciated.

Growing Hen
Posts: 103
Joined: Tue Feb 06, 2007 11:59
Location: Munich

Re: 64 bit installation issues on Intel Matrix RAID

Post by phlo » Thu Oct 22, 2009 17:32

Hello Aryos,

did you check the wiki ?
There is a nice howto what could solve your problem.

http://wiki.sabayonlinux.org/index.php? ... yon_and_XP

please try and if you run into problems come back and I will try to help.



Post Reply