Clean 5.0 installatiion - start-up error msgs. [Solved]

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Clean 5.0 installatiion - start-up error msgs. [Solved]

Postby Odysseus » Mon Oct 05, 2009 19:46

First of all I'd like to thank all on the development team for their hard work in putting together the new release. I decided to try a clean install and run the full KDE DVD binaries without recompiling them and see how things work. My impressions are very positive so far, but I have discovered a couple of issues which concern me.

First, installation issues: My laptop unfortunately has a BIOS limitation of 128gigs, because of this I've developed a partitioning scheme that allows me to overcome this so Grub will boot correctly. My partition scheme is as follows
Code: Select all
sda1:Windows:125,955mb (123gb)
sda2:/boot:102mb
sda3:swap:2gb
sda5:/:2960mb
sda6:/usr:16gb
sda7:/usr/local:3gb
sda8:/opt:3gb
sda9:/var:4gb
sda10:/home:31gb

Setting up my drive this way allows my swap file to be under the BIOS limit so that Tux on ice works correctly, and it places all of / under the limit so I don't get failure to detect disk error msgs during initial booting.

Needles to say, the default installation wanted to create one big / drive using LVM. I don't use LVM specifically because I've had issues in the past because of the BIOS limitation. So I chose not to use LVM during installation. However, I see that "dolvm" is still used in the grub.conf and LVM is activated at boot time init. file. This should be fixed in the next release so that if one chooses their own partitioning scheme they don't get stuck with LVM if they don't want it. Along the same lines I don't run any raid yet mdadm is installed and activated by default even though I don't use or need it.

Next, I deselected NFS, SSH, Cups, and Samba during the installation process, yet all were still installed and enabled. And to make matters worse, if one tries to uninstall them through equo or sulfur much of KDE wants to be removed, because of dependency issues. If you forcibly uninstall them, as soon as you do the next update they're reinstalled again. So there needs to be a refinement in the installation process so that if these apps aren't wanted, they truly don't get installed or reinstalled.

Next, start-up error msgs (and these truly concern me):
Code: Select all
rc boot logging started at Mon Oct  5 16:57:34 2009

sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/sbin/livecd-functions.sh: line 483: rev: command not found
* Setting system clock using the hardware clock [Local Time]...
 [ ok ]
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/sbin/livecd-functions.sh: line 483: rev: command not found
* Autoloaded 0 module(s)
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/sbin/livecd-functions.sh: line 483: rev: command not found
* Setting up the Logical Volume Manager...
 [ ok ]
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/sbin/livecd-functions.sh: line 483: rev: command not found
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/sbin/livecd-functions.sh: line 483: rev: command not found
* Checking local filesystems ...
/: clean, 17713/757248 files, 101936/757055 blocks
/opt: clean, 2505/787200 files, 112838/787177 blocks
/usr: clean, 302640/4196112 files, 2413699/4194965 blocks
/home: clean, 1236/8470336 files, 626348/8468255 blocks
/var: clean, 40203/1048576 files, 204989/1048233 blocks
/usr/local: clean, 3342/787200 files, 82112/787177 blocks
/boot: clean, 39/26208 files, 17713/104420 blocks
 [ ok ]
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/sbin/livecd-functions.sh: line 483: rev: command not found
* Remounting root filesystem read/write...
 [ ok ]
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/sbin/livecd-functions.sh: line 483: rev: command not found
* Updating /etc/mtab...
 [ ok ]
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/sbin/livecd-functions.sh: line 483: rev: command not found
* Mounting local filesystems...


As you can see there is an issue with locale. I had the same issue with the previous 4.2 core version that I was only able to resolve when I switched from baselayout-2 down to baselayout-1 and recompiled my system. I've gone to the Gentoo locale and UTF installation guides and followed them to a "T" yet still I have these warnings. What is causing this issue? Also what is, and why is livecd-functions.sh in my start-up? What purpose does this init file serve on a full hard drive install? Is it needed? Can I deactivate or uninstall it?

Finally, every time I log in to KDE I get a message about "migrating address book". I don't even have an address book setup yet, and if one was created by default it has no entries in it, so why the mesg every time I log in?

Any help to eliminate the startup issues in particular would be greatly appreciated. Thanks in advance.

Ciao
Last edited by Odysseus on Tue Oct 06, 2009 20:22, edited 2 times in total.
Odysseus
Simple Hen
 
Posts: 44
Joined: Wed Aug 26, 2009 2:37
Location: Miami, FL (homesick for SF,CA)

Re: Clean 5.0 installatiion - start-up error msgs.

Postby spacesyl » Tue Oct 06, 2009 14:43

Is /usr on a seperated LV/partition ?
spacesyl
Baby Hen
 
Posts: 9
Joined: Tue Oct 06, 2009 14:41

Re: Clean 5.0 installatiion - start-up error msgs.

Postby Odysseus » Tue Oct 06, 2009 19:21

spacesyl wrote:Is /usr on a seperated LV/partition ?

Thanks for the question, but no. As stated in the OP, I don't use LVM or MDADM, but both were installed and both are activated at boot time in the init scripts. But my fstab is as it should be, as it was auto-generated during installation, for my partitioning scheme:
Code: Select all
/dev/sda5               /                       ext4    user_xattr,noatime 1 1
/dev/sda8               /opt                    ext4    user_xattr,noatime 1 2
/dev/sda6               /usr                    ext4    user_xattr,noatime 1 2
/dev/sda10              /home                   ext4    user_xattr,noatime 1 2
/dev/sda9               /var                    ext4    user_xattr,noatime 1 2
/dev/sda7               /usr/local              ext4    user_xattr,noatime 1 2
/dev/sda2               /boot                   ext2    defaults        1 2
/dev/shm                /dev/shm                tmpfs   defaults        0 0
/dev/sda3               swap                    swap    defaults        0 0

I tried last night reinstalling, this time electing to install NFS, SSH, Cups, and Samba, but with the same results and the same error msgs regarding:
Code: Select all
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
So that problem is unrelated.

So I'm still looking for a work around. any help would be appreciated.

rc-update show
Code: Select all
consolekit | boot
vixie-cron |              default
udev |      sysinit
devfs |      sysinit
dbus | boot
keymaps | boot
root | boot
fsck | boot
hald | boot
mtab | boot
mount-ro |                             shutdown
mdadm |              default
netmount |              default
lvm | boot
fbcondecor |              default
procfs | boot
entropy_client |              default
killprocs |                             shutdown
termencoding | boot
serial | boot
xdm | boot
modules | boot
hwclock | boot
dmesg |      sysinit
sysctl | boot
net.lo | boot
syslog-ng |              default
device-mapper | boot
consolefont | boot
nfsmount |              default
alsasound |              default
hostname | boot
x-setup | boot
NetworkManager |              default
swap |              default
local |              default                 nonetwork
urandom |              default
hotplug | boot
localmount | boot
bootmisc | boot
savecache |                             shutdown


On a positive note I was able to stop the constant address book query when logging into KDE. That was resolved by entering a "dummy" entry and contact info which seems to have cleared up that particular problem. And I was able to resolve the "/sbin/livecd-functions.sh: line 483: rev: command not found" error by renaming that file.

So If I could fix the "set locale" start-up error I should be good to go!

Any ideas? Anyone?

TIA

Ciao
Odysseus
Simple Hen
 
Posts: 44
Joined: Wed Aug 26, 2009 2:37
Location: Miami, FL (homesick for SF,CA)

Re: Clean 5.0 installatiion - start-up error msgs. (solved)

Postby Odysseus » Tue Oct 06, 2009 20:40

I found the solution, it took me awhile, but apparently the baselayout-2 start-up scripts handle localization a bit differently than before. The default Sabayon installation routine is setting the "global" language variable in /etc/env.d/02locale using "LC_ALL".

According to the Gentoo Localization Guide, "Warning: Using LC_ALL is strongly discouraged as it can't be overridden later on. Please use it only when testing and never set it in a startup file." Which can be found here. http://www.gentoo.org/doc/en/guide-localization.xml.

I found the solution on Gentoo Bugzilla, bug #275003 which can be found here. http://bugs.gentoo.org/275003 In a nutshell all I had to do was edit /etc/env.d/02locale and remove the reference to LC_ALL. Then I did env-update && source /etc/profile, rebooted and viola! Errors were gone.

I hope this helps others who may be running into similar problems.

Life is good!!!!

Ciao
Odysseus
Simple Hen
 
Posts: 44
Joined: Wed Aug 26, 2009 2:37
Location: Miami, FL (homesick for SF,CA)


Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 2 guests

cron