SL 5.0_K and dmraid

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

SL 5.0_K and dmraid

Postby rikd » Sat Oct 03, 2009 1:26

Installed SL5 and went perfectly..
Was expecting to have to do the grub fix on reboot - and I wasn't dissapointed

so I rebooted with the CD expecting to be able to fix it...
Fell at the first hurdle..

dmraid -ay fails
I got the following
Code: Select all
sabayon sabayonuser # dmraid -ay -ddd -vvv
WARN: locking /var/lock/dmraid/.lock
NOTICE: skipping removable device /dev/sdc
NOTICE: skipping removable device /dev/sdd
NOTICE: skipping removable device /dev/sde
NOTICE: skipping removable device /dev/sdf
NOTICE: /dev/sdb: asr     discovering
NOTICE: /dev/sdb: ddf1    discovering
NOTICE: /dev/sdb: hpt37x  discovering
NOTICE: /dev/sdb: hpt45x  discovering
NOTICE: /dev/sdb: isw     discovering
ERROR: isw: Could not find disk /dev/sdb in the metadata
NOTICE: /dev/sdb: jmicron discovering
NOTICE: /dev/sdb: lsi     discovering
NOTICE: /dev/sdb: nvidia  discovering
NOTICE: /dev/sdb: pdc     discovering
NOTICE: /dev/sdb: sil     discovering
NOTICE: /dev/sdb: via     discovering
NOTICE: /dev/sda: asr     discovering
NOTICE: /dev/sda: ddf1    discovering
NOTICE: /dev/sda: hpt37x  discovering
NOTICE: /dev/sda: hpt45x  discovering
NOTICE: /dev/sda: isw     discovering
ERROR: isw: Could not find disk /dev/sda in the metadata
NOTICE: /dev/sda: jmicron discovering
NOTICE: /dev/sda: lsi     discovering
NOTICE: /dev/sda: nvidia  discovering
NOTICE: /dev/sda: pdc     discovering
NOTICE: /dev/sda: sil     discovering
NOTICE: /dev/sda: via     discovering
no raid disks
WARN: unlocking /var/lock/dmraid/.lock


But the installer detects them - I have to hit cancel a lot, but it does work.

Any ideas?
rikd
Simple Hen
 
Posts: 47
Joined: Mon Mar 19, 2007 22:56
Location: Limerick, Ireland

Re: SL 5.0_K and dmraid

Postby rikd » Sat Oct 03, 2009 15:02

An update...
I put in the SL4.2 DVD and actually dmraid behaves the same...

Now - I know I got SL4.2 installed ok, so I persisted...
figured out I used the installer to load the dmraid stuff properly in SL4.2 - just go through installer and the manual partitioning screen.

The real difference between SL4.2 and SL5 for me is that when I get to the manual partitions in SL4.2 /dev/mapper is properly populated and I can then recover the GRUB config.
In SL5 this is not the case - nothing appears in /dev/mapper when I'm in the partitioning screen, despite the partition tool showing me the partitions.

Anyways - I'm sorted with SL5 installed thanks to my trusty SL4.2 DVD :)
rikd
Simple Hen
 
Posts: 47
Joined: Mon Mar 19, 2007 22:56
Location: Limerick, Ireland


Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 1 guest