Pb installation xorg nvidia on Qosmio

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Post Reply
jaguar1637
Simple Hen
Posts: 63
Joined: Sun Jul 26, 2009 9:11
Location: Toulouse - France

Pb installation xorg nvidia on Qosmio

Post by jaguar1637 » Wed Aug 05, 2009 11:53

Hi all,

Could you give me a favor ?
I just launched Sabayon 4.2 KDE on a Toshiba Qosmio (Dual core w/ NVIDIA GeForce Go 7600)
The installation can not launch the X11 server and the installation.

I am stucked w/ the xorg.conf configuration.
I found the web page :
http://wiki.sabayonlinux.org/index.php? ... in_Sabayon

performed the emerge nvidia-drivers command, but in step 4, I can not go forward
" Edit etc/X11/xorg.conf and change the Driver option under Device from nv or vesa to nvidia, also ensure the the Load glx line is uncommented in the Module Section "

Did someone could help me to set up a simple configuration ? Do you think the configuration can continue after launching the X11 server ?

Cheers
JY [email protected]

WarraWarra
Sagely Hen
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: Pb installation xorg nvidia on Qosmio

Post by WarraWarra » Wed Aug 05, 2009 20:44

My Dell E1705 laptop nvidia 7800gtx xorg.conf this should get you into at least a gui kde / gnome desktop or copy the one from the livedvd if working correctly to your hard drive. This is from the livedvd.

When booting you can add the cheat codes to force the use of the nvidia driver.
xdriver=nvidia res=1440x900
This lets the desktop manager or kde or gnome know the driver will be nvidia and the res will only be 1440x900.

You can also if all else fails use
sh ./NV*.run
provided you are in the same folder as the downloaded nvidia.com ia32 or ia64 driver . At the end if asked confgi = yes please. Reboot and works fine.

Code: Select all

http://us.download.nvidia.com/XFree86/Linux-x86/185.18.31/NVIDIA-Linux-x86-185.18.31-pkg1.run
xorg.conf from SL4.2g livedvd

Code: Select all

Section "Module"
    SubSection  "extmod"
       Option    "omit xfree86-dga"
    EndSubSection
    Load    "i2c"
    Load    "ddc"
    Load    "vbe"
    Load    "dri"
    Load    "glx"
#    Load    "synaptics" ### the cursed driver causing jumping mousepad on laptop issues #####
EndSection

Section "ServerFlags"
     Option    "AllowMouseOpenFail"    "true"
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    VertRefresh    43 - 60
    HorizSync      28 - 80
EndSection


Section "Device"

    Identifier  "SabayonVga0"
    Driver      "nvidia"
    #BusID    "PCI:01:00"
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
    Option "UseEvents" "True"
    Option "LogoPath" "/usr/share/backgrounds/sabayonlinux-nvidia.png"

EndSection
	


Section "Screen"

    Identifier    "Screen 0"
    Device        "SabayonVga0"
    Monitor       "Generic Monitor"
    Option       "AddARGBGLXVisuals" "true"

    DefaultDepth 24

    SubSection "Display"
        Depth		8
        ViewPort	0 0
        Modes           "1440x900" "1024x768" "1024x768" "800x600"
    EndSubsection

    SubSection "Display"
        Depth           16
        ViewPort        0 0
        Modes           "1440x900" "1024x768" "1024x768" "800x600"
    EndSubsection

    SubSection "Display"
        Depth           24
        ViewPort        0 0
        Modes           "1440x900" "1024x768" "1024x768" "800x600"
    EndSubsection

EndSection


Section "DRI"
    Mode 0666
EndSection

Section "ServerLayout"
    Identifier   "Main Layout"
    Screen 0    "Screen 0"
EndSection

Section "Extensions"
   #Option "Composite" "Enable"
EndSection
Just to prove I have the hardware and not talking rubish as suggested in another post.

Code: Select all

laptop virtualbox-bin-3.0.2-r1 # /etc/init.d/vboxdrv setup
* Stopping VirtualBox kernel module...                                                                                                                                                              [ ok ]
* Removing old VirtualBox netadp kernel module...                                                                                                                                                   [ ok ]
* Removing old VirtualBox netflt kernel module...                                                                                                                                                   [ ok ]
* Removing old VirtualBox kernel module...                                                                                                                                                          [ ok ]
* Recompiling VirtualBox kernel module...                                                                                                                                                           [ ok ]
* Starting VirtualBox kernel module...                                                                                                                                                              [ ok ]
laptop virtualbox-bin-3.0.2-r1 # lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce Go 7800 GTX] (rev a1)
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
03:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
03:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
03:01.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 0a)
03:01.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)
0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
laptop virtualbox-bin-3.0.2-r1 # 

laptop virtualbox-bin-3.0.2-r1 # uname -a
Linux laptop 2.6.29-sabayon #1 SMP Mon Jul 20 13:34:20 UTC 2009 i686 Genuine Intel(R) CPU T2600 @ 2.16GHz GenuineIntel GNU/Linux
laptop virtualbox-bin-3.0.2-r1 # 

jaguar1637
Simple Hen
Posts: 63
Joined: Sun Jul 26, 2009 9:11
Location: Toulouse - France

Re: Pb installation xorg nvidia on Qosmio

Post by jaguar1637 » Sun Aug 09, 2009 1:21

Thank you very much ! I am going to apply this solution

Post Reply