grub problems after installation

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Post Reply
Advanced Hen
Posts: 240
Joined: Thu Oct 19, 2006 1:46
Location: dayton OH usa

grub problems after installation

Post by mdmarmer » Mon Jul 28, 2008 0:38

I have installed Sabayon 3.5 32-bit DVD to laptop Toshiba M45-S331 ... I cannot boot to Sabayon. DVD is a good burn -- I have successfully installed from it on a desktop. When I installed Sabayon GRUB to MBR of sda, I get GRUB loading stage 2 ... and it just sits there. I tried GRUB from Kanotix RC7and the same thing happens. I tried GRUB from Mepis 7.0 (older GRUB) and the system boots (I can boot to my other partitions) but when I try to boot to Sabayon I get GRUB error 2: File not found. I have successfully installed older versions of Sabayon on this laptop several times ( I had 3.4 installed, but I did a fresh install rather than upgrade to 3.5). Thanks for help!


Young Hen
Posts: 23
Joined: Sat Jun 07, 2008 1:15
Location: Rennes

Re: grub problems after installation

Post by eMxyzptlk » Mon Jul 28, 2008 10:08

How did you partition, your hard disk? LVM or usual parition ??
Try this... boot any Linux live doesn't matter what, then mount your hard disk inside it, chroot it it and follow this howto to reinstall MBR

Just a quick example of the chroot process just in case u never tried it, assuming ur partition is /dev/sda1

# mkdir /mnt/sabayon
# mount /dev/sda1 /mnt/sabayon
# mount --bind /dev /mnt/sabayon/dev
# chroot /mnt/sabayon /bin/bash
# mount -a
# grub

Post Reply