Installation successful, but with pitfalls

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Post Reply
theber
Baby Hen
Posts: 5
Joined: Sat Feb 01, 2020 12:11
Location: Germany

Installation successful, but with pitfalls

Post by theber » Sun Feb 02, 2020 11:39

I was able to successfully install Sabayon 19.03, but I had some trouble on the way. (I've installed many different OS's over the years.) Maybe this will help someone else. By the way, my hardware is about 2 years old. My video card is GeForce GT710.

First I downloaded the iso file from the website, and then used dd to make a USB stick.

1. The first installation went fine. Then using the Sabayon Wiki page (En:Introduction) I proceeded to update/upgrade the system. This did not work as stated in the Wiki; when I entered the command

Code: Select all

equo install glibc
the whole upgrade started without letting me first update Entropy. After this was done I went through the other commands in this part of the Wiki, and then rebooted. Then I got the black screen and cursor, so I followed the instructions on the "Known Issues" page. The command

Code: Select all

equo query installed nvidia
returned zero entries. I was not able to install the nvidia driver per the instructions; the lines of text rolled by so fast that I couldn't follow, but the last visible lines said something about the files not available on the server. After a while I quit to try reinstalling.

2. The second installation brought up the black screen with cursor before I could reach the desktop. Since I am using WiFi to connect, there was no way to get anything done. So I tried again.

3. The third installation went like the first. After rebooting of course the black screen came back. As in the first case I followed the "Known Issues" instructions. Seeing that there was somehow no nvidia driver installed, I tried

Code: Select all

equo query installed nouveau
, which said that the nouveau driver version 1.0.16 was in fact installed. After an internet search I found a command to unblock the nouveau driver:

Code: Select all

# sed -i s/'blacklist nouveau'/'#blacklist nouveau'/ /etc/modprobe.d/blacklist.conf
After rebooting everything was fine.

I find this confusing, seeing that the "Known Issues" page says that the nvidia drivers will be installed by default. Anyway it's working, and I guess I'll stick with the nouveau drivers until I get more comfortable with Sabayon.
...alles ist fertig, es muss nur noch gemacht werden...

Post Reply