unable to launch steam [Solved]

A place where Linux Gamers can share their experience and help each other with Linux Games, native or emulated ;)

Moderator: Moderators

bookewyrmm
Simple Hen
Posts: 49
Joined: Wed Jan 10, 2007 17:25
Location: Out, standing, in a field

unable to launch steam [Solved]

Post by bookewyrmm » Mon Feb 15, 2016 19:13

The settings:
I am running from a simi fresh install dated 12/16/15, Kernel 4.3.0, KDE Plasma 5.5.4, All software is up to date per magneto and per

Code: Select all

sudo equo update
then

Code: Select all

sudo equo upgrade
from CLI

the only additional software I have installed has been what is necessary for web-dev hobby and home ofice use, (Filezilla, Libre-Office, Putty) and Yakuake.

Hardware:
Intel core2 Quad 2.4 Ghz
8 Gb Ram
Nvidia 730 w/ 2Gb Ram
1Tb Seagate Hybrid drive

The problem:

When I try to launch steam from either a desktop shortcut or from the Kmenu, it fails, if I try to uninstall or reinstall from the CLI I get an error that the package is not found. If I use Rigo package manager, to reinstall the Steam Launcher, or any other steam packages, I get an error that "cannot be installed at this time due to missing/masked dependencies or dependency conflict"

How can I locate the files that are missing/ masked or in conflict?
Last edited by bookewyrmm on Fri Feb 19, 2016 5:26, edited 1 time in total.

Stupot
Sagely Hen
Posts: 1680
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: unable to launch steam

Post by Stupot » Tue Feb 16, 2016 5:02

What entropy repo(s) do you have enabled? Sabayon-weekly?

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: unable to launch steam

Post by wolfden » Tue Feb 16, 2016 5:06

weird, how are you trying to install it?

Code: Select all

bikinibottom spin # equo i steam-launcher --ask
╠  @@ Calculating dependencies...
╠  @@ These are the packages that would be installed:
╠  ## [R] [sabayonlinux.org] games-util/steam-launcher-1.0.0.51|0   [1.0.0.51|0]
╠  @@ Packages needing to be installed/updated/downgraded: 1
╠  @@ Packages needing to be removed: 0
╠  @@ Packages needing to be installed: 0
╠  @@ Packages needing to be reinstalled: 1
╠  @@ Packages needing to be updated: 0
╠  @@ Packages needing to be downgraded: 0
╠  @@ Download size: 2.8MB
╠  @@ Freed disk space: 0.0b
╠  @@ You need at least: 5.5MB of free space
     Would you like to continue ? [Yes/No] No
what is the error if any when you try to launch steam from command line?

bookewyrmm
Simple Hen
Posts: 49
Joined: Wed Jan 10, 2007 17:25
Location: Out, standing, in a field

Re: unable to launch steam

Post by bookewyrmm » Wed Feb 17, 2016 4:00

First, Thanks for the help...

I have not changed the default repos from my 15.10 install base.

when I try to (re)install steam from a terminal:

Code: Select all

[email protected] ~ $ sudo equo install Steam
Password: 
☛  !!! No match for Steam in repositories.
╠    ? When you wrote Steam You Meant(tm) one of these below?
╠     # x11-misc/sddm:0
╠     # app-emacs/setnu:0
╠     # x11-wm/sithwm:0
╠     # app-crypt/stan:0
╠     # dev-haskell/stm:0
╠     # net-misc/stone:0
☢ No packages found.
When I try to run it from the terminal:

Code: Select all

[email protected] ~ $ steam
/home/user/.local/share/Steam/steam.sh: line 159: DISTRIB_RELEASE: unbound variable
/home/user/.local/share/Steam/steam.sh: line 159: DISTRIB_RELEASE: unbound variable
Running Steam on sabayon  64-bit
/home/user/.local/share/Steam/steam.sh: line 159: DISTRIB_RELEASE: unbound variable
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1454620878)
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
where it hangs untill I <ctrl+C> to halt

I tried
equo i steam-launcher --ask
and it did reinstall, but still will not launch, getting same error as above when started from CLI

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: unable to launch steam

Post by wolfden » Wed Feb 17, 2016 4:21

have you ran a

Code: Select all

equo deptest
?

bookewyrmm
Simple Hen
Posts: 49
Joined: Wed Jan 10, 2007 17:25
Location: Out, standing, in a field

Re: unable to launch steam

Post by bookewyrmm » Wed Feb 17, 2016 4:26

yes, it found 1 package,

Code: Select all

kde-apps/kde-l10n:5, 
and installed it, still no steam.

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: unable to launch steam

Post by wolfden » Wed Feb 17, 2016 4:29

also

Code: Select all

eselect opengl list
is it set to nvidia?

bookewyrmm
Simple Hen
Posts: 49
Joined: Wed Jan 10, 2007 17:25
Location: Out, standing, in a field

Re: unable to launch steam

Post by bookewyrmm » Wed Feb 17, 2016 4:31

I just checked the /home/user/.steam/steam/logs/ and found

Code: Select all

[2016-02-13 00:59:38] Downloading update (245,578 of 246,619 KB)...
[2016-02-13 00:59:39] Downloading update (246,345 of 246,619 KB)...
[2016-02-13 00:59:39] Downloading update (246,619 of 246,619 KB)...
[2016-02-13 00:59:39] Download Complete.
[2016-02-13 00:59:39] uninstalled manifest found in /home/user/.local/share/Steam/package/steam_client_ubuntu12 (1).
[2016-02-13 00:59:39] Extracting package...
[2016-02-13 00:59:51] Installing update...
[2016-02-13 00:59:52] Cleaning up...
[2016-02-13 00:59:52] Update complete, launching...
[2016-02-13 00:59:52] Shutdown


[2016-02-13 01:00:05] Startup - updater built Feb  4 2016 12:22:08


[2016-02-13 01:00:58] Startup - updater built Feb  4 2016 12:22:08


[2016-02-13 01:09:06] Startup - updater built Feb  4 2016 12:22:08


[2016-02-13 01:09:33] Startup - updater built Feb  4 2016 12:22:08


[2016-02-13 01:10:43] Startup - updater built Feb  4 2016 12:22:08


[2016-02-14 23:20:13] Startup - updater built Feb  4 2016 12:22:08


[2016-02-15 12:05:06] Startup - updater built Feb  4 2016 12:22:08


[2016-02-15 12:05:42] Startup - updater built Feb  4 2016 12:22:08


[2016-02-15 12:07:04] Startup - updater built Feb  4 2016 12:22:08


[2016-02-15 12:07:29] Startup - updater built Feb  4 2016 12:22:08


[2016-02-15 12:08:08] Startup - updater built Feb  4 2016 12:22:08


[2016-02-16 21:48:12] Startup - updater built Feb  4 2016 12:22:08


[2016-02-16 21:55:58] Startup - updater built Feb  4 2016 12:22:08


[2016-02-16 21:56:48] Startup - updater built Feb  4 2016 12:22:08


[2016-02-16 22:03:01] Startup - updater built Feb  4 2016 12:22:08


[2016-02-16 22:23:59] Startup - updater built Feb  4 2016 12:22:08
in the bootstrap log.txt

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: unable to launch steam

Post by wolfden » Wed Feb 17, 2016 4:48

I can't reproduce here. I started up steam here for first time and it did a large update and it loaded just fine. I'm running KDE with intel graphics.

check your opengl settings

eselect opengl list and make sure it has * by nvidia

bookewyrmm
Simple Hen
Posts: 49
Joined: Wed Jan 10, 2007 17:25
Location: Out, standing, in a field

Re: unable to launch steam

Post by bookewyrmm » Wed Feb 17, 2016 15:31

will do when I get home this evening, thanks again

Post Reply