Page 1 of 1

No sound on 0AD [Solved]

Posted: Wed Jun 17, 2015 16:14
by abufaris
Not sure if this has cropped up before; but I am getting no sound whatsoever in 0AD.

I am running Sabayon Linux amd64 15.06 with Linux sabayon 4.0.0-sabayon kernel.

0Ad version: version: 0.0.17_alpha installed via equo.

I have this nagging suspicion this may have something to do with OpenAL and/or Pulseaudio.

Everything else sound related works fine on the box, but not 0AD. No error messages appear to be being generated about this issue. Any advice would be gratefully received.

Re: No sound on 0AD

Posted: Thu Jun 18, 2015 3:45
by abufaris
But, hold there... having looked under /etc/portage/package.use/00-sabayon.package.use I notice under in the entry for 0AD that no sound USE flag is enabled.

Oh dear.

Re: No sound on 0AD

Posted: Fri Jun 19, 2015 0:08
by joost
https://github.com/Sabayon/build/commit ... 48910508e7

Should be fixed in the next revision update.

Re: No sound on 0AD

Posted: Sat Jun 20, 2015 13:33
by abufaris
Excellent work, joost - many thanks.

I have edited the first post to read SOLVED.