wine Multi Theft Auto - text with artifacts

A place where Linux Gamers can share their experience and help each other with Linux Games, native or emulated ;)

Moderator: Moderators

Post Reply
xpto
Baby Hen
Posts: 12
Joined: Tue Jul 09, 2013 0:52

wine Multi Theft Auto - text with artifacts

Post by xpto » Sun Aug 17, 2014 15:07

I'm using Sabayon Linux amd64 14.08 XFCE.
Some text on Multi Theft Auto - like chat text - have some artifacts that make it difficult to read.
Here are some shots:
Image

I have tried different wine versions - 1.4.1, 1.6.2 and 1.7.21is the current one.
I have played MTA on a Ubuntu based distro - Caixa Mágica - in this machine with wine 1.4.1 without text artifacts.
Also tried on fresh Installation of Sabayon Linux 14.08 XFCE and KDE but the same thing happens.

lscpi

Code: Select all

04:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV770 [Radeon HD 4850] [1002:9442] (prog-if 00 [VGA controller])
        Subsystem: Hightech Information System Ltd. Device [1787:2266]
        Flags: bus master, fast devsel, latency 0, IRQ 43
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Memory at febe0000 (64-bit, non-prefetchable) [size=64K]
        I/O ports at e000 [size=256]
        [virtual] Expansion ROM at feb00000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Legacy Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
        Kernel driver in use: radeon
        Kernel modules: radeon
uname
Linux pupu 3.12.0-sabayon #1 SMP Sat Aug 2 19:50:15 UTC 2014 x86_64 Intel(R) Core(TM)2 Quad CPU Q8200 @ 2.33GHz GenuineIntel GNU/Linux
It was long time ago, but I think text in this game was ok.
What could be causing this? How to fix this?

Post Reply